Jump to content

bell_rj

Members
  • Posts

    346
  • Joined

  • Last visited

About bell_rj

  • Birthday 01/01/2020

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. @Chapelmaggot I'm really pleased to see that you like those missions I created as it's great to know that others find them useful. And I'm glad you seem to have found a solution to your problem.
  2. So I might be barking up the wrong tree but how about using ASCII char : (decimal 58) and string.char? https://www.tutorialspoint.com/string-char-function-in-lua-programming Thanks @Bailey for the restart tip!
  3. My LUA experience totals about 3 days so this may not work but my guesses are: ExportScript.Tools.SendData(2010, string.format("%s%s%s%s", lDigitalClock.txtHours .. ":", lDigitalClock.txtMinutes, "\n" .. lDigitalClock.txtSeconds, "\n" .. lCET)) OR, what about adding another %s to get: ExportScript.Tools.SendData(2010, string.format("%s%s%s%s%s", lDigitalClock.txtHours, ":", lDigitalClock.txtMinutes, "\n" .. lDigitalClock.txtSeconds, "\n" .. lCET)) (I'm assuming adding another %s argument is valid).
  4. So, good news. I re-saved the original LUA from Github and now it works. That's not the first time I've tried that so I don't know what's going on. I did see some odd behaviour with the non-CW Spit where I had to save the LUA twice before it would work. No idea why. I suspected file corruption but didn't see any differences when doing a compare in Notepad++. Another quick question if I may, is there a way to force DCS to re-read the LUA file without restarting the game? If you plan on doing any further development to DCS interface then I have a suggestion. I am trying to make a tile that shows low, normal and high oil pressure. I have used text for now, but it would be great to have a version of Momentary Button with Lamp that allows 3 image states, so I could use both > and < conditions in the same DCS Interface element. One bug (I think) I noticed with Momentary Button/Display (UFC) is that though it allows setting a condition to show a second state image, it doesn't seem to allow setting what that image is, unlike Momentary Button with Lamp. And finally, thanks for all this. I'm really enjoying using Stream Deck with all these elements that you have created. It's brought an extra level of enjoyment to DCS world. I'm even enjoying the coding and tracking down issues when I mess it up.
  5. Thank you @Bailey! So I've made good progress getting to grips with the SpitfireLFMkIX LUA code (made a lot of mistakes haha) but I have created a new tile that returns oil pressure, temp, and rad temp and also highlights if they are low or high (I'd be pleased to share this if interested). I need a pointer though on the SpitfireLFMkIXCW LUA please. The DCS Comms function doesn't seem to be able to 'see' the CW variant. So I see the error 'DCS module not detected.' and obvioucly no IDs are therefore visible. The module name in the LUA looks ok. Is this to be expected? From looking at the DCS folder structure in \DCS World\CoreMods\WWII Units\SpitfireLFMkIX there isn't even a separate folder for the CW variant, so I wonder if DCS even thinks of this as a separate module. Have you ever seen DCS Comms connect to the CW variant? Thanks!
  6. @Bailey Good news, I got the Spitfire (non-CW) and Mossie working. Thanks for your help! There was a slight hiccup where most of the Spitfire 3xxx IDs weren't getting to DCS for some reason, but resaving the LUA and a DCS restart fixed that. Just wanted to ask about the Spitfire CW. I noticed the LUA is missing most of the code that the non-CW script has in it. Just wondered if there was a reason for it before I tried copying across the functions and probably making a mess of it, haha.
  7. @Bailey Ahhhh so that's what I missed. Thank you very much! I can't wait to get this working.
  8. Hi, I hope someone can help me with this issue. I've got Stream Deck, have installed the DCS-ExportScript and the DCS Interface plugin, and have successfully established comms between DCS and the deck. For example I can see the altitude readout using DCS ID "28", so that's all good. I read the wiki and saw a list of tiles including an altimeter tile (ID "3004"). (https://github.com/asherao/DCS-ExportScripts/wiki/Spitfire-LF-MkIX) but I can't work out how to get the tiles to display. I've tried referencing the ID with no joy, unsurprisingly because when I check ID Lookup there is no such thing. I suspect I'm misunderstanding how the tiles are meant to work. Can someone help please?
  9. Ohhh. The newsletter could have been clearer on that matter. When it listed out all the jets that would get the new FLIR, I didn't pick up that those were only ED jets. I doubt I'll be the only one to miss that. It would be better to spell things out in the newsletter rather than miss important points. (edit: I get that it'll come to third party jets eventually but the timing sounds like it may be quite different).
  10. This is a very good point. And if ED can make the cow 'moo' whilst being flown along I'm just gonna be in stitches and repeatedly pressing F3 for the slingloaded cow fly-by view. "moooooooooooooooooooooooooo!"
  11. Well obviously it's flying cows. Why do you even need to ask?
  12. I have similar feelings to many in this thread. I'm seeing a slightly different issue as well, when taking off the aircraft wants to pitch up massively. I also see this in flight when at about 180mph (with a light load). I believe I have appropriate trim set prior to take off roll commencing so I'm not quite sure what is going on, or if it's just my piloting? It wasn't like this at first release. Edit: Please ignore the above, it was due to a badly behaving hotas button making the elevator trim go to max nose up.
  13. @Hawkeye60So I did some more testing and hands up, I made a mistake in installing the mods - there's no problem with the mods working. I had accidentally copied the whole structure of the mod files under tech. Many apologies! So I can now place all the units and they look great. The aerial torpedoes issue is real though - I re-tested the Algerie and also tested the Le Malin and Richelieu - and the torps pass under or through. However the torpedoes did impact the Dunkerque - 100% hits every time. So it's just the other ships where they fail. So at least I can make a mission where the bombers target the Dunkerque, and have other ships as escort but not targets for torpedoes. And the only other thing I noticed is that cannon/mg fire from FW190s seems to pass through the Algerie and Dunkerque (didn't get a chance to test that on other ships) and impact the water without causing any damage (as seen in the map unit view). Not sure if this is a DCS limitation and I suppose damage would be relatively minor, but the AI will do strafing runs after dropping bombs. They miss by a mile with the bombs but the strafing runs are on target.
  14. Great, thank you very much. Please let me know if I can help with any testing on the torpedo issue. It's odd that I can't select the units to place them in the ME. They just don't appear in any country list - and certainly not France. While the Algerie appears in many country lists. I've put each unit in its own subfolder under \mods\tech - that's correct, right? I also have the DKM naval squadron and Bismarck mods installed - they do appear as expected. I'll try removing those to see if there is a conflict.
  15. Hi, Firstly thanks for your work on these mods. I need some help please. I downloaded and installed the Algerie, Dunkerque, Richelieu, and Le Malin (in latest DCS beta) and put them all in their own subfolder in \Saved Games\DCS\Mods\tech but only the Algerie appears as a placeable unit in the ME. Is this a bug or am I doing something wrong? Aerial torpedos dropped from a JU88 run right under or through the Algerie. Is that expected? AA fire works really well so I enjoyed watching the JU88s get shot down. Thanks!
×
×
  • Create New...