Jump to content

HOTAS Cougar Error 2 back from the dead


Prophet
 Share

Recommended Posts

Been having this problem for a while. Pretty much gave up on the stupid thing, but this Mig-21 interested me, since Cobra was so gracious to donate the key I won.

 

But I just couldn't get by this Error 2 when opening the CCP. Couldn't read/write from the device, if I could manage to get the Firmware updater open without error, it wouldn't recognize the trigger pull to erase it.

 

Obviously either a permanent defect, or bad firmware. Its a Cougar, lets go with firmware. This problem is much to the same as what Cali had with 2. http://forums.eagle.ru/showthread.php?t=61124&highlight=Cougar

 

What caught my eye this time was what hollywood villian said.

 

"If anybody else is still having this problem I think I might have figured out the solution. The key for everything to work is having the firmware in the controller already flashed BEFORE you plug it into windows7 x64. I myself had to use another PC with windows XP 32bit just to flash it, and btw, at first it didn't work in XP 32bit AT ALL either, but it did allow me run the HOTAS cougar update, and then it magically seemed to come alive. After that i just plugged it into the win7 machine and it seems so far to be working perfectly."

 

I created and booted from BartPE. I installed the drivers. Ran the Firmware updater no problem, and here I am back in Win 8 working like a charm.

 

If you got problems, it appears that sometimes only a 32bit system will do.

 

P.S. I tried XP mode and other virtualizations and it wouldn't read/write either. Also keep this in mind. "Up-date I have solved my problem! It was very easy and maybe a little bit stupid of me but, all new motherboards come with the new USB 3.0 plug's and that was the problem!

The Cougar isn't USB 3.0 compatible!"


Edited by =Prophet=
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...