Jump to content

Totaly Confused (Thrustmaster Warthog)


dbunger
 Share

Recommended Posts

I have a Thrusmaster Warthog HOTAS. I have not loaded any of the Thrustmaster software. The controller is recognized in Windows. The controller works fine in all mission(so far)except "Aircraft Startup" training mission. I can see all the buttons I press, switch or toggle move, but I get no throttle movement at all. When I push the stick forward it goes right and acts very slowly. Any help would be appreciated.

 

Thx

EVGA X99 FTW, EVGA 3080 FTW, Intel Core i7-5820K Haswell-E 6-Core 3.3 GHz, G.SKILL Ripjaws 4 Series 64GB (4x16GB), CORSAIR Hydro Series H105, EVGA 750 Gold PS, Oculus Rift, TM F-16, A-10C HOTAS.

Link to comment
Share on other sites

Enter the controls settings and redefine the according axis. All of them.

 

^ That...

 

You probably have some conflicting axis assignment. Go into control options and select A10C Sim commands, go into Axis assignments, clear everything assigned to your pitch, roll, rudder and left/right throttle and start again. Should only take about 2-3 minutes to do so.

Link to comment
Share on other sites

Nope. this is what I did.

Enter Settings/Aircraft A10C Real/Axis Commands

Cleared everything assigned to your pitch, roll, rudder and left/right throttle

Selected Left Throttle, Highlighted "Throttle HOTAS Warthog" field. Clicked "Default" it entered JOY_RZ

Did the same for Right, Default entered JOY_Z

 

Just doing the throttle mind you.

 

Went back in game, Training/A10C/A10C Familiarization/

Lesson "HOTAS Fundamentals"

 

Start sim, throttle works fine.

 

 

Quit, Select Aircraft Operation/Aircraft Start-up

start sim, no throttle.

 

Is there something about aircraft start-up that would prevent the throttle and stick not to function?


Edited by dbunger

EVGA X99 FTW, EVGA 3080 FTW, Intel Core i7-5820K Haswell-E 6-Core 3.3 GHz, G.SKILL Ripjaws 4 Series 64GB (4x16GB), CORSAIR Hydro Series H105, EVGA 750 Gold PS, Oculus Rift, TM F-16, A-10C HOTAS.

Link to comment
Share on other sites

Also a lot of folks have to cycle the throttle to get it to go into the start up cycle. Specifically, your throttles are below the detent (off). You grab the one you want to start, pull it up and over the detent to idle. Nothing happens. You put it back to off then back to idle again and the engine goes into the start sequence. I'm not sure why but I have to do this every time I start the plane. I'm not sure if that is your problem but if you are just having an issue with the engine starts that may be it.

http://www.youtube.com/user/311Gryphon

i7-8700, 32 GB DDR4 3000, GTX 1080 TI 11GB, 240 GB SSD, 2TB HDD, Dual (sometimes Triple) monitor, TM Warthog HOTAS, Saitek Pro Combat Pedals, TrackIR

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Ok guys, that worked! Thx for helping out this noob. I still can't find this tho:

 

Make sure to check the Hotas Sync at mission start in the options

Any help here?

 

Again thx for the help!

EVGA X99 FTW, EVGA 3080 FTW, Intel Core i7-5820K Haswell-E 6-Core 3.3 GHz, G.SKILL Ripjaws 4 Series 64GB (4x16GB), CORSAIR Hydro Series H105, EVGA 750 Gold PS, Oculus Rift, TM F-16, A-10C HOTAS.

Link to comment
Share on other sites

Still having issues with the stick, throttle working fine now.

 

Same problem with stick, works fine in all but in "Aircraft Start-up". Will check the "HOTAS Sync at mission start" when I get home tonight.

EVGA X99 FTW, EVGA 3080 FTW, Intel Core i7-5820K Haswell-E 6-Core 3.3 GHz, G.SKILL Ripjaws 4 Series 64GB (4x16GB), CORSAIR Hydro Series H105, EVGA 750 Gold PS, Oculus Rift, TM F-16, A-10C HOTAS.

Link to comment
Share on other sites

The Sync cockpit controls with HOTAS, I believe is unreliable.

 

I've unchecked sync. For a cold start the most reliable way to "wake up" the cockpit with the throttle is have them at idle then slide back to off to initiate the sync. The same goes for flaps and other toggles on the throttle.

 

28rd3xe.jpg


Edited by Gunny Huntarr
  • Like 1

[sIGPIC][/sIGPIC]

SysSpecs:

Display= 4K 55" UHD JU6700 Series Curved Samsung

Processor= Intel64 i7-5820K CPU @ 3.30GHz

RAM= 16 GB Ripjaws 4 series DDR4 2400 MHz

GPU= NVIDIA GeForce MSI GTX 980 OCV1 1152MHz Core 4GB GDDR5 Memory

Storage= 128GB Apotop S3C SSD

Storage= 2TB Toshiba DT01ACA200 HDD

OS= Win 10

Peripheral= TrackIR5 w/ TrackClip PRO

Controller= Thrustmaster HOTAS WARTHOG™ USAF Replica :joystick:

 

Link to comment
Share on other sites

Still having issues with the stick, throttle working fine now.

 

Same problem with stick, works fine in all but in "Aircraft Start-up". Will check the "HOTAS Sync at mission start" when I get home tonight.

 

If it happens only in that mission I'd also start looking at what you're doing in the actual ingame cockpit...

­­­­­­

Link to comment
Share on other sites

Still having issues with the stick, throttle working fine now.

 

Same problem with stick, works fine in all but in "Aircraft Start-up". Will check the "HOTAS Sync at mission start" when I get home tonight.

 

I'm not sure, but I think you need hydraulic pressure from the engines before the stick will move in a cold start.

System specs:

 

Gigabyte Aorus Master, i7 9700K@std, GTX 1080TI OC, 32 GB 3000 MHz RAM, NVMe M.2 SSD, Oculus Quest VR (2x1600x1440)

Warthog HOTAS w/150mm extension, Slaw pedals, Gametrix Jetseat, TrackIR for monitor use

 

Link to comment
Share on other sites

If the stick only moves up and down at cold start and not to the left and right: This is NORMAL!

 

airelons are controlled by hydraulics. If the craft is fully running with generators etc then the stick will be able to travel to left and right in game.

 

If you still have joystick problems: go to profile page and tune axis. Check to see if the joystick moves the full range. same with throttle. if all works in tuning page then all is well and you just need to start the plane in the correct manner.

 

ie. have throttle in idle off and when apu at 100 percent and apu generator on lift throttle left from off position to idle. Don't lift both throttles at the same time. Wait till left engine spools up completely. so unlock your throttle.

 

when both left and right engine generators are fully generating power, your stick should act correctly.

Link to comment
Share on other sites

I've unchecked sync. For a cold start the most reliable way to "wake up" the cockpit with the throttle is have them at idle then slide back to off to initiate the sync. The same goes for flaps and other toggles on the throttle.

 

Couldn't agree more! This has become my SOP, as it's the most reliable way I've found so far, and it works all the time.

 

Regarding the original problem: OP, can you load the training mission via the "Mission" main menu and then, once the problem occurred, quit the mission, save the track and upload it here (with a description of what happened and what should have happened)?

  • Like 1
Link to comment
Share on other sites

Alright guys got it working! The throttle was this:

 

"Also a lot of folks have to cycle the throttle to get it to go into the start up cycle. Specifically, your throttles are below the detent (off). You grab the one you want to start, pull it up and over the detent to idle. Nothing happens. You put it back to off then back to idle again and the engine goes into the start sequence. I'm not sure why but I have to do this every time I start the plane. I'm not sure if that is your problem but if you are just having an issue with the engine starts that may be it."

 

And the stick was this:

 

I'm not sure, but I think you need hydraulic pressure from the engines before the stick will move in a cold start.

 

Again, thx to all of you for the help! I have a feeling I'm in for a long ride :)

EVGA X99 FTW, EVGA 3080 FTW, Intel Core i7-5820K Haswell-E 6-Core 3.3 GHz, G.SKILL Ripjaws 4 Series 64GB (4x16GB), CORSAIR Hydro Series H105, EVGA 750 Gold PS, Oculus Rift, TM F-16, A-10C HOTAS.

Link to comment
Share on other sites

Alright guys got it working! The throttle was this:

 

"Also a lot of folks have to cycle the throttle to get it to go into the start up cycle. Specifically, your throttles are below the detent (off). You grab the one you want to start, pull it up and over the detent to idle. Nothing happens. You put it back to off then back to idle again and the engine goes into the start sequence. I'm not sure why but I have to do this every time I start the plane. I'm not sure if that is your problem but if you are just having an issue with the engine starts that may be it."

It's because the position of OFF on the throttle is a button press and transitions from Idle to Max is an Axis. You can see this using the windows Game Controller Settings.

 

And the stick was this:

 

I'm not sure, but I think you need hydraulic pressure from the engines before the stick will move in a cold start.

 

Again, thx to all of you for the help! I have a feeling I'm in for a long ride :)

Yes the stick is dead :joystick:until Hydraulic pressure is reached.

 

Stick with it, This Study Sim is absolutely addictive.

 

10wjrlv.jpg

  • Like 1

[sIGPIC][/sIGPIC]

SysSpecs:

Display= 4K 55" UHD JU6700 Series Curved Samsung

Processor= Intel64 i7-5820K CPU @ 3.30GHz

RAM= 16 GB Ripjaws 4 series DDR4 2400 MHz

GPU= NVIDIA GeForce MSI GTX 980 OCV1 1152MHz Core 4GB GDDR5 Memory

Storage= 128GB Apotop S3C SSD

Storage= 2TB Toshiba DT01ACA200 HDD

OS= Win 10

Peripheral= TrackIR5 w/ TrackClip PRO

Controller= Thrustmaster HOTAS WARTHOG™ USAF Replica :joystick:

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...