Jump to content

Does your GPU almost burst into flame when you run modelviewer


vicx
 Share

Recommended Posts

Modelviewer on my PC runs at 240+ fps and makes my GPU run at 100% and the GPU fan ramps up to very high speed and the noise it makes is ridiculous. I don't need that all noise when I just want to check some stuff in the modelviewer.

 

Nvidia actually had a frame-rate limiter built into the driver interface but at some point it got removed. However today I got so sick of the fan noise that I went looking for, and found, a tool that restores the framerate limiter setting. Nvidia Inspector lets you limit the framerate in lots of different ways but I just lock it to 60. Screenshot shows how to set the right value and how that locks the framerate in modelviewer and stops the GPU working so hard.

 

1u8gBoS.jpg

Link to comment
Share on other sites

*EDIT* I'm using the standalone modelviewer and I think it does things a little differently. I don't know why maxfps isn't working but I've decided to look into it sometime in the future when I am in the mood to play with Lua.


Edited by vicx
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

Might be easier to make a ModelViewer.exe profile for your drivers and limit the FPS there.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, R7970 Lightning @ 1.2 / 6 GHz Memory

3x ASUS VS248HP + Oculus HMD, Thrustmaster Warthog HOTAS + MFDs

Link to comment
Share on other sites

  • 2 weeks later...

Hi, I use ingame modelviewer and I cant limit its FPS. Limiting by graphic card profile doesnt work for me (R9 380, Crimson edition drivers). There is a file graphic_readme.txt in Config folder in the game, the most important:

 

New method to overdrive settings for game and modelviewer:

 

"C:\Users\<YOUR-LOGIN>\Saved Games\edModelViewer\Config\autoexec.cfg" (create if not present)

 

"options.graphics.maxfps = 30" (example line to copy into the autoexec.cfg)

 

 

This also doesnt work for me, BUT model viewer keeps creating file ModelViewer.cfg in C:\Users\<YOUR-LOGIN>\Saved Games\DCS\Config\

 

Is there any way to limit fps using the old method? Any other suggestions? Thanks

My skins on DCS User Files, Enjoy!

________________________________

FC3, Mi-8, UH-1, CA, L-39, AV-8B, F-14

Link to comment
Share on other sites

There shoild be a LUA in the main DCS Folder.

 

/DCS World/Config/ModelViewer/autoexec.lua

 

 

Saved Games Model viewer is mainly positi9ns of dialog boxes, render resolution, etc.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, R7970 Lightning @ 1.2 / 6 GHz Memory

3x ASUS VS248HP + Oculus HMD, Thrustmaster Warthog HOTAS + MFDs

Link to comment
Share on other sites

There shoild be a LUA in the main DCS Folder.

 

/DCS World/Config/ModelViewer/autoexec.lua

 

 

Saved Games Model viewer is mainly positi9ns of dialog boxes, render resolution, etc.

 

it tells nothing about the fps option

[sIGPIC][/sIGPIC]

My DCS Mods, Skins, Utilities and Scripts

 

| Windows 10 | i7-4790K | GTX 980Ti Hybrid | 32GB RAM | 3TB SSD |

| TM Warthog Stick | CH Pro Throttle + Pro Pedal | TIR5 Pro | TM MFD Cougar | Gun Camera: PrtScn |

Link to comment
Share on other sites

Do we add:

 

options.graphics.maxfps = 60

 

To the file in Eagle Dynamics\DCS World\Config\ModelViewer ?

 

Edit:

 

Another quick question. In V1.2 I used to be able to simply reload the model and select a skin to view new versions without having to exit the Model Viewer program. Ever since V1.5, I must exit it every time I want to see changes. Makes things take a lot longer. Is there a workaround for this?


Edited by Flogger23m
Link to comment
Share on other sites

I dont think it has a FPS command for Model Viewer.

 

the Autoexec.lua was mainly loading textures, 3D models etc on startup.

 

Easiest option is to make a ModelViewer.exe profile in nVidia or AMD driver panel and define FPS limiter to limit to whatever FPS.

 

I actually still use the 1.2 Model Viewer for alignment tweaking, or I make a mission in DCS and start, pause, look at model, make changes, exit mission, make changes, re launch mission.


Edited by SkateZilla

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, R7970 Lightning @ 1.2 / 6 GHz Memory

3x ASUS VS248HP + Oculus HMD, Thrustmaster Warthog HOTAS + MFDs

Link to comment
Share on other sites

Well the walkaround with profile in AMD driver doesnt work for me and I like to use ModelViewer since I can easily look at any place on skin and it always took only to reload the model to see recent changes.

 

And this (graphics_readme.txt in Config group) doesnt work for me either (a bit long text, I put it in spoiler):

 

 

Hi!

 

Old graphics.cfg is gone and replaced with graphics.lua.

However, please, do not edit this file directly.

Otherwise you'll lose your changes after each update.

 

New method for overriding options is to create (or edit) a file

 

C:\Users\<YOUR-LOGIN>\Saved Games\DCS\Config\autoexec.cfg

 

or

 

C:\Users\<YOUR-LOGIN>\Saved Games\edModelViewer\Config\autoexec.cfg

 

(for model viewer)

 

and place your changes there.

Note:

- autoexec.cfg settings will override the options set via GUI.

- Graphic options in autoexec.cfg should be prefixed with options.graphics.

- file encoding should be UTF-8 without BOM

 

Example autoexec.cfg:

 

options.graphics.maxfps = 30

options.graphics.render3D = false

options.graphics.ScreenshotQuality = 75

-- add custom texture path

-- note the slashes!

table.insert(options.graphics.VFSTexturePaths, "c:/Users/<LOGIN>/Saved Games/DCS/MyTextures")

 

 

 

Happy gaming!

 

dsb at eagle dot ru

 

 

I would really appreciate to get these things working.

My skins on DCS User Files, Enjoy!

________________________________

FC3, Mi-8, UH-1, CA, L-39, AV-8B, F-14

Link to comment
Share on other sites

I actually still use the 1.2 Model Viewer for alignment tweaking, or I make a mission in DCS and start, pause, look at model, make changes, exit mission, make changes, re launch mission.

 

Is it possible to use it with V 1.5? My version seemed to have been updated automatically when 1.5 was released.

Link to comment
Share on other sites

I still have my 1.2 dcs install on a separate drive.

 

I have afterwork stuff to do today, I'll look at some things and try to get something together.

 

The reload model not reloadi g textures was one of the first things I noticed, which is why I was simply launching DCS 1.5 with aircraft and skin, noting any changes, quit mission and then click the button to try again on debrief, less than 1 second loading time here on normal HDD.

 

also quicker than re load, and having to scroll and look for livery.

 

plus I can see how it looks in actual DCS, as model viewer still looks a bit different.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, R7970 Lightning @ 1.2 / 6 GHz Memory

3x ASUS VS248HP + Oculus HMD, Thrustmaster Warthog HOTAS + MFDs

Link to comment
Share on other sites

I used to do that method myself, but with V1.5 I can't seem to minimize DCS more than once (Win 7). V1.2 I could readily minimize any time I wanted.

 

The real annoying thing for me is that model viewer starts minimized every other time, so I must open task manager to maximize it and even then it will only appear a quarter of the size. So I must exit and reload it a 2nd time in which it will be full screen. Makes viewing small changes take so much longer.

 

With any luck, the program will be updated a bit in the future.

Link to comment
Share on other sites

mine opens off the screen sometimes.

 

Gotta hit WinKey UP, DOWN, LFT , or RGT.

 

I just Alt Tab, from DCS back to desktop/photoshop.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, R7970 Lightning @ 1.2 / 6 GHz Memory

3x ASUS VS248HP + Oculus HMD, Thrustmaster Warthog HOTAS + MFDs

Link to comment
Share on other sites

  • 1 year later...

I have this problem as well, I put autoexec FPS limits on both the DCS and ModelViewer folders, and it's working at 300 FPS when a model is loded, it's going 1800 FPS when modelviewer is empty.

 

I'll see if I can limit with my GPU Drivers.

 

EDIT: Nope Target Frame Rate Control doesn't work, with my latest Crimson drivers on RX 480

 

It's not compatible so much with windowed stuff, more works with fullscreen. And I'm still on windows 7.


Edited by Worrazen

1st.: PC Specs: Win10P 2004 (20H1), 1440p@75"32 - MB: Asus ROG Strix X-570E - CPU: AMD Ryzen 5 PRO 4650G - GPU: AMD Radeon RX480 - RAM: 64 GB - SSD: Samsung 970 EVO Plus 1TB NVMe

2nd.: PC Specs: Win10P 2004 (20H1), 1440p@75"32 - MB: Asus P9X79 - CPU: Intel i7 3820 - RAM: 32GB - GPU: AMD Radeon RX480 8GB - SSD Samsung 870 EVO 250GB (DCS), Input: Saitek Cyborg X/FLY5

Modules: A-10C I/II, F/A-18C, Mig-21Bis, M-2000C, AJS-37, Spitfire LF Mk. IX, P-47, FC3, SC, CA, WW2AP, CE2.

Terrains: NTTR, Normandy, Persian Gulf, Syria.

Link to comment
Share on other sites

I have brought this up, hopefully an answer is given as to correct format to limit FPS and other settings.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, R7970 Lightning @ 1.2 / 6 GHz Memory

3x ASUS VS248HP + Oculus HMD, Thrustmaster Warthog HOTAS + MFDs

Link to comment
Share on other sites

  • 3 months later...

Hi, I was experimenting recently:

 

"C:\Users\<YOUR-LOGIN>\Saved Games\edModelViewer\Config\autoexec.cfg" (create if not present)

 

insert line:

"options.graphics.sync = true"

 

This seems to reduce the frame rate in model viewer to 136. It is more than needed for skin making, but It seems to be working both with loaded model and clear opened modelviewer. I will more test it later.

 

New problem:

 

How to reload textures in model viewer?

 

It used to work so that reloading model flushed textures and enabled loading them again (when the file was edited and saved meanwhile). Now I need to shut down MV and start it again.


Edited by Dyk

My skins on DCS User Files, Enjoy!

________________________________

FC3, Mi-8, UH-1, CA, L-39, AV-8B, F-14

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...