Jump to content

micro stutters


theropod
 Share

Recommended Posts

Try setting the GPU at a normal clock speed. Over clocking has had issue with the software in earlier releases. Worth a check in this one.

This was a Boutique Builder iBuypower rig. Until I got the tinker bug again i7 920 @3.6Mhz 12Gig Corsair XMS3 ram 1600 Nvidia 760 SLi w/4Gig DDR5 Ram Intel 310 SSD HDD 160 Gb + Western Digital 4Terabyte HDD Creative SB X-Fi HD Audio Logitech X-530 5.1 Surround Speaker System Dual Acer 32"Monitors. PSU 1200 w Thermaltake Win10 64Bit.

Link to comment
Share on other sites

Since the 1.5 release, I am finally able to play DCS with my 2012 Macbook Pro, via Windows 10 on my BOOTCAMP partition. I got totally amazing FPS but inexplicable stutter that made the sim unplayable even with very high fps. The problem went away ENTIRELY simply by running the game in Windowed mode (i.e unticking Run in Fullscreen)

Hope that helps.

Amazed by the incredible performance boost with the new 1.5 engine. Thank you ED

 

Martin :)

Link to comment
Share on other sites

Some people are experiencing the opposite video problem as well. It seems for some, no matter if you have the full screen check box checked or not, the game is running windowed.

 

You can hit R-ALT + ENTER to change it in game. For some this stops the stutters and tearing.

Link to comment
Share on other sites

With two Titan X's in SLI with vsync disabled/gsync enabled, and alt+Enter, I'm indicating 60 FPS; however I'm getting noticable lack of smoothness/micro stutters when looking at terrain. Its almost 'FSX like'. Definitely not as smooth as pre 1.5 Open beta

Asus ROG Maximus X Apex

Core I7 8700K @ 5.3Ghz / Liquid cooled (Kraken X62)

32GB DDR4 RAM 3200ghz

EVGA RTX 2080 Ti XC

Acer X5280HK G-SYNC 4K Monitor

ASUS Essence STX II Sound Card

Samsung 960 Pro M.2 PCI-E SSD 2TB

Windows 10 Professional 64

Latest drivers

Link to comment
Share on other sites

Try setting the GPU at a normal clock speed. Over clocking has had issue with the software in earlier releases. Worth a check in this one.

 

Some people are experiencing the opposite video problem as well. It seems for some, no matter if you have the full screen check box checked or not, the game is running windowed.

 

You can hit R-ALT + ENTER to change it in game. For some this stops the stutters and tearing.

 

thank you mates:)

 

atalia1, thank you for your advice,but i dont use overclock,it is on default speed.

weird thing is my fps didnt decreased under 40 on any area on the map.

i noticed that the batum is the worst place on my test.but my fps is high enough like 60- 120.

i tested with msaa off but even though my increased fps ,stutter is still occurs.

as paganus's advice ,i tried r-alt enter but nothing changed:(

Link to comment
Share on other sites

60 Hz monitor lol

Asus ROG Maximus X Apex

Core I7 8700K @ 5.3Ghz / Liquid cooled (Kraken X62)

32GB DDR4 RAM 3200ghz

EVGA RTX 2080 Ti XC

Acer X5280HK G-SYNC 4K Monitor

ASUS Essence STX II Sound Card

Samsung 960 Pro M.2 PCI-E SSD 2TB

Windows 10 Professional 64

Latest drivers

Link to comment
Share on other sites

  • ED Team

I used to get micro stutter due to tacview which I was using, it was writing to a second mechanical drive instead of my SSD, when I changed it my micro stutter went.

 

Just a thought for people who export stuff via the scripts folder in C:\Users\yourname\Saved Games\DCS.openbeta\Scripts

 

might be worth checking if you are, to eliminate that as a cause. If you are not ignore :)

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 64GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

I'm very finicky about touching or playing with my GPU. I think I'll wait for update 3 to see.

 

My stutters are not that severe and only happen when slapping zoom view axis instead of incrementally moving it.

AWAITING ED NEW DAMAGE MODEL IMPLEMENTATION FOR WW2 BIRDS

 

Fat T is above, thin T is below. Long T is faster, Short T is slower. Open triangle is AWACS, closed triangle is your own sensors. Double dash is friendly, Single dash is enemy. Circle is friendly. Strobe is jammer. Strobe to dash is under 35 km. HDD is 7 times range key. Radar to 160 km, IRST to 10 km. Stay low, but never slow.

Link to comment
Share on other sites

60 Hz monitor lol

 

 

 

Careful your intellect is showing.

This was a Boutique Builder iBuypower rig. Until I got the tinker bug again i7 920 @3.6Mhz 12Gig Corsair XMS3 ram 1600 Nvidia 760 SLi w/4Gig DDR5 Ram Intel 310 SSD HDD 160 Gb + Western Digital 4Terabyte HDD Creative SB X-Fi HD Audio Logitech X-530 5.1 Surround Speaker System Dual Acer 32"Monitors. PSU 1200 w Thermaltake Win10 64Bit.

Link to comment
Share on other sites

With two Titan X's in SLI with vsync disabled/gsync enabled, and alt+Enter, I'm indicating 60 FPS; however I'm getting noticable lack of smoothness/micro stutters when looking at terrain. Its almost 'FSX like'. Definitely not as smooth as pre 1.5 Open beta

 

Titan SLI, 4.9GHz and 8GB ????

 

 

weakest link in chain ? ever heard of that ?

 

It's like a Ferrari on 155/14 wheels, nothing goes...

Gigabyte Aorus X570S Master - Ryzen 5900X - Gskill 64GB 3200/CL14@3600/CL14 - Asus 1080ti EK-waterblock - 3x 980Pro 1TB - 1x Samsung 870 Evo 1TB - 1x SanDisc 120GB SSD - Heatkiller IV - MoRa3-360LT@9x120mm Noctua F12 - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win11 Pro/Linux - Phanteks Evolv-X 

Link to comment
Share on other sites

  • 2 weeks later...

A little tip that can possibly greatly reduce/remove stutters, and provide extremely smooth flying:

cro_mig_21 posted a tip about forcing Windows 7/8/10 to use the HPET timer exclusively.

 

For me it all but removed all stutters.

I got as smooth flying as I have never seen it before.

Only have a few "hick-ups" now and then, but much less than earlier.

(I also use "Left Alt-Enter" to force full screen mode.)

 

I am running windows 7 64 bit with 8 GB RAM and a GTX 670 GPU. CPU is a i7 2600K OC to 4.4 GHz max.

Running DCS 1.5 with max settings on everything, 8xQ AA and 8x anisotropic. 1920x1200 monitor.

 

Explanation:

Apparently Windows has three different timers that it uses by default: TSC, LAPIC and HPET, all with different clock speeds.

By default, Windows uses a combination of all three if HPET is enabled in BIOS, otherwise the other two alone.

 

It seems that, when using all three, Windows tries to constantly synchronize between them, leading to stutters.

If Windows is forced to only use HPET, the timers are in better sync, and everything seems to flow better inside DCS at least.

 

People are reporting differing results in other forums/games, some even having better results disabling HPET in BIOS instead.

But we are now 4 users in the "Flying near trees causes great fps loss" thread that has had good results forcing the HPET timer for Windows.

 

As I see it, it could be worth a try.

 

Force Windows to use the HPET timer:

1. Make sure that the HPET timer is enabled in BIOS (often on by default).

2. Open the command prompt, write "bcdedit /set useplatformclock true" and then reboot.

 

Restore default timer setup in Windows:

1. Open the command prompt, write "bcdedit /deletevalue useplatformclock" and then reboot.

2. Set the HPET timer as desired in BIOS.

 

Caveat:

One user reported problems with having to reactivate his Mig 21 module, but I think it is maybe because he had to enable the HPET timer in BIOS first.

Apparently that can be seen by DCS as a HW change.

I had no such problems myself.

 

Links to descriptions of the timers and discussions of different results:

http://www.neowin.net/forum/topic/1075781-tweak-enable-hpet-in-bios-and-os-for-better-performance-and-fps/

 

http://www.overclock.net/t/1487105/want-higher-fps-what-timer-do-you-use#post_2220916

 

And of course Google if you want more information. :)

  • Like 1

System specs:

 

Gigabyte Aorus Master, i7 9700K@std, GTX 1080TI OC, 32 GB 3000 MHz RAM, NVMe M.2 SSD, Oculus Quest VR (2x1600x1440)

Warthog HOTAS w/150mm extension, Slaw pedals, Gametrix Jetseat, TrackIR for monitor use

 

Link to comment
Share on other sites

I tried the bcdedit and I really didn't see much difference.

 

I'll check my BIOS setting later.

 

hsb

hsb

HW Spec in Spoiler

---

 

i7-10700K Direct-To-Die/OC'ed to 5.1GHz, MSI Z490 MB, 32GB DDR4 3200MHz, EVGA 2080 Ti FTW3, NVMe+SSD, Win 10 x64 Pro, MFG, Warthog, TM MFDs, Komodo Huey set, Rverbe G1

 

Link to comment
Share on other sites

Did it really do a job ?

 

I tried the bcdedit and I really didn't see much difference.

 

I'll check my BIOS setting later.

 

hsb

 

As I said, your results may vary.

That's why you need to test it for yourself.

 

For me it did a huge difference, however not so much in the number of FPS.

 

It is more that the sim now have a very fluid motion to it, so that it feels more like a movie and more importantly: Some heavy stutters I usually had every time I was shooting or zooming in are all but gone.

 

The fluid motion also does that I can see the results of my controls movements much better and faster, like it should be.


Edited by Sporg

System specs:

 

Gigabyte Aorus Master, i7 9700K@std, GTX 1080TI OC, 32 GB 3000 MHz RAM, NVMe M.2 SSD, Oculus Quest VR (2x1600x1440)

Warthog HOTAS w/150mm extension, Slaw pedals, Gametrix Jetseat, TrackIR for monitor use

 

Link to comment
Share on other sites

since last update is unstable mig 21 fps = /

back to update 2 :(

 

+1 :mad:

[sIGPIC][/sIGPIC]

System specs: CPU: i7-9700K@ 5.0 GHz | RAM: 32 GB | GPU: RTX 2080 Super | Thrustmaster HOTAS Warthog | CH Products Pro Pedals |HP REverb

Link to comment
Share on other sites

....

 

Caveat:

One user reported problems with having to reactivate his Mig 21 module, but I think it is maybe because he had to enable the HPET timer in BIOS first.

Apparently that can be seen by DCS as a HW change.

I had no such problems myself.

 

Links to descriptions of the timers and discussions of different results:

http://www.neowin.net/forum/topic/1075781-tweak-enable-hpet-in-bios-and-os-for-better-performance-and-fps/

 

http://www.overclock.net/t/1487105/want-higher-fps-what-timer-do-you-use#post_2220916

 

And of course Google if you want more information. :)

 

 

 

The guy with the lic problem on the MiG-21 was me, but I DEACTIVATED HPET everywhere, NOT ACTIVATED it !!!

 

From my personal experience I say it boosted my Win10 startup a bit, didnt harm DCS ( was OK before with Gsync ) but overall more snappy I`d say.

 

So there are 2 guys with 2 good results, one switched it OFF, the other one switched it ON, HPET !

 

Bit

Gigabyte Aorus X570S Master - Ryzen 5900X - Gskill 64GB 3200/CL14@3600/CL14 - Asus 1080ti EK-waterblock - 3x 980Pro 1TB - 1x Samsung 870 Evo 1TB - 1x SanDisc 120GB SSD - Heatkiller IV - MoRa3-360LT@9x120mm Noctua F12 - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win11 Pro/Linux - Phanteks Evolv-X 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...