Jump to content

Any way to fix dark shadow?


Recommended Posts

I know there has been several threads about this but one didn't come up recently so i want to ask has anyone found a fix for it yet. For those that are unfamiliar, it looks like this: (commonly occurs when there's water involved)

ScreenShot_001Small.jpg

ScreenShot_002Small.jpg

 

And no there's not a huge cloud over my head, the plane just gets dark depending on the camera angle

 

Anyway, some said this was an issue with advance haze but i turned that off and the problem still occured. i was wondering if any of the devs had any input or any modders out there that can change something in the coding so it won't come up again.

 

If there's not a fix, then this thread acts as a reminder to the devs in hopes it will be fixed in black shark or a patch.

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

  • ED Team

Its a bug with MOVING ships in the mission. And also it concerns shadows.

 

Make a simple mission, and use FULL shadows. Make a ship move to a waypoint. Go into the mission, and you will now have this annoying shadow on your plane and on ships and so on.

 

Edit the mission, but this time, let the ship be dead in the water. What happens? No shadow bugs now.

 

Edit the mission once more, and let the ship go to a waypoint, but this time, turn the shadows down a notch. What happens? No shadow bugs (but of course, you dont have self-shadowing either).

 

Hope this helps.

Link to comment
Share on other sites

When I have that problem, the next missions I play have the same bug, you need to reestart lomac to solve that. This don´t happend when the ships are static objects

 

Other thing it´s that sometimes the problem desappeared while I´m playing, but the numbers and the red stars change to a very dark colour.

 

My solution it´s simply put all planar shadows when there are ships involved.

Link to comment
Share on other sites

Yea i agree, anytime over water created this, anyone know why. And did any nvidia drivers out there got rid of it. I hope the devs could comment on this and assure us it will be fixed in black Shark. Would hate to see a darker ka-50 that's already black.

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

It's like asking for the shorelines bug or "courtains" bug to be finaly fixed ;)

51PVO Founding member (DEC2007-)

100KIAP Founding member (DEC2018-)

 

:: Shaman aka [100☭] Shamansky

tail# 44 or 444

[sIGPIC][/sIGPIC] 100KIAP Regiment Early Warning & Control officer

Link to comment
Share on other sites

  • 1 month later...

Sorry just wanted to bump this to see if anyone had any bright ideas on how to fix the issue or if Black Shark has fixed the issue. We know it’s probably caused by the advance haze and the full shadow option, neither of them we would like to turn down. Is there a way to get rid of the dark shadow without downgrading our eye candy? It use to occur near water but now it’s everywhere, even deep inland and on every plane. It’s also not an nvidia issue; it looks like its on ATI cards as well. Please ED we really like to see this bug gone. I can barely get a good shot in external view for screenshots or movie because of this bug.

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

AFAIK the last nVidia driver (91.31) solve a little of the problem and creates a little other.

 

That is the bug is reversible if you get altitude from the moving ship but the bug now apears everytime no matter the existence of moving ships or whatever. It apears onece you get far enough with the viewing camera (in cockpit or outside) from the object you see (your plane or other). Is like the "full shadoww" option is switched off too early. I know the shadows are not calculated from some distance for optimisations but now the switching is toovisible. maybe one intermediary shadow mode is missing with the new drivers.

 

 

I'll check this "effect option=none" and see if solves something (and what we lose :D )

[sIGPIC][/sIGPIC]

I5 4670k, 32GB, GTX 1070, Thrustmaster TFRP, G940 Throttle extremely modded with Bodnar 0836X and Bu0836A,

Warthog Joystick with F-18 grip, Oculus Rift S - Almost all is made from gifts from friends, the most expensive parts at least

Link to comment
Share on other sites

How about just using: active shadows instead of full, problem fixed. Anyway only 1 object in the view is using shadow buffers, the rest doesn't. It's not really big deal to get rid of it. You almost don't notice it anyway.

51PVO Founding member (DEC2007-)

100KIAP Founding member (DEC2018-)

 

:: Shaman aka [100☭] Shamansky

tail# 44 or 444

[sIGPIC][/sIGPIC] 100KIAP Regiment Early Warning & Control officer

Link to comment
Share on other sites

Is not that you lose that shadow is that you lose a nice illumination. I personaly like full shaddows... and I don't fly Su33 for that bug in particulary :D .

[sIGPIC][/sIGPIC]

I5 4670k, 32GB, GTX 1070, Thrustmaster TFRP, G940 Throttle extremely modded with Bodnar 0836X and Bu0836A,

Warthog Joystick with F-18 grip, Oculus Rift S - Almost all is made from gifts from friends, the most expensive parts at least

Link to comment
Share on other sites

But the only plane that you need to fly closer to the Aircraft Carrier... moving... is the Su-33 :P .

[sIGPIC][/sIGPIC]

I5 4670k, 32GB, GTX 1070, Thrustmaster TFRP, G940 Throttle extremely modded with Bodnar 0836X and Bu0836A,

Warthog Joystick with F-18 grip, Oculus Rift S - Almost all is made from gifts from friends, the most expensive parts at least

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...