Jump to content

MB-339A/PAN by Frecce Tricolori Virtuali


Jagg
 Share

Recommended Posts

Had the same problem as reported by Magot. After replacing the line

 

Guns = {gun_mount("M_2_L1", { count = 0 },{muzzle_pos = {0, 0, 0}})},

 

with

 

Guns = {},

 

 

as described by Automan, DCS starts normally. I also can load a mission with the MB-339. Dind't fly any mission until now, so I don't know if the guns still work, after altering the MB-339PAN.lua.

A-10A, A-10C, A-10C II, AV-8B, F-5E, F-16C, F/A-18C, F-86F, Yak-52, Nevada, Persian Gulf, Syria, Supercarrier, Combined Arms, FW 190 A-8, FW 190 D-9, Spitfire LF Mk. IX, Normandy + WWII Assets Pack

 

Link to comment
Share on other sites

Had the same problem as reported by Magot. After replacing the line

 

Guns = {gun_mount("M_2_L1", { count = 0 },{muzzle_pos = {0, 0, 0}})},

 

with

 

Guns = {},

 

 

as described by Automan, DCS starts normally. I also can load a mission with the MB-339. Dind't fly any mission until now, so I don't know if the guns still work, after altering the MB-339PAN.lua.

The MB339 uses the DEFA as guns, so that line were superfluous, indeed the bullets counter was declared as 0.

Anyway we hope that no further problem will appears, if yes please inform us.

 

Frecce Tricolori Virtuali - EFM coder

Link to comment
Share on other sites

Hi Magot, this maybe a rapid fix for the problem:

open MB-339PAN.lua with an editor like Notepad++ and replace this line

 

 

Guns = {gun_mount("M_2_L1", { count = 0 },{muzzle_pos = {0, 0, 0}})},

 

with

 

Guns = {},

 

Let me know

 

yea, it works good, thanks :)

Link to comment
Share on other sites

Ok, just in case someone is scared to use editor, below is attached the file that must be pasted (confirm overwrite:D) in MB-339PAN folder.

This will fix the DCS 2.5.4 crash;)

MB-339PAN.lua

MainMenulogo.png.6e3b585a30c5c1ba684bc2d91f3e37f0.png

 

ACER Predator Orion 9000: W10H | Intel i9-7900X OC@4.5Ghz | 8x16GB Crucial Ballistix Sport | Sapphire GTX1080TI | Intel 900P 480GB | Intel 600P 256GB | HP EX950 1TB | Seagate Firecuda 2TB

ACER Predator XB281HK: 28" TN G-SYNC 4K@60hz

ThrustMaster Warthog Hotas, TPR, MFD Cougar Pack, HP Reverb Pro

Link to comment
Share on other sites

Hi Magot, this maybe a rapid fix for the problem:

open MB-339PAN.lua with an editor like Notepad++ and replace this line

 

 

Guns = {gun_mount("M_2_L1", { count = 0 },{muzzle_pos = {0, 0, 0}})},

 

with

 

Guns = {},

 

Let me know

 

Yes, it work very well. Thank you! :thumbup:

Link to comment
Share on other sites

I need help with dcs-bios + MB 339

 

I could make the led work ok mb339pam

 

DcsBios::LED vor(0x8200, 0x0004, PIN);

DcsBios::LED tacan(0x8200, 0x0002, PIN);

DcsBios::LED rnav(0x8200, 0x0008, PIN);

 

DcsBios :: LED fltDirAlt (0x8200, 0x0040, PIN);

DcsBios :: LED fltDirGs (0x8200, 0x0020, PIN);

DcsBios :: LED fltDirRadioNav (0x8200, 0x0010, PIN);

 

 

what does not work for me are the swich

 

MASTER ARMAMENT Switch

DcsBios :: Switch2Pos masterArm ("MASTER_ARM", PIN);

 

WARN TEST Button

DcsBios :: Switch2Pos warnLtTestButton ("WARN_LT_TEST_Button", PIN);

 

 

can help solve swich

Link to comment
Share on other sites

It could be related to the export lua but its not easy to solve.

We are currently working hard on the efm and we will get rid of the export lua with the next update of the mod

I'm sorry but we are a small group and we cannot work on too much things at the same time, and now we are focused on the developement


Edited by PONY3_Aracno

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

we will get rid of the export lua with the next update of the mod

 

This would be a huge relief, but take your time and keep your quality up instead of a rushed release, because your work is amazing.

Louis|Dancer, foundation member of the digital Swiss Air Force, a group of enthusiasts trying to imitate everything that has to do with Swiss military aviation on dcs. If you want to join us, contact us via instagram.

our youtube chanel:dSAF

our instagram:dSAF

 

my rusty pc: msi gtx1080ti / ryzen 5 2600x / ga-ab350 gaming motherboard / 16gb ram / rift cv1 / warthog

Link to comment
Share on other sites

Have upgraded to 2.5.4 beta and had to remove the mb339 to get sim back working. I deleted the aircraft from the c:\saved games\dcs open Betaz\Mods\Aircraft. Put the mods back in blocks and kept restarting to confirm working. The mb339 was the only mod I had to leave behind. Any suggestions. No rush

Link to comment
Share on other sites

Have upgraded to 2.5.4 beta and had to remove the mb339 to get sim back working. I deleted the aircraft from the c:\saved games\dcs open Betaz\Mods\Aircraft. Put the mods back in blocks and kept restarting to confirm working. The mb339 was the only mod I had to leave behind. Any suggestions. No rush

 

here is the fix: https://forums.eagle.ru/attachment.php?attachmentid=200188&d=1545340577

 

Ok, just in case someone is scared to use editor, below is attached the file that must be pasted (confirm overwrite:D) in MB-339PAN folder.

This will fix the DCS 2.5.4 crash;)

https://forums.eagle.ru/attachment.php?attachmentid=200188&d=1545340577

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

guys, not sure what I'm doing wrong, put it on the runway hot start so its not procedure, tootle off down the line, as soon as I rotate it explodes? AI do it fine....dam bots
Do your rotation at about 140-150 kts... this is due to your tail cone hit the ground during the rotation and since the aircraft hasn't a damage model yet, the only way that it has to react is the explosion. Do the same during landing...maintaing your vertical speed low and your IAS around 130 kts (on this last data I don't remember well, but do your test)

 

Frecce Tricolori Virtuali - EFM coder

Link to comment
Share on other sites

Duke, nice work! Looking good. If you don’t mind me saying, it looks like you’re dealing with reversed yaw-roll coupling, where of course a straight-winged jet will normally exhibit roll in the direction of yaw rate. In your videos it appears to want to do the opposite, especially apparent in spins.

 

I’m trying to imagine why this would happen, but without looking at your code I can’t come up with anything. Have you noticed that and are you still working on it?

Link to comment
Share on other sites

Duke, nice work! Looking good. If you don’t mind me saying, it looks like you’re dealing with reversed yaw-roll coupling, where of course a straight-winged jet will normally exhibit roll in the direction of yaw rate. In your videos it appears to want to do the opposite, especially apparent in spins.

 

I’m trying to imagine why this would happen, but without looking at your code I can’t come up with anything. Have you noticed that and are you still working on it?

Every advice is well accepted ;)

 

Yes, in the spin phase I did an error, I continued to perform the menouvre with opposite rudder while I should have to perform the classical spin.

 

Frecce Tricolori Virtuali - EFM coder

Link to comment
Share on other sites

Awesome stuff! For future reference, it is easier for us to see it by using the YOUTUBE tag. Just use like so. Looking forward to this EFM release!

 

 

 

[YOU TUBE]video id[/YOU TUBE]

 

get rid of spaces for it to work

 

Yeah, sorry but using tapatalk I thought that the youtube tag was automatic. Next time I will place it manually ;)

 

Frecce Tricolori Virtuali - EFM coder

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...