Jump to content

Sa-3 Missile exploding shortly after launch?


Recommended Posts

So yesterday I set up a custom mission to practice A to G in the M2000C (an aircraft I am rapidly falling in love with!).

 

I set up some hard targets on the disused airfield north of Batumi (the one used in all the weapon training missions for the A10 and Mirage).

 

I also set up an Sa-3 site (one launcher, TR and SR).

 

I approached from the West at about 150ft, as I approached the Sa-3 locked on and launched at me however the missiles exploded 50ft/2secs after launch.

 

Is this a bug? I havent encountered this in Nevada (the only other range I have set up in a similar manner). Could it be (due to my height) it couldn't track properly?

Link to comment
Share on other sites

I would hate to be an air defense troop having my own missiles exploding right off the rail in front of me. That's unsafe at best. Super design.

 

That's why missile selfe destruct is never automatic but instead a manual task.

 

Either way, in a RL scenario the SAM crew would keep the missile flying towards the last known position and try to reaquire the target.

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to comment
Share on other sites

That's why missile selfe destruct is never automatic but instead a manual task.

 

Either way, in a RL scenario the SAM crew would keep the missile flying towards the last known position and try to reaquire the target.

That is kind of what i thought would happen.

 

I doubt it will make difference but i might jack up the AI to excellent and see if that makes a difference.

 

Sent from my GT-I9505 using Tapatalk

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...