Jump to content

Ka-50 trimming with my Microsoft FFB2 doesn't work anymore as it used to.


majapahit
 Share

Recommended Posts

I have come back to black shark after quite some time and

I noticed the trimming with my Microsoft FFB2 doesn't work anymore properly as it used to.

 

It used to be pushing the stick forward, hit the trim, and the helicopter would continue flying with the stick in the set position. Hovering the same, hit hover and the Ka-50 would hold still in the air.

 

Not anymore.

 

I have to trim and trim again and still the copter is dipping or rising. Hovering is a somewhat drunken nightmare.

 

When I compare and set up BS2 with my TH Warthog non-forcefeedback stick, enabling centering position mode,

 

I can notice that BS2 trims with no problem at all.

 

Push the THWH forward, hit the trim, center, and Ka-50 will fly straight rock Steady.

 

Hit Hover and will hover on a penny.

 

What's up?

 

Anyone experiences the same?

 

N.B. Was quite some versions ago Ka-50 w. FFB2 seemed to work quite nicely.

| VR goggles | Autopilot panel | Headtracker | TM HOTAS | G920 HOTAS | MS FFB 2 | Throttle Quadrants | 8600K | GTX 1080 | 64GB RAM| Win 10 x64 | Voicerecognition | 50" UHD TV monitor | 40" 1080p TV monitor | 2x 24" 1080p side monitors | 24" 1080p touchscreen |

Link to comment
Share on other sites

Did you try to change the trimming method?

Try Central Trimmer Mode

 

tried on/off, not trimming right/cumbersome

| VR goggles | Autopilot panel | Headtracker | TM HOTAS | G920 HOTAS | MS FFB 2 | Throttle Quadrants | 8600K | GTX 1080 | 64GB RAM| Win 10 x64 | Voicerecognition | 50" UHD TV monitor | 40" 1080p TV monitor | 2x 24" 1080p side monitors | 24" 1080p touchscreen |

Link to comment
Share on other sites

Probable solution for your troubles:

https://forums.eagle.ru/showpost.php...44&postcount=4

 

If I remember correctly, trim used to work fine with axis curves. It definitely doesn't now. Set Axis curvature to 0 and trim will be fine. As I've posted elsewhere, I hope ED would fix this, ie. enable proper and precise trimming with axis curves set up.

 

Axis = 0

that works,

 

thx

| VR goggles | Autopilot panel | Headtracker | TM HOTAS | G920 HOTAS | MS FFB 2 | Throttle Quadrants | 8600K | GTX 1080 | 64GB RAM| Win 10 x64 | Voicerecognition | 50" UHD TV monitor | 40" 1080p TV monitor | 2x 24" 1080p side monitors | 24" 1080p touchscreen |

Link to comment
Share on other sites

  • 10 months later...
Probable solution for your troubles:

https://forums.eagle.ru/showpost.php...44&postcount=4

 

If I remember correctly, trim used to work fine with axis curves. It definitely doesn't now. Set Axis curvature to 0 and trim will be fine. As I've posted elsewhere, I hope ED would fix this, ie. enable proper and precise trimming with axis curves set up.

 

Yes... your method works !!! I'm so happy to see the FF come back alive.

set curve to zero, works.

 

Haha I can hardly imagin how did you find the key. Here it is.

 

Thank you so much!!

Link to comment
Share on other sites

Probable solution for your troubles:

https://forums.eagle.ru/showpost.php...44&postcount=4

 

If I remember correctly, trim used to work fine with axis curves. It definitely doesn't now. Set Axis curvature to 0 and trim will be fine. As I've posted elsewhere, I hope ED would fix this, ie. enable proper and precise trimming with axis curves set up.

 

I found another problem.

Once I use "HTC VIVE" VR headset, the trimmer FF wont work.

Witout VR, FF works.

With VR connected, FF dosen't work.

I doubt they can resolve this complicated problem. Pity

Link to comment
Share on other sites

  • 1 month later...

There is ABSOLUTELY a bug with the trim system.

 

I have tested it by locking my joystick firmly in the pitch and roll axis so absolutely no input is possible.

 

EVERY press of the trim button causes a pitch movement to be commanded in the direction the pitch is currently biased towards, either positive or negative, thus continued pressing the trim button will either plough you into the ground or do a backflip.

 

There is no commanded input shown on the controls indicator nor the ingame animation of the joystick but the pressing of TRIM DOES COMMAND A PITCH INPUT (i believe erroneously)

 

Hopefully Sithspawn can escalate this as a confirmed bug.

 

One can only partially get round this by the cheat of disabling in game FFB and using SIMFFB and unmapping your in game binding for trim, but you can ONLY use flight director mode like this. The Shark flys like a dream using this workaround.

Link to comment
Share on other sites

I found another problem.

Once I use "HTC VIVE" VR headset, the trimmer FF wont work.

Witout VR, FF works.

With VR connected, FF dosen't work.

I doubt they can resolve this complicated problem. Pity

 

I'm pretty sure this is an issue with VR taking up too many USB resources, and thus there's enough to register the joystick, but not the FFB part. Try disconnecting some USB devices and try again, I was able to get my FFB working by doing so.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...