Jump to content

Please Help - Saitek X45 cannot get to work...


Recommended Posts

I am an old internet fighter pilot looking to get back into the fight. Last flew online around 2002. Things are sure different now! Everything is so much more complicated and getting stuff to work on a PC seems like rocket science the frustration has me needing to kill something.

 

I have a newist PC I bought specifically for DCS and with an eye to getting an Oculus just over a year ago. I posted a thread then about getting a PC, the full specs of my machine are in this thread:

 

https://forums.eagle.ru/showthread.php?t=153536

 

I have a Saitek X45 stick and throttle and Saitek Pro Flight rudder pedals. The X45 is ancient, I used it over 15 years ago flying Warbirds and AH. But it is paid for and right now that matters.

 

When I first plugged in the X45 it worked fine. No problems at all. Calibrated in windows perfectly and gave no issues. I got IL2 CLOD running a bit but then I plugged in the rudder pedals and suddenly they stick axis would not function. All axis - joystick, throttle, sliders and rotating knobs - they are pinned to a corner. By that I mean that when you go into the joysticks properties and test, the little x indicator does not move around in sync with the joystick but rather it does not move at all and stays pinned into a corner - to the far extreme. The raw value will indicate 1. The throttle and sliders are the same. All hat switches and buttons indicate and work fine. This of course makes flying any sim impossible, no joystick no controls.

 

I did post a thread about this on the ATAG forums a while back. The issue never got resolved but this does show some ideas and explanations of the issue:

 

http://theairtacticalassaultgroup.co...ad.php?t=22121

 

This issue has to be all about Windows 10 and an ancient Saitek system with drivers that have compatibility issues. It also has something to do with the computers registry and how a joystick is noted or listed there. I am NOT a tech guru in any sense and I honestly have no idea what a computer registry really is. I certainly have no idea how to edit one.

 

I have tried uninstalling the X45 and plugging it back in to try and get it to install as a default generic joystick and then just calibrate it in windows but I cannot get that to work and really do not know what I am doing. It also seems that when I plug it in and it installs itself when I look in Device Manager it shows as - Other Devices - Unknown Device. I do not know what is going on but when the X45 gets plugged in and it installs itself something goes on that screws it up from working. Driver? The X45 is not supported by Saitek for Windows 10 for sure. But it DID work initially AND it seems that it would work if installed as just a plain generic joytick/throttle. But also with the rudder pedals. Has to be a way.

 

I have this PC running and the Oculus Rift working and it runs Project Cars just fine. I am turning some pretty hot laps at Spa in my Lotus 98T F1 car using a Logitech G27 wheel and pedals setup. That works without any issues.

 

I know this can be fixed and made to work but I am totally lost at this point. It would be awesome to get DCS running and do some VR flying in a 109 but I cannot afford to buy a new stick setup right now. Any help here is hugely appreciated.

 

Fangio

Link to comment
Share on other sites

As I posted in the copied threat in input/output --- Anyone who can help me over the phone and/or in a screen sharing session such that this problem is fixed and I am rendered 100% able to fly DCS with my X45 stick/throttle and the Saitek pro flight pedals....

 

I WILL PAY YOU $50.

Link to comment
Share on other sites

From what I can tell, if the stick works in solo config, aka NO other peripherlas attached, it should also work when other input devices are connected---but--- there is a big chance that one of your other devices overwrites some axis input and thus you end up with the stick in one corner.

 

This is a a rather common problem for DCS pilots I am afraid.

 

When you test the devices togther in Win Cpanel, do you then already get the stick showing wrong inputs or only when you enter DCS ?

 

When you have only the stick attached, can your DCS deal with it properly ?

 

WHen you have all but the stick attached, does the rest work flawless in DCS ?

 

 

Trying to narrow down the reason(s).

Gigabyte Aorus X570S Master - Ryzen 5900X - Gskill 64GB 3200/CL14@3600/CL14 - Asus 1080ti EK-waterblock - 3x 980Pro 1TB - 1x Samsung 870 Evo 1TB - 1x SanDisc 120GB SSD - Heatkiller IV - MoRa3-360LT@9x120mm Noctua F12 - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win11 Pro/Linux - Phanteks Evolv-X 

Link to comment
Share on other sites

From what I can tell, if the stick works in solo config, aka NO other peripherlas attached, it should also work when other input devices are connected---but--- there is a big chance that one of your other devices overwrites some axis input and thus you end up with the stick in one corner.

 

This is a a rather common problem for DCS pilots I am afraid.

 

When you test the devices togther in Win Cpanel, do you then already get the stick showing wrong inputs or only when you enter DCS ?

 

When you have only the stick attached, can your DCS deal with it properly ?

 

WHen you have all but the stick attached, does the rest work flawless in DCS ?

 

 

Trying to narrow down the reason(s).

 

 

 

Bitmaster....

I just spent 45 minutes drafting a very detailed response with notes relative to everything I have tried -- the forum apparently auto logged me out and then lost the entire post when I clicked to submit. Poof - gone....

So. All over again.... briefly this time (draft in word doc then cut and paste.... I may learn slow but I do learn! ).

I do not have DCS installed at all. There is no point to buying the game if my joystick does not work in windows. I have IL2 CLOD - it does not work in that. It does not work in windows at all, cannot calibrate. No axis function. No joystick, no throttle, no rotaries. All buttons work fine. I see all this in either TEST or CALIBRATE within windows.

When I first got the PC and plugged in the X45 – it worked perfectly. When I later plugged in the rudder pedals, they worked fine but the joystick was dead – all the problems appeared and have never gone away. Since the time another controller was plugged into the PC, the X45 has never worked correctly regardless of what I attempt.

The Saitek Pro Flight rudder pedals will work fine. I play Project Cars using a Logitech G27 wheel / pedal combo and it works fine. The X45 does not work. I have not attempted to use the X45 at the same time the G27 is plugged in – I swap them. Also, when I do plug in the X45 I always plug it into a USB 2.0 port – NOT a USB 3.

I believe these issues have everything to do with the “registry” (whatever that really means). I think the core issue is something to do with windows registry and the X45 being screwed up there. I did read online that others got it to work but with no real details on how plus it DID work for me at first so I am sure there is some way to fix this.

Link to comment
Share on other sites

  • 2 weeks later...

USBDEVIEW is a very powerful tool despite it looks simple and flat.

 

USB-DEVICE-VIEWER lets you see ALL usb devices that ever touched your PC !

 

Delete all those that make trouble and those you know that will never come back again.

 

Keep it simple, keep it sleek ;)

 

 

Q: when you test that stick on a 2nd PC it does work ?? preferably also Win10( 64bit ? )

 

 

report back, we are done when your stick works again ;=)

Gigabyte Aorus X570S Master - Ryzen 5900X - Gskill 64GB 3200/CL14@3600/CL14 - Asus 1080ti EK-waterblock - 3x 980Pro 1TB - 1x Samsung 870 Evo 1TB - 1x SanDisc 120GB SSD - Heatkiller IV - MoRa3-360LT@9x120mm Noctua F12 - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win11 Pro/Linux - Phanteks Evolv-X 

Link to comment
Share on other sites

Gaaawd....just reading all those HW issues makes me think and ask myslef:

 

DO I NEED TO PUT MY NEW RIG TOGETHER NOW ???

 

 

YES.damn...hammer it together and let it FLYYYYYYYYYY

 

Bit over & out...putting my rig together now ( olympic watergames ahead,. need to rinse LoL )

 

 

Why do Macs not have such bold stupid issues ??? Why only those stupid Redmond boxes ???

Gigabyte Aorus X570S Master - Ryzen 5900X - Gskill 64GB 3200/CL14@3600/CL14 - Asus 1080ti EK-waterblock - 3x 980Pro 1TB - 1x Samsung 870 Evo 1TB - 1x SanDisc 120GB SSD - Heatkiller IV - MoRa3-360LT@9x120mm Noctua F12 - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" QHD Gsync 144Hz - Win11 Pro/Linux - Phanteks Evolv-X 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...