Jump to content

Trouble loading/saving profiles


Recommended Posts

Hello there, so with the arrival of my TM Hotas Im diving much seriously into DCS, starting with the P51D so obviously wanted to setup all the switches and stuff based in my needs.

 

After doing so, I realized I couldnt set it up to on/off switch function in the normal control adjustments, so I came to the forums and read that you had to get your hands into changing the Control Profile file code, not really a problem for me for getting what I wanted, until all inconviniences started with it.

 

First, I noticed the codelines I saw around the forums were NOTHING like the ones I have now, after reading I also came to realize that they changed the old ".lua" profile files to ".diff.lua" files and as far as I've seen, difficult to believe, but I see no one has found or came with a way of modifying these new files in almost 5 years... Really a shame because, YES I've read the alternative that its been used since then, which is modifying the first and last line of an old .lua profile and pasting it in the, in my case:

 

C:\Program Files\Eagle Dynamics\DCS World\Mods\aircraft\P-51D\Input\P-51D\joystick

 

in order to work with new versions of DCS, but I have to say that this hasn't worked for me and thats why Im posting this, it only says to paste these .lua profiles on that folder after you modify their lines and remove the code from the name if it has one, and thats it, like stating this will magicly reassign your keys ingame, but obviously it doesn't, seeing so, the most logical thing to do is to LOAD the profile and this is when the major problem starts.

 

Main Problem:

 

CAN'T LOAD PROFILES OF ANY KIND, It sure lets me press the Load Button and start looking around folders and stuff, but they are Never recognized, Not .lua files, Not .diff.lua files either, only way I can see them to click and load is to change the option from loading ".diff/lua" to "all files" then I can see them, but its worthless because once I select them and click on load, nothing happens, it doesnt loads anything.

 

Funny thing is that if I enter the "Adjust Controls" option and after modifying stuff I click on save profile, It saves it, and the file even appears, like it gets created on whatever folder I saved it to, but, if I do further modifications, save them, and then want to go back into loading the Profile I just saved with this exact version of DCS in the same PC, IT DOESNT RECOGNIZE THEM OR LOADS IT EITHER, basicly same behaviour stated above happens.

 

Screenshot Samples:

 

Ew6vuPJ.jpgdlv3gEe.jpgNo profiles show to load on either cases as seen above, even when they clearly show on the proper folders.

 

So really want to know whats happening here, if anyone has had this before, I did my research on this problem before posting this thread, I could just found 2 threads pointing this, one was never answered to, and the other seemed to kinda have the same problem Im talking about but replies focused on other stuff and never got an answer for this exact situation Im talking about.

 

So really hope I got a proper response for this issue because keeping like this I wont be able to set my TM Hotas correctly, and I really want to do so because Im planning on sticking around DCS for a Looooong while.

 

Thanks for reading, and awaiting response =)


Edited by Xanatos4
lack of pics
Link to comment
Share on other sites

The simplest way to set up stick or whatever is to just assign buttons to functions you need and press OK at bottom of screen. This will automatically save everything for you. You don't need to load a profile later just select the aircraft in dropdown menu on top right of screen if you want to make more changes later in main menu. When you start a mission it will load correct profiles for that aircraft. You don't need to load control profile before you start.

If you do want to save and load profiles keep in mind its only saving or loading for each controller separately so you need to click on a box in that column you want to save or load to.

 

Link to comment
Share on other sites

Yeah, well I have no problem with the game saving and keeping my every modification because it does, my issue with it is that I cant set up the TM Hotas switch functions to recognize "on/off" positions, its been stated that the only way of making it do so is by manualy editing the .lua files in a text editor such as Notepad++ which I have.

 

But since you Cant modify the new format .diff.lua files by this way, the alternative way that is mentioned in the forums is to modify an old .lua file and remap it manually with what you need, then you're told to paste it in the, already mentioned:

 

C:\Program Files\Eagle Dynamics\DCS World\Mods\aircraft\P-51D\Input\P-51D\joystick Folder

 

But this does nothing, and I'm not able to manually load it from there either so that means no "on/off" switch function which means I'm not able to sort out the problem, thats why I'm concerned of being able to load this .lua profile because so far as I've seen there's no other way of getting those on/off switch functions to be recognized by DCS.


Edited by Xanatos4
typo
Link to comment
Share on other sites

If you're trying to add 2pos/3pos switches it needs to be done in the default.lua for the aircraft or via the base_joystick_binding.lua, located in the aircraft directory in MODS in your DCS game directory (NOT your save game directory) and dcs/config/input/aircrafts respectively.

 

Changes to your .diff.lua won't register because the control you're referencing does not exist; the .diff.lua is simply a list of things you have changed relative to the default.lua

 

The format has changed slightly but if you hacked up the old ones it should still make sense to you.

Link to comment
Share on other sites

Yes cthulhu68 thats kinda what I need to be doing, changing the down values for each switch and stuff but problem is that after I do it, I cant get DCS to recognize the .lua file, I want to know how can I get it to recognize that modified .lua profile since as I said it seems Im not able to load it normaly from the control adjustments menu.

 

And still thanks for the follow up =)

Link to comment
Share on other sites

@feefifofum

 

Yes, I know the .lua profile must be on the location you mentioned, I even marked it on the main post above as the rute I'm pasting the modified .lua files, and it shows on the 2nd screenshot above.

 

What I want to know is how can I get DCS to recognize THAT .lua Profile, because it seems I cant load it by conventional method, so how can I get DCS to Use the .lua file and not the .diff.lua thats created by default after I adjust controls in game.

Link to comment
Share on other sites

Alright after hours of trying stuff out, I discovered the way of making DCS recognize the .lua files, which by the way is not pointed out in Any thread discussing the control profile situation, at least not mention in the main posts, obviously I cant read every single post for every single thread, but I think is something preety important to mention to avoid someone else going through this.

 

What was happening:

 

Since my instalation is brand new, I downloaded DCS last year so the first profile files I met were the .diff.lua and had no old .lua from myself so had to download someone else's P51D .lua Profile in order to modify it, thing is that this person had whatever other name to the .lua itself and I just kept it that way, WRONG.

 

Solution:

 

So Stupid but is not too obvious to think of it as a problem, JUST CHANGE THE NAME to Match the .diff.lua profile files located on the Saved Games/blablabla/ folder, once I did that I could see a joystick conflict was created within the game, (My .diff.lua assignations with the .lua downloaded profile) this obviously meant DCS was finally reading the .lua pasted in the Eagle Dynamics/mods/P51/blablabla folder

 

So Im happy I could at least sort that out, although not entirely happy because a new conflict came in which I also spent hours trying to sort out and searching around threads looking for a solution and havent found any.

 

Not sure if continuing posting here, since this escalated a bit out of loading saving profiles, but still has to do with the profile files themselves and editing them. Im gonna explain the situation and then see if you guys could point me in the right direction here because this is really being much of a headache to set up some f"#$in switches which should already have a simple way to set up by now.

 

New Situation:

 

So I remapped the downloaded P51D .lua profile, and as I said DCS finally recognizes it, cool, But thing is that, after I remapped, which at first wasnt as long work since the profile I downloaded already had the 2/3 switch functions set and even couple of switches already matched my own config.

 

Thing is that I changed everything to meet my config, and when I went into game, Withiiin the Adjust Controls panel, all the keys are correct, like I would activate Switch 16 and it will mark my "Fuel Booster ON" function which is perfect, as I set it up, or my BTN20 which is set for my "Fuel Shut Off Valve" it all shows correctly on the Control Adjustments. However, the strangest thing happens when In game... No Switch matches my configuration as shown on the Adjustments panel, for example, I will press my BTN20 Switch which as I say is shown set to "Fuel Shut Off Valve" and in game it would turn the Magnetos to On or Both, BTN16 would be the "Primer" instead of the "Fuel Booster ON" so this is not making any sense for me.

 

How come all the controls will show correct match on the Control Adjustments and then when I quit pause menu and Im able to play, the controls are something totally different, this is already driving me crazy and if someone could please tell me a hint of whats going on would be highly appreciated.

Link to comment
Share on other sites

  • 1 year later...

hitting OK does not save the controls for Me

 

I have to re do ALL my controls every time I play. When I save the warthog joystick, I can

then load the joystick and its fine. But every time I turn DCS on, both the Throttle and

pedals are loaded with stuff I do not want.

 

So after reading this, I guess I have to save each one, one at a time as setting everything

up and then clicking save does not save the pedals or throttle.

 

I am mostly flying the harrier and just wish I could figure this out.

 

I have not tried going into any saved game area and looking for lua files

so any help would be much appreciated.

controls.thumb.jpg.09e8a136d6d7e9183bde98813860bdf0.jpg


Edited by ctguy1955
added photo of how OK does not save controls for ME
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...