Jump to content

Can't Fire the gun on a10 and f15 with my Joystick

Recommended Posts

Hello guys ,


I can't get the gun trigger on my joystick to work with the a10 and f15 planes.

I am able to shoot the gun using the space bar and the master arms switch is up.I am able to drop bombs and fire missiles with the Release button on my stick.


While flying Russian planes the trigger button works so i suppose its not a hardware problem.

I read in another post about a safety switch that exists in usa planes and prevents you to press the trigger , but i can't find it in the controls menu(not sure if it even exists).


Another thing is that i used my dcs .lua to map the keys.I think everything works as supposed except the gun trigger in american jets so i am not sure if its relevant.I am not sure how to reverse that mapping so if anyone knows please let me know.


Finally i tried resetting the keybind and then remapping without any luck.


I am using a mad cats fly 5 (meh).


Thanks in Advance. Chris :joystick:

Link to comment
Share on other sites

What function have you bound, that you expect to fire the cannon with?


"cannon" selects the cannon HUD modes on the F-15 and A-10.

"weapon release" releases the selected weapon, but never fires the gun.

"weapon fire" is the function that actually shoots the gun.

Check my F-15C guide

Link to comment
Share on other sites

Hi Sryan,


My joystick Button 1 (which is the trigger) is mapped to Gun Trigger under the Hotas tab.

The button works when i am flying russian planes( i can shoot the gun with Joystick Button 1 on su 27 for example).

The ''weapon fire'' control under the weapons category is mapped to space bar on the keyboard but its unavailable in the joystick tab(the square is empty and i can't select it).

Somehow i suspect that this is due using my dcs .lua to map the keys because when i unplug the joystick i am only seeing a few tabs in control category.


I am bit new to all this so please bear with me :)))


Meny thanks, Chris

Link to comment
Share on other sites

I just resolved this.As i suspected it had to do with mapping controls using my dcs template.


I went in to the installation folder, and deleted the .lua files for keyboard mappings and remapped manually.

Now it works as expected


Time to fly, oh and btw i just checked your F-15c guide, amazing stuff for newbs like myself :))


Link to comment
Share on other sites

  • 3 weeks later...

That depends a bit. The general way is to do tutorial missions etcetera and just note what you are using. That way you'll find things like "laser on" and know their name, and then just look for that name. Also note that you can subdivide the "hundreds" of things through the drop-down menu to sections. For example, in A-10C you'll find something called "HOTAS" in there, being everything that the real pilot has on HOTAS. As a shortform in that specific plane - those things are what you want.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...