Jump to content

Migrated to new PC and now can't fly any modules


Recommended Posts

Old PC crashed so not able to deactivate the licenses, built a new PC and DCS is installed on it's own dedicated drive so moved the drive to the new PC and received the warnings that modules ned to be reactivated. Reactivate them all but when I try to fly anything all I see is the F10 map and no way to get to the cockpit of the plane..


Happens with all modules.

Obviously a licensing issues but how do I resolve this since I already reactivated the modules?



"Pride is a poor substitute for intelligence."


Link to comment
Share on other sites

I've no suggestions, but I have exactly the same problem as you.


I made a fresh install of Windows 10 on to an SSD at Christmas. No other hardware changes. I don't recall deactivating my DCS modules beforehand but have 8-10 activations left on each.


It's been a few months since I first installed DCS on the new OS install but I believe I copied the whole 'MODS' folder across to the new install, to save lots of re-downloading. Since then I haven't actually flown any aircraft, but today I find I can't get into the cockpit of anything except the free aircraft.


So far I have tried:


  • Deleting registry entries based on the info here: http://en.wiki.eagle.ru/wiki/Problem_with_Activation, then reactivating the modules. No joy.
  • Running the xxx_protect.exe as administrator in the 'bin' folder of each module, and trying to re-activate there. Each module said it was already activated, but I chose to try activation again. It said it was successful, but my problem remains.
  • Running the xxx_protect.exe file and deactivating a module, then reactivating it. Same problem.
  • Clicking the 'DRM' button in the in-game Module Manager and making the same changes from there. Nothing.
  • Edit: Also tried to repair DCS World several times after making various changes. No help either.

Aside from deleting the whole installation and starting all over again, I'm fast running out of ideas... :(



One would have thought this kind of thing would be quite simple in this day and age. I guess copying old files across isn't taken care of in the DRM applications. Next I'll try deleting (renaming) some files...




Edited by Martyn
Link to comment
Share on other sites

Windows 10 can have some restrictive permissions, try changing your dcs folder permission to full control "allow". I have no idea if this will help with your problem, but it has helped me in the past with strange dcs errors.



6600K @ 4.5 GHz, 12GB RAM, GTX 970, 32" 2K monitor.


Link to comment
Share on other sites



You might need to do an entire re-install.


Least Re-install all modules.


Use GUI Utility, or Command Line, Uninstall All Modules, then Re-install them.

Edited by SkateZilla

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill (F4-3200C16D-16GTZR x2),

ASRock X470 Taichi Ultimate, XFX RX6800XT Merc 310 (RX-68XTALFD9)

3x ASUS VS248HP + Oculus HMD, Thrustmaster Warthog HOTAS + MFDs

Link to comment
Share on other sites

Thanks for the input both.


I've tried a few more things. I moved my DCS directory to my SSD (had only Win 10 and FSX on there till now), except for the MODS directory so I could re-download my aircraft. Then I ran the repair utility. Also deleted all keys out of the registry.


After trying to get a couple of modules running, I found that the A-10C would work but not the Hawk. Since DCS wasn't really 'installed' in the new location (the path didn't match the original path), I decided to make a full reinstall anyway. I had still got a copy of my 'old' DCS directory (pre new OS installation at Christmas) which I renamed so it matched the old path, then ran the uninstalled via Control Panel.


Next I made a new install onto my SSD, but to save a download I only deleted the root files and 'bin' folder contents. This was enough to allow the installer to run and re-download the missing files. Now I have an 'almost' clean install.


Having signed in, in-game, I am prompted to download all my aircraft based on my account log-in. Doing one at at time, I have the A-10C and Ka-50 working, but the Hawk is still a no-go. I'll continue on with the rest now... and report back the end result.


A DCS reinstall is feeling like the new FSX... more time spent tinkering/fixing and less time flying :doh:


Update: All modules except for the Hawk are now working. I clicked the in-game DRM button in the Module Manager and it activated (didn't ask to re-activate), but it still doesn't work. Ultimately, putting my DCS install in a different location seemed to be enough to fix the problem for the other modules, but to avoid any possible future issues, the full reinstall was the safest option. At least a complete re-downloaded wasn't needed. For now I'll just ignore the Hawk...

Edited by Martyn
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...