Jump to content



Recommended Posts

I'm trying to get to the bottom of this problem. I've tried everything I know of to fix this.


Oculus rift

Geforce 1070

16gb ram


When I first got my rift it never did this. I think when I updated to windows 10 is when it started but im not sure. Changing graphics settings doesnt help. Switching usb ports, powered ports, disable aero snap, new sensors, nothings has helped. Tracking is perfect but if you move your head there is a halo circle that will cause text to flicker and glitch. Any help>?????

Link to comment
Share on other sites

  • ED Team

Hi and welcome to the forum


First thing I would try is using DDU cleaner before doing a fresh GPU driver install


it has help many in the past.


if that does not help try and cleanup and repair of DCS, and retest, if it does not help please attach your logs


( guides in my signature )


Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 64GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

Did the DDU uninstall and fresh driver install and also repaired DCS same problem exists. Tracking is perfect but jitters still exist. You can really tell when you roll and look at the wings.


I did notice if I run as administrator the problem is fixed in the menus but still exists in the game.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...