Jump to content

104th Phoenix online mission & DCS-Bios


Recommended Posts

Does anyone know why while on the 104th Phoenix online mission, it does not work with DCS-Bios?

Does not work LED control, 7 segment display and alphanumeric LCD displays.


Server has setting "player export" disabled. Need enabled.

My cockpit A-10C

Строю кокпит A-10C

i7 7700k, 32Gb RAM, SSD NVMe, GTX 1080, Hotas Warthog, HTC Vive.


With love from Russia

Link to comment
Share on other sites

Thanks for bringing this to my attention again, I had dropped the ball on this one. This issue should now finally be fixed in v0.5.3 of DCS-BIOS, which I just released.


When "player export" (or "ownship export" as it is called internally) is turned off, the function LoGetSelfData() became unavailable. DCS-BIOS relies on this to determine the aircraft type.


I contacted ED about this months ago, and they fixed it months ago (by making the aircraft type always available).


I had assumed that would be all it takes to fix this issue. When I tried to set up my own multiplayer server with the tester version of DCS (because the fix had not arrived in the public build yet), the old PC I tried to run it on had a hard disk failure. Then life got in the way and I forgot about the whole thing.


The remaining issue that I would have found if my test server had worked (and that I could now find in five minutes by testing against the 104th server) is that the CommonData exports still tried to access values that were disabled by setting allow_ownship_export to false, such as the current position and heading.


So now everything but the CommonData exports should continue to work in multiplayer regardless of server settings.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...