Jump to content

New Third Party Apps Support in Oculus Home


dburne
 Share

Recommended Posts

Ok so with the latest version 1.17 of the Oculus Home software, we now have third party app support in the Oculus Home Environment.

 

This means after running a game executable outside of Oculus Home, it will automatically put an executable within the Oculus Home environment so one can launch it from there without needing to lift the Rift up to double click on desktop with the mouse to launch it.

 

It appears to work well, in another game I have it did as described and I can now launch that game from within Oculus Home VR. However for some reason, my DCS is not behaving. I had launched my DCS2.1 Open Alpha, and it put the executable in the OH environment. But when I try and launch it from within OH, it loads up just the hangar with no menu or sound, just stuck there looking at the hangar. It still launches fine outside of OH, just not from within.

 

Anyone else try this yet and have it working properly?


Edited by dburne

Don B

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | Gigabyte 4090 OC | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle | VPC Rotor TCS Base w/ Alpha-L Grip| Point Control V2|Varjo Aero|

Link to comment
Share on other sites

Same here. Must be a beta yet.

 

Regards

 

Ok thanks good to know it is not just me. Must be a bug then in the Oculus software, I will just leave it there and try it again later, maybe when the next version of OH is pushed out.

 

I know if you delete the shortcut it is gone permanently from within Oculus Home and can not be restored, so I don't want to do that. Hopefully they will change that as well at some point.

Don B

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | Gigabyte 4090 OC | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle | VPC Rotor TCS Base w/ Alpha-L Grip| Point Control V2|Varjo Aero|

Link to comment
Share on other sites

Could this be related to a launch/working directory issue? What if you try it with a shortcut to DCS rather than directly to the DCS exe? Of course, double check the the shortcut has correct working directory set in it.

 

I have no idea if this fixes it though, I don't have access at the moment.

Link to comment
Share on other sites

Could this be related to a launch/working directory issue? What if you try it with a shortcut to DCS rather than directly to the DCS exe? Of course, double check the the shortcut has correct working directory set in it.

 

I have no idea if this fixes it though, I don't have access at the moment.

 

I have really no idea, and would not even know at this point how to edit a shortcut's path in the Oculus Home Environment. This is all new with version 1.17 of Oculus software.

 

It is obviously launching DCS as it gets into the Hangar, just no menu or sound very strange...

Again no problem launching it outside of the Oculus Home environment as was typically done.

Don B

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | Gigabyte 4090 OC | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle | VPC Rotor TCS Base w/ Alpha-L Grip| Point Control V2|Varjo Aero|

Link to comment
Share on other sites

Ok I found the file for the shortcut listed in the Oculus Home folder under Software/Manifests, and opened it with Notepad++, don't know if there is a clue in there or not...

 

 

{"canonicalName":"E_EagleDynamics_DCSWorld2OpenAlpha_bin_DCS","displayName":"DCS.exe","files":{"E:\\Eagle Dynamics\\DCS World 2 OpenAlpha\\bin\\DCS.exe":""},"firewallExceptionsRequired":false,"isCore":false,"launchFile":"E:\\Eagle Dynamics\\DCS World 2 OpenAlpha\\bin\\DCS.exe","launchParameters":""E:\\Eagle Dynamics\\DCS World 2 OpenAlpha\\bin/DCS.exe"","manifestVersion":0,"packageType":"APP","thirdParty":true,"version":"1","versionCode":1}

Don B

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | Gigabyte 4090 OC | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle | VPC Rotor TCS Base w/ Alpha-L Grip| Point Control V2|Varjo Aero|

Link to comment
Share on other sites

Here's what the new update is supposed to do:

 

Warning: using OH to open DCS will cause the GPU temp to go above 90c and the GPU fan to go above 80%.

I didn't want to see how much beyond these parameters it would go. I've not seen numbers like that. It would be interesting to know if others had the same experience when trying to launch DCS from within OH.

 

 

 

Capture.JPG

Capture.thumb.JPG.58068f2514df73825c2c9e5539e16e2b.JPG


Edited by fitness88
Link to comment
Share on other sites

Tried again starting from within Oculus Home this afternoon still no go for me, launches into the hangar still with no menu at all and no sound. Very strange, can launch outside of OH just fine.

 

I will wait and see if a future update to OH maybe takes care of it.

Don B

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | Gigabyte 4090 OC | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle | VPC Rotor TCS Base w/ Alpha-L Grip| Point Control V2|Varjo Aero|

Link to comment
Share on other sites

Tried again starting from within Oculus Home this afternoon still no go for me, launches into the hangar still with no menu at all and no sound. Very strange, can launch outside of OH just fine.

 

I will wait and see if a future update to OH maybe takes care of it.

 

 

The same for me as well.

I think there is some issue going on that's not too good as I mentioned previously, lots of stress on the system.

Link to comment
Share on other sites

Does this have something to do with how many versions of DCS you have installed? I have four versions, in the Oculus menu the icons look the same for all four as the executable file is the same so maybe it gets confused. It launches sometimes but other times I get the same, just an aircraft in the hanger.

I have a problem when trying to set PD etc in the oculus tray tool for each version because it will only save one executable called run and they all have an executable called run!!

Link to comment
Share on other sites

I have a problem when trying to set PD etc in the oculus tray tool for each version because it will only save one executable called run and they all have an executable called run!!

 

This seems to be working fine for me as far as my profile in OTT applying properly, I have mine pointed to DCS.exe.

Don B

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | Gigabyte 4090 OC | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle | VPC Rotor TCS Base w/ Alpha-L Grip| Point Control V2|Varjo Aero|

Link to comment
Share on other sites

DCS Launching w/ the hanger Scene and no UI is a Result of an Illegal Flag in the Launch Command.

 

ie in your Desktop ShortCut, Change your Target to :

"...../Eagle Dynamics/DCS World/Bin/DCS.EXE" -ADDED_ILLEGAL_FLAG_TEST

 

and you'll get the same thing, it's how I recorded my Hanger Scene Video a while back w/ no UI

 

 

Oculus is Adding a Parameter at the End of the EXE String that the DCS EXE does not Recognize.

 

Until Oculus Fixes the String Generation to not add random Flags to the Execution Path String, this problem wont go away.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, R7970 Lightning @ 1.2 / 6 GHz Memory

3x ASUS VS248HP + Oculus HMD, Thrustmaster Warthog HOTAS + MFDs

Link to comment
Share on other sites

Oculus is Adding a Parameter at the End of the EXE String that the DCS EXE does not Recognize.

 

Until Oculus Fixes the String Generation to not add random Flags to the Execution Path String, this problem wont go away.

 

Interesting, now I know - thanks for the info!

I will mention this over on the Oculus forums so maybe they will see it.

Don B

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | Gigabyte 4090 OC | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle | VPC Rotor TCS Base w/ Alpha-L Grip| Point Control V2|Varjo Aero|

Link to comment
Share on other sites

This seems to be working fine for me as far as my profile in OTT applying properly, I have mine pointed to DCS.exe.

 

It seems to work fine for me too when I set it to one version only, I point it to the DCS exe file which is called run exe in the DCS World folder, if I then want to set a profile for DCS 2 Alpha, I point it to the exe file in the DCS 2 folder which is also called run exe. When I save this profile there is only one profile saved, this happens when trying to make a profile for any DCS version on my system there is only one exe saved, I assume that what ever is saved in that profile will apply to which ever version I run so I don't seem to be able to have a different set up for each version. How do you get over this?

Link to comment
Share on other sites

I have mine pointed to DCS.exe, not Run.exe

 

Seems to apply properly for any version.

Don B

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | Gigabyte 4090 OC | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle | VPC Rotor TCS Base w/ Alpha-L Grip| Point Control V2|Varjo Aero|

Link to comment
Share on other sites

I have mine pointed to DCS.exe, not Run.exe

 

Seems to apply properly for any version.

 

OK thanks for that I will have to have a look at this later, I could only see run exe in my files so will take another look when I get a minute. Do you have a exe run in you DCS folder or just the DCS exe?

Link to comment
Share on other sites

OK thanks for that I will have to have a look at this later, I could only see run exe in my files so will take another look when I get a minute. Do you have a exe run in you DCS folder or just the DCS exe?

 

DCS.exe is in the "Bin" folder.

 

Edit: I just checked, does not matter which version I run, the settings I have in Oculus Tray Tool apply properly for each version - 1.5 and 2.1.

Just point it to the DCS.exe file, does not matter which version you browse to when setting it.


Edited by dburne

Don B

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | Gigabyte 4090 OC | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle | VPC Rotor TCS Base w/ Alpha-L Grip| Point Control V2|Varjo Aero|

Link to comment
Share on other sites

You can edit the "displayName" values so you can keep your different instances sorted. This won't be a problem once the versions are merged. :thumbup:

 

Great to know, thanks.

Now if I could just get the exe's to work inside Oculus Home...

Don B

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | Gigabyte 4090 OC | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle | VPC Rotor TCS Base w/ Alpha-L Grip| Point Control V2|Varjo Aero|

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...