Jump to content

Can't buy additional campaigns????


Slayer_42
 Share

Recommended Posts

Hey guys

 

when i try to buy a campaign on DCS via their website i get the message on screen saying "Requires DCS World version 1.5!", and i am unable to buy it! I haven't had any issues buying modules before and i definitely have an up to date version of both 1.5 and 2.0 so i why does the DCS website seem to think i dont have 1.5 on my computer??

 

cheers in advance

Link to comment
Share on other sites

  • ED Team

hi Slayer_42

 

which campaign are you trying to buy?

 

also ensure you are logged into your account on the store

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 64GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

thanks for the reply BIGNEWY, for some reason the situation seems to have resolved itself overnight? But just for the record the campaign i was trying to buy was the "A-10C Tactical Training Qualification Campaign" for DCS 1.5. And i can confirm i was definitely logged into DCS.

 

cheers

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...