Jump to content

Pitch/Roll Autopilot Won't Turn On


Recommended Posts

so i'm playing the Mt. Elbrus rescue mission, but with the huey swapped out for the Mi-8. when i begin the mission with the hot start option, i can't get the Pitch/Roll autopilot button to stay on.

 

i can activate the heading and altitude buttons OK, but when i click the pitch/roll autopilot button, it flashes green for a millisecond then turns off. i've been flying the Mi-8 for a while now and haven't seen this happen.

 

any ideas what could be causes this behavior?

 

thanks!

Acer Predator Triton 700 || i7-7700HQ || 512GB SSD || 32GB RAM || GTX1080 Max-Q || FFB II and Thrustmaster TWCS Throttle || All DCS Modules

Link to comment
Share on other sites

Is it powered up properly? All necessary switches and fuses on?

 

i believe so. if the other autopilot functions are working (altitude heading), wouldn't that mean the pitch/roll should as well?

Acer Predator Triton 700 || i7-7700HQ || 512GB SSD || 32GB RAM || GTX1080 Max-Q || FFB II and Thrustmaster TWCS Throttle || All DCS Modules

Link to comment
Share on other sites

Well, not quite. Pitch&roll channel needs co-pilot's attitude indicator to work (as it uses indicator's gyros to retrieve orientation from), so IF there's anything wrong with that instrument, the channel won't work either, while the rest of the autopilot will.

i7 9700K @ stock speed, single GTX1070, 32 gigs of RAM, TH Warthog, MFG Crosswind, Win10.

Link to comment
Share on other sites

Well, not quite. Pitch&roll channel needs co-pilot's attitude indicator to work (as it uses indicator's gyros to retrieve orientation from), so IF there's anything wrong with that instrument, the channel won't work either, while the rest of the autopilot will.

 

interesting. thanks for the info.this happens after a brand new loading of the game and the vehicle is hot. so nothing should be broken. but i'll go in and give her a fresh inspection now to see whats up

Acer Predator Triton 700 || i7-7700HQ || 512GB SSD || 32GB RAM || GTX1080 Max-Q || FFB II and Thrustmaster TWCS Throttle || All DCS Modules

Link to comment
Share on other sites

interesting. thanks for the info.this happens after a brand new loading of the game and the vehicle is hot. so nothing should be broken. but i'll go in and give her a fresh inspection now to see whats up

 

Pitch/Roll autopilot should be enabled by default for "Parking Hot" and "Runway" starts.

Link to comment
Share on other sites

Oddly enough, this is an issue that I have started having after last update also. I have been flying this chopper from day one and have gone over everything but it just doesn't stay on. Hmm......

 

so i'm not crazy! thanks for the confirmation

Acer Predator Triton 700 || i7-7700HQ || 512GB SSD || 32GB RAM || GTX1080 Max-Q || FFB II and Thrustmaster TWCS Throttle || All DCS Modules

Link to comment
Share on other sites

No problem seen here also (cold start or hot start) but I have not tried cold and high hot starts for a while.

The pitot tubes are hot and toasty before you depart?

I do not believe these are on with a hot start but I am unsure in cold conditions.


Edited by Rogue Trooper

My gaming system is pure DCS. Nothing but DCS, every bit of software that does not belong there is not there.... I hope!

HP G2 Reverb, Windows VR setting: IPD is 64.5mm, High image quality, 90Hz refresh rate. Steam: VR SS set to 100%, motionReprojectionMode set to "motionreproduction" and Locked in at 45 Hz display,

DCS: Pixel Density 1.0, Forced IPD at 55 (perceived world size), 0 X MSAA, 0 X SSAA. My real IPD is 64.5mm. Prescription VROptition lenses installed. VR Driver system: I9-9900KS 5Ghz CPU. XI Hero motherboard and RTX 3090 graphics card, 64 gigs Ram, No OC at the mo.

Vaicom user. Thrustmeter warthog user. MFG pedals with damper upgrade.... and what an upgrade! Total controls Apache MPDs set to virtual Realiy height.... . fabulous!

Link to comment
Share on other sites

  • 2 weeks later...

Any feed back on this problem dresoccer4?

My gaming system is pure DCS. Nothing but DCS, every bit of software that does not belong there is not there.... I hope!

HP G2 Reverb, Windows VR setting: IPD is 64.5mm, High image quality, 90Hz refresh rate. Steam: VR SS set to 100%, motionReprojectionMode set to "motionreproduction" and Locked in at 45 Hz display,

DCS: Pixel Density 1.0, Forced IPD at 55 (perceived world size), 0 X MSAA, 0 X SSAA. My real IPD is 64.5mm. Prescription VROptition lenses installed. VR Driver system: I9-9900KS 5Ghz CPU. XI Hero motherboard and RTX 3090 graphics card, 64 gigs Ram, No OC at the mo.

Vaicom user. Thrustmeter warthog user. MFG pedals with damper upgrade.... and what an upgrade! Total controls Apache MPDs set to virtual Realiy height.... . fabulous!

Link to comment
Share on other sites

  • 1 year later...

"Pitch&roll channel needs co-pilot's attitude indicator to work (as it uses indicator's gyros to retrieve orientation from"

 

This happened to me also, so I turned that on from right triangle switchbox and uncaged the attitude indicator and it worked. thanks

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...