Jump to content

Remove CH Product permanently (Win10)


Iku_CC
 Share

Recommended Posts

Howdy,

 

After latest Windows 10 update CH Product manager stopped working properly. So I decide to replace my good old CH Pro pedals with TM TFRD pedals.

 

Problem is that after removing CH Products I still have one uknown device on my system (which is chproduct. If I install control_manager-v4.55a.exe then this unknown device disappear and after I make uninstall for it all CH device seems to be removed at Windows Device Manager.

 

But after reboot that annoying unknown device is back again...:mad::mad:

 

How do I permanently remove this CH Product from my Windows 10?

 

If I look device manager after reboot there is three Unknown devices and if I look properties of these and Device instance path I get this information

CHPRODUCTS\VID_068E&PID_C020\1&10D0EA8D&0&0000

CHPRODUCTS\VID_068E&PID_C020\1&1A590E2C&2&0000

CHPRODUCTS\VID_068E&PID_C020\1&238A9B32&0&0000

 

If I make Scan for hardware chnages then two of them disappears and this one is there

CHPRODUCTS\VID_068E&PID_C020\1&10D0EA8D&0&0000


Edited by Iku64

 

[sIGPIC][/sIGPIC]

HP Z420 | Xeon E5-1650 @3.20GHz/3.70Ghz | 16Gb DDR3-1333 | ZOTAC GTX 980 Ti AMP! | Micron RealSSD C400 256Gb | Sound Blaster Z | TrackIR4 | Thrustmaster HOTAS Warthog| CH Pro pedals | Win 10 Pro 64-bit

 

Link to comment
Share on other sites

There is a USB device cleaner...ill post the name when I get home.

[sIGPIC][/sIGPIC]

Primary Computer

ASUS Z390-P, i7-9700K CPU @ 5.0Ghz, 32GB Patriot Viper Steel DDR4 @ 3200Mhz, ZOTAC GeForce 1070 Ti AMP Extreme, Samsung 970 EVO M.2 NVMe drives (1Tb & 500 Gb), Windows 10 Professional, Thrustmaster Warthog HOTAS, Thrustmaster Warthog Stick, Thrustmaster Cougar Throttle, Cougar MFDs x3, Saitek Combat Rudder Pedals and TrackIR 5.

 

-={TAC}=-DCS Server

Gigabyte GA-Z68XP-UD3, i7-3770K CPU @ 3.90GHz, 32GB G.SKILL Ripjaws DDR3 @ 1600Mhz, ZOTAC GeForce® GTX 970.

Link to comment
Share on other sites

Thx..I googled this usb cleaner but too many options so I wait your suggestion..:)

 

[sIGPIC][/sIGPIC]

HP Z420 | Xeon E5-1650 @3.20GHz/3.70Ghz | 16Gb DDR3-1333 | ZOTAC GTX 980 Ti AMP! | Micron RealSSD C400 256Gb | Sound Blaster Z | TrackIR4 | Thrustmaster HOTAS Warthog| CH Pro pedals | Win 10 Pro 64-bit

 

Link to comment
Share on other sites

I made more test and I found one Usb device cleaner...but it can't found this CH Control manager because it's not real usb device...it's component of Control Manager...if I install it..no error on device manager..but when I unisntall it..this error comes back. I found registery jey..but can't delete it...

 

[sIGPIC][/sIGPIC]

HP Z420 | Xeon E5-1650 @3.20GHz/3.70Ghz | 16Gb DDR3-1333 | ZOTAC GTX 980 Ti AMP! | Micron RealSSD C400 256Gb | Sound Blaster Z | TrackIR4 | Thrustmaster HOTAS Warthog| CH Pro pedals | Win 10 Pro 64-bit

 

Link to comment
Share on other sites

  • 2 years later...

I have the same issue, my foot pedals have stopped working and I see an unknown device but cannot get rid of it. When I reboot it comes back. Has anyone been able to get rid of everything and start from scratch, minus resetting/reinstalling Windows?

AMD Ryzen 9 3900x, 64GB DDR 4, MSI Ventus 2070 Super, Samsung 970 M.2 NVMe, WD Blue 512GB SSD, TM Warthog, CH Pro Pedals, Acer AH101 WMR

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...