Jump to content

Compositor Frame Drops


jza103
 Share

Recommended Posts

With the Oculus Rift, I started getting frequent compositor frame drops (seen by using Oculus Tray Tool HUD overlay) with either BETA 2.5.2.19157 or 2.5.2.19273. I also have the RELEASE version 2.5.2.18736 installed and it does not have this problem.

 

Here's how Oculus defines them:

 

Compositor Frames Dropped - Increments each time the compositor fails to present a new rendered frame at V-Sync (Vertical Synchronization).

From a user experience perspective even a single compositor frame drop is jarring and very noticable.

 

It doesn't appear to be GPU performance related as happens whether not I have all the settings on low, I'm just sitting at the main menu, flying at 15,000 ft over water with nothing else in view, or if I'm at a crowded airport. I can be getting 90 FPS and still see them pop up.

 

I've done all the basics, delete the metashaders, reinstall, make sure all other apps are closed, etc.. however it hasn't made any difference. Furthermore, under identical conditions the RELEASE version 2.5.2.18736 does not have this problem.

 

Any ideas? What other information can I provide that would help troubleshoot this?

 

I have an i7 6700K with a GTX 980TI and 32 Gigs of RAM and a fast SSD.

 

Thanks!

Link to comment
Share on other sites

Well I think you answered your own question, it doesn't happen on release version but does on open beta. Have same issues it's just the state of open beta at the moment and hopefully it gets ironed out

 

Sent from my SM-G892A using Tapatalk

I7-8700 @5GHZ, 32GB 3000MHZ RAM, 1080TI, Rift S, ODYSSEY +. SSD DRIVES, WIN10

Link to comment
Share on other sites

Good to know I'm not the only one. I didn't see anyone else mention this problem specifically so I wasn't sure if I was a corner case or not. Are you on the latest release version, I think it's 2.5.2.19273? If you are, do you not have the problem in there?

 

Now that I know I'm not the only one, this post will really just serve to bring awareness to ED of the issue so it doesn't make it into the next release version. The other 15,000+ view thread mostly is talking about performance issues related to frame rate issues and not compositor drops. If the devs are monitoring that thread, I'd be worried they wouldn't be aware that there are at least two issues being brought up.

Link to comment
Share on other sites

Good to know I'm not the only one. I didn't see anyone else mention this problem specifically so I wasn't sure if I was a corner case or not. Are you on the latest release version, I think it's 2.5.2.19273? If you are, do you not have the problem in there?

 

Now that I know I'm not the only one, this post will really just serve to bring awareness to ED of the issue so it doesn't make it into the next release version. The other 15,000+ view thread mostly is talking about performance issues related to frame rate issues and not compositor drops. If the devs are monitoring that thread, I'd be worried they wouldn't be aware that there are at least two issues being brought up.

 

 

Yes these 'compositor frame drops' (nice to know the name for them) are responsible for the steam background loading screen flashes. I also had to go back to the release version as they were occuring randomly. I also seem to get them (think its the same thing) when pilots eject, though it only happens the first time a pilot ejects so I just shoot down 4 WW2 friendlies and can then play on with no problems. If I start the game up anew though I then have to shoot down 4 more planes!

 

 

 

Also occur, if I turn clouds on, or if I use the bombs with the viggen or mig 21(at least last I checked).

 

 

 

It's the single biggest problem facing VR. FPS is not a problem IMO but the devs need to look into this problem above all else. They manifest as sudden drops in which you lose about 20/30 frames instantly.

 

 

 

Problem has been reported many times, but with the latest beta I wasnt able to identitfy the cause (clouds etc). Just happened randomly...

------------

 

3080Ti, i5- 13600k 32GB  VIVE index, VKB peddals, HOTAS VPC MONGOOSE, WARTHOG throttle, BKicker,

Link to comment
Share on other sites

I'm getting massive framedrops fx when planes explode or a damaged the first time. If you play the same mission 4-5 times it gets gradually better. Hardly a solution.

 

 

I've always thought this was an exclusive HTC vive problem. Can you tell me how it manifests on the oculus rift? Do you get flashes and see momentary loading screens as on the HTC VIVE?

------------

 

3080Ti, i5- 13600k 32GB  VIVE index, VKB peddals, HOTAS VPC MONGOOSE, WARTHOG throttle, BKicker,

Link to comment
Share on other sites

I've always thought this was an exclusive HTC vive problem. Can you tell me how it manifests on the oculus rift? Do you get flashes and see momentary loading screens as on the HTC VIVE?

 

I'm on a Samsung Odyssey HMD :)

 

I see the loading screen - sometmes for quite a long time. It not only breaks immersion but also make air to air combat in particular impossible.


Edited by Count Sessine
Link to comment
Share on other sites

I'm on a Samsung Odyssey HMD :)

 

I see the loading screen - sometmes for quite a long time. It not only breaks immersion but also make air to air combat in particular impossible.

 

 

Is this mostly in Jet, Helicopter, or WW2 plane combat?

 

 

For me helicopters are fine.

WW2 planes are basically fine but require a bit of breaking in (you need to shoot them down (make pilots eject) a few times to get rid of the loading flashes)

Jets I haven't really tried enough, but in my experience only flash when using certain types of bombs, or when they explode.

Important thing to rememeber turn clouds off! If you don't you will get random flashes.

 

 

Trouble is although its 100 percent a problem with the game itself there are any number of reasons it might be happening. You might for example just need to update your GPU drivers

 

Really wish the devs would fix this!


Edited by Wolf8312

------------

 

3080Ti, i5- 13600k 32GB  VIVE index, VKB peddals, HOTAS VPC MONGOOSE, WARTHOG throttle, BKicker,

Link to comment
Share on other sites

Is this mostly in Jet, Helicopter, or WW2 plane combat?

 

 

For me helicopters are fine.

WW2 planes are basically fine but require a bit of breaking in (you need to shoot them down (make pilots eject) a few times to get rid of the loading flashes)

Jets I haven't really tried enough, but in my experience only flash when using certain types of bombs, or when they explode.

Important thing to rememeber turn clouds off! If you don't you will get random flashes.

 

 

Trouble is although its 100 percent a problem with the game itself there are any number of reasons it might be happening. You might for example just need to update your GPU drivers

 

Really wish the devs would fix this!

 

It is exclusively reported from the M2000 as it is the only plane I fly these days. But it happens on all maps.

 

I noticed the drops kick in when planes (both my own and others) are destroyed, bombs fall, missiles are fired and curiously also when I turn on the radar at the start-up on the ground.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...