Jump to content

X-52 Pro Throttle not responding


Recommended Posts

I'm sorry but i've spent over an hour on this...

The throttle works fine in F15C. I can't for the life of me get it to work on the FA18. The assigment appears to work. The throttle responds in the axis setup. But in game when i do a free flight instant mission the throttle refuses to do anything.

Please help me with what i'm missing....

 

The buttons of the joystick also don't auto fill when clicking the button i want to assign the function to. For instance cannon and clicking the trigger.

 

I tried firing up the profiler too but it didn't help.

Link to comment
Share on other sites

Try hitting "escape" ang go to controls option , assign there ? Otherwise , if you are running open beta , without the latest hotfix , there was a major controls problem . Check for update . And no need to apologise...

9700k @ stock , Aorus Pro Z390 wifi , 32gb 3200 mhz CL16 , 1tb EVO 970 , MSI RX 6800XT Gaming X TRIO , Seasonic Prime 850w Gold , Coolermaster H500m , Noctua NH-D15S , CH Pro throttle and T50CM2/WarBrD base on Foxxmounts , CH pedals , Reverb G2v2

Link to comment
Share on other sites

I'm sorry but i've spent over an hour on this...

The throttle works fine in F15C. I can't for the life of me get it to work on the FA18. The assigment appears to work. The throttle responds in the axis setup. But in game when i do a free flight instant mission the throttle refuses to do anything.

Please help me with what i'm missing....

 

The buttons of the joystick also don't auto fill when clicking the button i want to assign the function to. For instance cannon and clicking the trigger.

 

I tried firing up the profiler too but it didn't help.

Make sure you are not playing in "game mode" (easy mode)

F18 only work if the game is set to "sim mode". They have only done a "half job" at controller option in game mode and then "forgot" about the rest. I dont know why and have asked a lot of times but no feedback...

I also use a X-52 Pro and it work perfect in "sim mode". But I dont use the software for the stick


Edited by Havremonster
Link to comment
Share on other sites

Thanks for the tip. I'll make sure it's in Sim mode when i get home.

 

Smokey

I'm not sure how to tell if i'm running open beta. I just installed the latest DCS world and FA18 from steam. When you say hotfix will the steam version just update to the latest release when i look for updates or is there some back door process? I googled around a little bit but it sounded like the hotfix was just an interim release to fix certain bugs.

Link to comment
Share on other sites

Yes , the bugs in question dealt with a controller assignment disaster . I'm not on Steam , so can't help you there . Checking the installation directory should tell version . "DCS WORLD" for stable , otherwise will state "OPEN BETA" .


Edited by Svsmokey

9700k @ stock , Aorus Pro Z390 wifi , 32gb 3200 mhz CL16 , 1tb EVO 970 , MSI RX 6800XT Gaming X TRIO , Seasonic Prime 850w Gold , Coolermaster H500m , Noctua NH-D15S , CH Pro throttle and T50CM2/WarBrD base on Foxxmounts , CH pedals , Reverb G2v2

Link to comment
Share on other sites

I put it in sim mode and went to the steam game options and changed to open beta and it works now. Some of the buttons aren't recognized on the throttle but it sounds like that can be fixed if you use the saitek software. I think it's good enough for now at least!

Thanks for the help!

Link to comment
Share on other sites

You can cross-check button operation in Windows devices . That verifies the button operation is getting into the 'puter . Glad to hear of progress !

9700k @ stock , Aorus Pro Z390 wifi , 32gb 3200 mhz CL16 , 1tb EVO 970 , MSI RX 6800XT Gaming X TRIO , Seasonic Prime 850w Gold , Coolermaster H500m , Noctua NH-D15S , CH Pro throttle and T50CM2/WarBrD base on Foxxmounts , CH pedals , Reverb G2v2

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...