Jump to content

[REPORTED] Sky redraws every time exiting F10 map


imacken
 Share

Recommended Posts

How long does it take to fix this? Been posting about it for a long time now.

In VR, (more or less) every time I exit the F10 map, the sky gets redrawn. Sometimes takes a few seconds, and can cause problems with dark cockpits, etc.

Quite hard to capture, but the attached hopefully shows the effect to an extent.

Intel i7 12700K · MSI Gaming X Trio RTX 4090 · ASUS ROG STRIX Z690-A Wi-Fi · MSI 32" MPG321UR QD · Samsung 970 500Gb M.2 NVMe · 2 x Samsung 850 Evo 1Tb · 2Tb HDD · 32Gb Corsair Vengance 3000MHz DDR4 · Windows 11 · Thrustmaster TPR Pedals · Tobii Eye Tracker 5 · Thrustmaster F/A-18 Hornet Grip · Virpil MongoosT-50CM3 Base · Virpil Throttle MT-50 CM3 · Virpil Alpha Prime Grip · Virpil Control Panel 2 · Thrustmaster F-16 MFDs · HTC Vive Pro 2 · Total Controls Multifunction Button Box

Link to comment
Share on other sites

  • 2 weeks later...

Yep, only in VR. Been like that for months, and have posted several times on this topic. Goes from dark sky to normal in about 1 or 2 secsonds.

Intel i7 12700K · MSI Gaming X Trio RTX 4090 · ASUS ROG STRIX Z690-A Wi-Fi · MSI 32" MPG321UR QD · Samsung 970 500Gb M.2 NVMe · 2 x Samsung 850 Evo 1Tb · 2Tb HDD · 32Gb Corsair Vengance 3000MHz DDR4 · Windows 11 · Thrustmaster TPR Pedals · Tobii Eye Tracker 5 · Thrustmaster F/A-18 Hornet Grip · Virpil MongoosT-50CM3 Base · Virpil Throttle MT-50 CM3 · Virpil Alpha Prime Grip · Virpil Control Panel 2 · Thrustmaster F-16 MFDs · HTC Vive Pro 2 · Total Controls Multifunction Button Box

Link to comment
Share on other sites

Yep, only in VR. Been like that for months, and have posted several times on this topic. Goes from dark sky to normal in about 1 or 2 secsonds.

 

I'll see if its reported if not will report if I can reproduce.

 

If it's any help, this issue is totally tied to the SceneVR hanger render used at the main menu, which also renders when opening the F10 map during flight (you can see as much as it's in the background when in the map view).

 

It feels like it's because the engine is being asked to very quickly render back and fourth between 2 completely differing 3D environments...and struggles to do it without visible artifacts.

 

As further evidence tying the issue to the VR hanger render - I used to edit the sceneVR.lua to stop the hanger rendering at game startup, providing a simple grey void with just the menu...this had the additional benefit of eliminating this black sky/redraw issue when using the map during flight.

 

Unfortunately, something changed with the update before last wherein the SceneVR.lua edit no longer works and simply crashes the game at startup. which is a shame.

 

Hopefully this helps with narrowing down the problem.


Edited by Fubarbrickdust

9700k@5.2Ghz | GTX 1080ti | 32gb Ram@3200Mhz | 512gb M.2 NVME SSD

Oculus Rift S | VKB GF Pro Mk.II+MCG Pro (rotary wing) | BRD DS-Raven (fixed wing) | MFG Crosswind V2 | Jetseat+SSA/SSM | SimLab GT1 80/20 Rig | NLR Motion Platform V3 | Quad Bass Shaker Setup

DIY Control Panels: 'White Rhino' Throttle | UFC | MFBB Left | MFBB Right | MFBB Centre | WEP-TECH ACP | HYD-MECH LDG | SYS-ELEC | AN/ARC Radio

Link to comment
Share on other sites

I have seen this happen ever since the new memory manager was introduced: it was one of the reasons why so many people asked for an option to disable that new memory manager on high-end systems since it introduced more problems than it fixed.

The cockpit lighting suffers from the same problem: it is overly dark after exiting F10, and it either takes a few moments to re-render the correct lighting, or until the aircraft moves from its original spot (when on the ground).

Spoiler

Ryzen 9 5900X | 64GB G.Skill TridentZ 3600 | Gigabyte RX6900XT | ASUS ROG Strix X570-E GAMING | Samsung 960Pro NVMe 1TB | HP Reverb G2
Pro Flight Trainer Puma | VIRPIL MT-50CM2+3 base / CM2 x2 grip with 200 mm S-curve extension + CM3 throttle + CP2/3 + FSSB R3L + VPC Rotor TCS Plus base with SharKa-50 grip mounted on Monstertech MFC-1 | TPR rudder pedals

OpenXR | PD 1.0 | 100% render resolution | DCS "HIGH" preset

 

Link to comment
Share on other sites

This is great! After several posts on this without a reply, I was beginning to think I was imagining it!


Edited by imacken

Intel i7 12700K · MSI Gaming X Trio RTX 4090 · ASUS ROG STRIX Z690-A Wi-Fi · MSI 32" MPG321UR QD · Samsung 970 500Gb M.2 NVMe · 2 x Samsung 850 Evo 1Tb · 2Tb HDD · 32Gb Corsair Vengance 3000MHz DDR4 · Windows 11 · Thrustmaster TPR Pedals · Tobii Eye Tracker 5 · Thrustmaster F/A-18 Hornet Grip · Virpil MongoosT-50CM3 Base · Virpil Throttle MT-50 CM3 · Virpil Alpha Prime Grip · Virpil Control Panel 2 · Thrustmaster F-16 MFDs · HTC Vive Pro 2 · Total Controls Multifunction Button Box

Link to comment
Share on other sites

I rarely see this on SP but do get it occasionally on MP can be anywhere on map (MP Caucasus map) it doesn't seem to stop me doing anything in game when it happens, actually it looks cool and dark in a surreal way. :D

Control is an illusion which usually shatters at the least expected moment.

Gazelle Mini-gun version is endorphins with rotors. See above.

 

Currently rolling with a Asus Z390 Prime, 9600K, 32GB RAM, SSD, 2080Ti and Windows 10Pro, Rift CV1. bu0836x and Scratch Built Pedals, Collective and Cyclic.

Link to comment
Share on other sites

I'll see if its reported if not will report if I can reproduce.

 

NineLine, have you now reported this very annoying issue?

Intel i7 12700K · MSI Gaming X Trio RTX 4090 · ASUS ROG STRIX Z690-A Wi-Fi · MSI 32" MPG321UR QD · Samsung 970 500Gb M.2 NVMe · 2 x Samsung 850 Evo 1Tb · 2Tb HDD · 32Gb Corsair Vengance 3000MHz DDR4 · Windows 11 · Thrustmaster TPR Pedals · Tobii Eye Tracker 5 · Thrustmaster F/A-18 Hornet Grip · Virpil MongoosT-50CM3 Base · Virpil Throttle MT-50 CM3 · Virpil Alpha Prime Grip · Virpil Control Panel 2 · Thrustmaster F-16 MFDs · HTC Vive Pro 2 · Total Controls Multifunction Button Box

Link to comment
Share on other sites

It is possible this only happens on nVidia cards where I have seen it also. But on AMD i don’t think I have this issue.

 

I'm getting this on my AMD Vega 64 card (8GB Video RAM) and 32GB System RAM, so it's not just a Nvidia specific issue.

 

As said earlier, it started with the new 'memory manager' which (for me at least) has not provided any observable advantages on my system.

Ryzen 3900x | 32GB DDR4 @ 3600MHz | Gigabyte X570-Aorus Ultra



Gigabyte GeForce RTX 2080 Ti Gaming OC | Samsung C34F791 | HTC Vive Pro | Windows 10 Pro x64

Auzentech X-Fi Forte | Thrustmaster MFDs, Warthog & Cougar with Simped-Vario F16C Pedals

Link to comment
Share on other sites

As said earlier, it started with the new 'memory manager' which (for me at least) has not provided any observable advantages on my system.

 

Yep, same here.

Intel i7 12700K · MSI Gaming X Trio RTX 4090 · ASUS ROG STRIX Z690-A Wi-Fi · MSI 32" MPG321UR QD · Samsung 970 500Gb M.2 NVMe · 2 x Samsung 850 Evo 1Tb · 2Tb HDD · 32Gb Corsair Vengance 3000MHz DDR4 · Windows 11 · Thrustmaster TPR Pedals · Tobii Eye Tracker 5 · Thrustmaster F/A-18 Hornet Grip · Virpil MongoosT-50CM3 Base · Virpil Throttle MT-50 CM3 · Virpil Alpha Prime Grip · Virpil Control Panel 2 · Thrustmaster F-16 MFDs · HTC Vive Pro 2 · Total Controls Multifunction Button Box

Link to comment
Share on other sites

I have the same problem. In rare occasions in MP, going from the F10 map back to F1 even crashes my video driver beyond recovery. Meaning, Im still in game, I hear the throttle sound reacting to throttle movement, but the video including the mouse is completely frozen.

 

Every time I switch to the F10 map, the delay to re-render the cockpit iseems to be very significant and I need to hope the game wont crash. this was working find a few patches ago (not entirely sure when it changed, but not too long ago).

 

this is using Oculus Rift on GTX1080 latest video drivers

Link to comment
Share on other sites

I have that issue as well. An option of disabling the VR hangar would be nice to have since it seems to be the issue.

 

+1

 

Just some black background in front of which the menu floats would be fine by me as well.

PC: AMD Ryzen 9 5950X | MSI Suprim GeForce 3090 TI | ASUS Prime X570-P | 128GB DDR4 3600 RAM | 2TB Samsung 870 EVO SSD | Win10 Pro 64bit

Gear: HP Reverb G2 | JetPad FSE | VKB Gunfighter Pro Mk.III w/ MCG Ultimate

 

VKBNA_LOGO_SM.png

VKBcontrollers.com

Link to comment
Share on other sites

Have this issue as well, quite often...looking forward to a fix.

VR Cockpit (link):

Custom Throttletek F/A-18C Throttle w/ Hall Sensors + Otto switches | Slaw Device RX Viper Pedals w/ Damper | VPC T-50 Base + 15cm Black Sahaj Extension + TM Hornet or Warthog Grip | Super Warthog Wheel Stand Pro | Steelcase Leap V2 + JetSeat SE

 

VR Rig:

Pimax 5K+ | ASUS ROG Strix 1080Ti | Intel i7-9700K | Gigabyte Z390 Aorus Master | Corsair H115i RGB Platinum | 32GB Corsair Vengeance Pro RGB 3200 | Dell U3415W Curved 3440x1440

Link to comment
Share on other sites

+1

 

Just some black background in front of which the menu floats would be fine by me as well.

 

ooooh, I did not know that it was actually defaulting to the VR load screen. I am using a mod called VR MenuReadyRoom which is awesome, but apparently thats causing the issue for me.

 

I just tested with that mod disabled and now the F10 map loads in the fraction of a second back to the cockpit so the issue seems to be gone ?!

Link to comment
Share on other sites

I have no mods...I get the brief black sky thing when returning from the F10 map too.

Intel Core i7 6700K @ 4.5GHz. Asus-Z170-PRO MB

CORSAIR H105 HYDRO CPU COOLER.

EVGA GTX 1080Ti FTW3 Elite.

16GB DDR4 2666MHZ HYPERX SAVAGE.

SAMSUNG M.2 SSD 128GB SM951 Boot Drive.

SAMSUNG SSD 500GB EVO Working Drive.

Windows 10 Professional

Link to comment
Share on other sites

  • 2 weeks later...
I've seen it since then too. Something changed in that patch to create the problem.

 

Exactly. We still haven’t seen a confirmation fron NineLine on this as being reported.

Intel i7 12700K · MSI Gaming X Trio RTX 4090 · ASUS ROG STRIX Z690-A Wi-Fi · MSI 32" MPG321UR QD · Samsung 970 500Gb M.2 NVMe · 2 x Samsung 850 Evo 1Tb · 2Tb HDD · 32Gb Corsair Vengance 3000MHz DDR4 · Windows 11 · Thrustmaster TPR Pedals · Tobii Eye Tracker 5 · Thrustmaster F/A-18 Hornet Grip · Virpil MongoosT-50CM3 Base · Virpil Throttle MT-50 CM3 · Virpil Alpha Prime Grip · Virpil Control Panel 2 · Thrustmaster F-16 MFDs · HTC Vive Pro 2 · Total Controls Multifunction Button Box

Link to comment
Share on other sites

+1 yep seeing it too. Just come back to DCS after a little break to get up to speed for the imminent F-14 release!

 

I regularly take an extended break from DCS to hopefully come back to an improved product - never really happens thou. Pretty sure my performance in VR is worse than when I left, incl this, which TBH is the least of my problems. Now sitting on the tarmac/runway looking in the direction of the hangars at Vegas and I am getting 22 FPS in the Rift!! Never seen that before lol.

 

I swear to god if I dare take another break I will come back to negative FPS in DCS using VR...and yes I am sure somehow, someway ED will make that a thing ;-)

Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |

Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit | TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

I'm not playing in VR, but I now experienced this problem for the first time when playing MP (Buddyspike BlueFlag) last weekend. It got so bad, that at some point midmission, that it caused mini freezes everytime I exited the F10 map and almost crashed the game/driver. The graphic card fans also started spinning at max speed all of a sudden, just when exiting the F10 map. They calmed down again after a few seconds. I've never had that before. I switched from a AMD R9 280X to a Nvidia RTX 2080 the week before, if that's relevant.


Edited by QuiGon

Intel i7-12700K @ 8x5GHz+4x3.8GHz + 32 GB DDR5 RAM + Nvidia Geforce RTX 2080 (8 GB VRAM) + M.2 SSD + Windows 10 64Bit

 

DCS Panavia Tornado (IDS) really needs to be a thing!

 

Tornado3 small.jpg

Link to comment
Share on other sites

Pretty sure my performance in VR is worse than when I left

 

Odd, since mine is considerably better, and we have pretty much the same system configuration.

Since recently I am able to fly with MSAA x2 enabled (along my usual settings that are pretty much maxed out and PD 1.5) and good framerates, which I contribute to both ED's work on optimisation, and more mature nVidia drivers.

 

In the past I have tried several times to fly with MSAA enabled, which resulted in abysmal frame-rates...

 

 

 

 

 

Back on topic, the sky being redrawn is seriously annoying, especially during night operations...

Spoiler

Ryzen 9 5900X | 64GB G.Skill TridentZ 3600 | Gigabyte RX6900XT | ASUS ROG Strix X570-E GAMING | Samsung 960Pro NVMe 1TB | HP Reverb G2
Pro Flight Trainer Puma | VIRPIL MT-50CM2+3 base / CM2 x2 grip with 200 mm S-curve extension + CM3 throttle + CP2/3 + FSSB R3L + VPC Rotor TCS Plus base with SharKa-50 grip mounted on Monstertech MFC-1 | TPR rudder pedals

OpenXR | PD 1.0 | 100% render resolution | DCS "HIGH" preset

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...