Jump to content

Stable Release-TDC Axis Commands Vertical and Horizontal No longer work


Recommended Posts

I just updated Stable Release tonight for DCS World. Everything works perfectly with the exception that I've noticed my TDC does not work in the Horizontal or Vertical Axis anymore. I'm talking about assigning axis commands to the little TDC button on the Thrustmaster Throttle. I have a Thrustmaster Warthog HOTAS. When looking in the Axis Commands menu, the keybinds are there for Horizontal and Vertical axis but when rolling the button, nothing. All other slewable buttons like the "slider" work, pitch and roll on joystick work, throttles work but not the little TDC in the horizontal or vertical axis.

 

I first noticed this while trying out the Hornet tonight. Then tried other aircraft including Su-27 and F-16C. TDC slew in the horizontal and vertical axis does not work.

 

It was working fine last night before I updated today.

 

Is anyone else noticing this or having this particular problem?

Link to comment
Share on other sites

Not me, works just as before the stable update.

Win10 Pro 64-bit, Ryzen 5800X3D, Corsair H115i, Gigabyte X570S UD, EVGA 3080Ti XC3 Ultra 12GB, 64 GB DDR4 G.Skill 3600. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

Hey gentlemen, thank you for the responses. I've actually resolved the issue this morning. Here's what happened and how I resolved it. I put it here in case anyone else runs into this problem.

 

First off I don't think it was a DCS World Bug. I think something coincidentally just happened with my HOTAS communicating with my PC. After trying different modules and seeing that everything worked flawless except those two axis' for the TDC button, I then went into IL-2 Great Battles to see if I could map those axis' to that game's controller settings. I couldn't even though I should have been able to. Okay, that told me it's not DCS World. It has to be something with my HOTAS equipment itself or something in the way Windows 10 is not seeing my one button and it's two axis'.

 

So then I went to my "Devices" section in Windows 10 and looked at the controllers and opened them up to check that each button was working etc. Everything again was working perfectly except the X and Y axis of that TDC button. They should have been working but were not. Okay, that tells me maybe connections in the Warthog TDC itself are to blame.

 

So I do the next best thing I can think of and that is unplug my Warthog Throttle and the Joystick to be safe and let them sit for about an hour.

 

Plug both back in and check the Devices again in Windows 10 and low and behold, all axis, both Y and X for the TDC button now work and are showing so in the game controller interface.

 

I then start DCS World and fly and hurrah!!!, TDC now slews like it should for all modules. I'm back in the business of flying my favorite flight sim.

 

Not a DCS World Bug. Issue Resolved.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...