Jump to content

[REPORTED]DCS Vsync option seriously affects VR performance


some1
 Share

Recommended Posts

In theory Vsync should not matter in VR because it's disabled there. But in case of DCS, if the option is left enabled in the game settings, then it severely affects frametimes on my system and cause a lot of stutters.

 

This is with Vsync OFF:

B5BTKZk.jpg

 

 

This is with Vsync ON:

rkHb5P9.jpg

 

 

You can see a pattern of raising "spikes" in GPU frametimes, that repeats every few seconds. If there's not enough headroom left, it will cause drops below 45 FPS and massive stutter. 

 

This only happens for me if Vsync in DCS options is enabled and Vsync in nVidia control panel is left at its default "use the 3D application" setting. If the Vsync is globally forced in nVidia drivers for all games, then the checkbox in DCS does nothing and the performance is fine.

 

So for me all worked nicely until I upgraded graphics card to 3080 and wiped clean GPU drivers, which reset nVidia profile to default setting. Since then I've been wondering why the performance in DCS is so bad despite better hardware. Turns out it wasn't the case of bad drivers or some recent DCS update, but a silly checkbox that shouldn't even affect anything. 

Hardware: Virpil T-50CM, Hotas Warthog, Hotas Cougar, Slaw Rudder, Wheel Stand Pro, GVL224 Trio Throttle, Thrustmaster MFDs, Saitek Trim wheel, Trackir 5, Reverb

Link to comment
Share on other sites

  • ED Team

Interesting,

 

will ask the team about this, 

 

thanks

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 64GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

  • ED Team

We will be disabling Vsync while VR is enabled. This will be in a future patch. 

 

thanks

  • Like 1

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 64GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

  • BIGNEWY changed the title to [REPORTED]DCS Vsync option seriously affects VR performance

About this I also found that setting vsync to fast in nvidia control panel helps with VR regardless of the dcs setting

Vincent "Virus" 

Base: VPForce "Rhino" Force Feedback base + Virpil T-50CM2 Grip

Throttle: Winwing Orion F18 Throttle with Fingerlift Add-On

Rudder: MFG Crosswind v3 Rudder with damper and Combat Pedals

Misc: Trackir v5 pro, Razer Tartarus, JetSeat, Heavily Modded Speedmaster Flight Seat

System: R9-5900x, 64GB Ram, Evga 2080ti, Ultrawide 34" Monitor

Link to comment
Share on other sites

I can confirm the vsync problem. Even when vsync in DCS is set to off and in Nvidia control panel is forced off,  FPS are still limited to 62-63 (2D, lowest settings). When vsync is forced to fast (from the control panel), FPS are 150 constantly. The difference in VR is also huge.


Edited by Brainless

Ryzen 5900X (Water), 32GB DDR4@3600CL16, ASUS Strix GTX 1080 Ti (Water), U4021QW, Samsung 980 Pro 2TB, 2x1000GB RAID 1, 2000GB,

Thrustmaster Warthog + MFG Crosswind, HMD Odyssey+

Link to comment
Share on other sites

Can someone please clarify, since it's not that clear from what is written here. For best performance in VR what is the workaround:

 

1. Uncheck Vsync in Game settings

2. What should the setting in Nvidia Control Panel be set to? Fast, or Use 3d Application Setting? Off?


Edited by Lurker

Specs: Win10, i9-9900KF@5Ghz, 32GB DDR4 RAM 3200XMP, 1 TB M2 NVMe SSD, KFA2 RTX3090, VR G2 Headset, Warthog Throttle+Saitek Pedals+MSFFB2  Joystick. 

Link to comment
Share on other sites

Can someone please clarify, since it's not that clear from what is written here. For best performance in VR what is the workaround:
 
1. Uncheck Vsync in Game settings
2. What should the setting in Nvidia Control Panel be set to? Fast, or Use 3d Application Setting? Off?

You can try different combos and see how it performa with your rig I guess? Should be a couple of combos anyway


Sent from my iPhone using Tapatalk
Link to comment
Share on other sites

  • 1 year later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...