Jump to content

Cockpits in FC3 aircraft do not update when new waypoints are set through mission scripting

Recommended Posts

I believe I have found a bug which applies to all FC3 aircrafts, while doing the scripting for one of the missions. I believe this might be trivial to fix.


This bug affects FC3 airplanes when mission author attempts to allocate alternative route to spawned player aircraft. The issue occurs when waypoints get update via script and do not get reflected in cockpit instruments.

Environment: Open BETA,

Steps to reproduce:

  1. Download the attached mission file
  2. Start DCS, load the mission file and start a mission
  3. Select your slot (I recommend one of the flankers, since they have the most obvious representation of navigation routes)
  4. Turn on electric power (RSHIFT+L)
  5. Switch NAV mode to ENR/МРШ (1)
  6. Observe that next nav point is to the left as specified in mission editor
  7. Activate the Radio Menu (BACKSLASH => \ )
  8. Select Other (F10)
  9. Select Waypoint Problem Demonstration (F2)
  10. Select Assign new route (F1)
  11. Observer that no change occurred on cockpit interfaces
  12. Cycle Switch NAV mode to ENR/МРШ (4 times press 1)
  13. Observe that NAV plan got update for all instruments





Edited by okopanja
Added attachments
Link to comment
Share on other sites

  • 3 weeks later...

I've just tried your mission and I added some other aircraft to see if it would work with them. So far, no joy. Can you give me an example of a module which gets its waypoints updated by this method?

Don't accept indie game testing requests from friends in Discord. Ever.

Link to comment
Share on other sites


I just downloaded the same mission and tried it with: J-11A and A-10A. (I recommend J-11a since you see in the display how navpoints got changed)

The problem can still be reproduced. I did make a type in missions instructions: to activate the menu instead of backspace you need to hit the backslash, so you can get the menu.

Essentially you can see in the youtube video I left what occurs. Initially the navigation plan is to the left (nord-west). Once you use the menu, the script I wrote allocated the new navigation plan, which leads to the right side (nord-east)

This thing has 3 subvariants:

1. SP

2. Multiplayer, hosted inside the same process where you play the DCS

3. Multiplayer, hosted inside dedicated server


For cases 1 and 2: the navpoints will be changed by script, with defect being that no update occurs until you fully cycle NAV modes

For case 3: editing of the nav point does not work at all

Please try 1 and 2, and for the 3 I can bring up my home server if you wish to try that one.



Link to comment
Share on other sites

I'll make the request. Can you please confirm this featue ("pilot:Route(WayPoints)") only works for FC3 aircraft? I couldn't get it to work with recent modules.

Edited by Flappie

Don't accept indie game testing requests from friends in Discord. Ever.

Link to comment
Share on other sites

That's what I thought. It looks more like a hack to me than anything else. I'm not sure devs will do anything about it, apart maybe prevent it to work in SP.

That is why I prefer not to report it, sorry.


Don't accept indie game testing requests from friends in Discord. Ever.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...