Jump to content

Fire button stops working


3Sqn_Sven
 Share

Recommended Posts

I'm having repeated instances of my weapons release not working. I'm using the ERI mod, otherwise a stock game. Will be fine for about half an hour, then all of a sudden gun trigger and missiles won't work. Been flying the F-15 mostly but it also happens in the russian jets. Same thing happened to Ruggbutt.

3Sqn - Largest distributor of Flanker, Fulcrum and Frogfoot parts in the Black Sea Region

Link to comment
Share on other sites

I had a similiar problem. I uninstalled the Yoda ERI mod awhile back because of this, it's relate to numpad 1 button. like ruggbutt reported the bug on your forums.

 

if you want to use ERI mod. dont touch the numpad 1 button

Maximus, The only real Maximus in DCS World. :music_whistling:

 

I am not associated to viper 33 | Maximus. he is the imposter.

Link to comment
Share on other sites

I'm using the stock game, and still sometimes I cannot launch a missile. And yes, it often happens 20-30 mins into the flight, when i often am out of med-range missiles and sneaking for heater kills. It costed me a few lost planes. I fly russian birds, and it has happened on almost all missiles - R-27ER/ET/77.

Last night I was sneaking on an eagle, and was <10km away, had seeker lock on my ET, had LA and it didn't fire. We closed in, merged and all of this time I was trying to launch it with no luck. I did not have a stuck modifier cause everything else on the kbd and joy was working. Really weird!

Link to comment
Share on other sites

I'm not using the keyboard for anything so it's kind of weird. From Ruggs description of the problem, his issue did seem directly related to the keypad as he uses it. I don't through...

3Sqn - Largest distributor of Flanker, Fulcrum and Frogfoot parts in the Black Sea Region

Link to comment
Share on other sites

I am getting exactly the same issue. Stock FC2 install using CH Fighter stick.

It happens randomly, all launch parameters met, pickle (press,2 bananas then release the button) no missile launch.

 

A second or on some occasions a third press hold release will result in missile launch.

Link to comment
Share on other sites

Now when I come to think of it... Missiles and systems aren't 100% reliable, from talks with real fighter pilots, not everything works the way it should, when you want it to. Radars not being able to lock, missiles not being able to track or dropping dead from the pylons, or even remaining on the pylon are things that rarely, but do happen in RL. I doubt this has been modeled in FC2, but would be a nice touch.

 

Entering a fight not being 100% sure if everything will work perfectly would be a nice addition to the atmosphere and the immersion of the sim... Even when you close in, press the trigger and nothing happens... "Oh sh*tttttttt"... what a thrill :D

Link to comment
Share on other sites

I'm using the stock game, and still sometimes I cannot launch a missile.

 

Does this happen with all weapons including the gun that you can't fire Fahhh?

 

I had the same issue as you Sven, no cannon or missiles in the F-15. Since I uninstalled the ERI mod the problem went away. Now, I can't say with 100% certainty, because I did not thoroughly test that ERI was causing the issue, but in my case it seemed to be.

Link to comment
Share on other sites

I have a Microsoft X6 keyboard that has removable keypad (so can be attached either left or right) but I don't use it (it is not attached to the keyboard proper) and I get this problem. I don't use Yoda's ERI mod at the moment either.

 

I did have missile firing problems when in windowed mode, even when the window was fullscreen size. Most of my keyboard/missile launch problems went away when I ensured that the window was full size *and* the "fullscreen" option was checked. It appears focus in LockOn would be lost and then would come back after a few minutes (also meant I couldn't change nav mode etc). I've also found that re-mapping the chat commands to the FC1.12 bindings would also periodically cause strange keyboard behaviour - but I have not investigated this thoroughly to ensure it wasn't me making a mistake.

 

Anyway, my point is you ought to have the "fullscreen" option ticked or other applications can steal keyboard input "focus" (looks like TeamSpeak 3 likes to do this).

Link to comment
Share on other sites

No problems here, using ERI and in full screen mode.


Edited by Pilotasso

[sigpic]http://forums.eagle.ru/signaturepics/sigpic4448_29.gif[/sigpic]

My PC specs below:

Case: Corsair 400C

PSU: SEASONIC SS-760XP2 760W Platinum

CPU: AMD RYZEN 3900X (12C/24T)

RAM: 32 GB 4266Mhz (two 2x8 kits) of trident Z RGB @3600Mhz CL 14 CR=1T

MOBO: ASUS CROSSHAIR HERO VI AM4

GFX: GTX 1080Ti MSI Gaming X

Cooler: NXZT Kraken X62 280mm AIO

Storage: Samsung 960 EVO 1TB M.2+6GB WD 6Gb red

HOTAS: Thrustmaster Warthog + CH pro pedals

Monitor: Gigabyte AORUS AD27QD Freesync HDR400 1440P

 

Link to comment
Share on other sites

hmmm what operating system guys?

[sigpic]http://forums.eagle.ru/signaturepics/sigpic4448_29.gif[/sigpic]

My PC specs below:

Case: Corsair 400C

PSU: SEASONIC SS-760XP2 760W Platinum

CPU: AMD RYZEN 3900X (12C/24T)

RAM: 32 GB 4266Mhz (two 2x8 kits) of trident Z RGB @3600Mhz CL 14 CR=1T

MOBO: ASUS CROSSHAIR HERO VI AM4

GFX: GTX 1080Ti MSI Gaming X

Cooler: NXZT Kraken X62 280mm AIO

Storage: Samsung 960 EVO 1TB M.2+6GB WD 6Gb red

HOTAS: Thrustmaster Warthog + CH pro pedals

Monitor: Gigabyte AORUS AD27QD Freesync HDR400 1440P

 

Link to comment
Share on other sites

I'm on XP. I've had the same issue as Moa where I've remapped keys for chat to 1.12 default and had all my keys stop working, but this issue of the fire buttons not working is seperate I think. It happens randomly, all other functions work, ie EVERY other button and command works except for weapons release, and it will happen without me using a chat window.

 

It's almost like I'm unwittingly setting the master arm to safe...is there a master arm command now in the fighters?

3Sqn - Largest distributor of Flanker, Fulcrum and Frogfoot parts in the Black Sea Region

Link to comment
Share on other sites

It's because of ERI's master arm switch being numpad 2.

 

We have a winner!

 

How come it doesn't work all the time. I hit numpad 2, I can't fire, I hit it again and I still can't fire, but if I hit it a couple of times I can fire again?

3Sqn - Largest distributor of Flanker, Fulcrum and Frogfoot parts in the Black Sea Region

Link to comment
Share on other sites

I've got an idea of what's happening. If you look at the PACS panel on the eagle, on the right side where it says COOL, if the master arm is set to arm there will be a box around the COOL, if it is safe it will be unboxed. So when I press 2 it is cycling, as opposed to it being just one press. So by looking at the pacs panel you know whether you're safe or armed.

 

I've changed the key to 3 in the ERI script as I use 2. The issue is now that I only want to press it, not cycle it 100 x sec by pressing the 3 key. Maybe I could change it to another button on the main part of the keyboard

3Sqn - Largest distributor of Flanker, Fulcrum and Frogfoot parts in the Black Sea Region

Link to comment
Share on other sites

Good find Sven. took awhile for me to figure why I couldnt fire anything. and the LO forum claim that there is NO master arm key commands. but it was added into ERI-Mod.

 

now I figured out why I couldnt fire the missile or shoot the cannon. Thanks for posting this.

 

Cheer S!.

 

Ill try to clear the numpad to clear the assigned "quick view" commands. and see what happen.

 

EDIT:

 

there is 3 keybinding found in ERI_radar.lua

 

kb_libs = package.loadlib("./Config/Export/lua_keys.dll","init_libs") or package.loadlib("./Config/Export/lua_keys_win7.dll","init_libs")

if kb_libs then kb_libs(); end -- Lib successfully initialized! allows access to kb_fcns

-- use http://msdn.microsoft.com/en-us/library/bb431750.aspx as reference for key codes

-- Our keyboard settings

keys = {};

keys["step"]=0x60; -- num0

keys["lbst"]=0x61; -- num1

keys["masterArm"]=0x62; -- num2

 

there is number pad 0 for steps, 1 for LBST and 2 for MasterArm toggle.


Edited by Maximus

Maximus, The only real Maximus in DCS World. :music_whistling:

 

I am not associated to viper 33 | Maximus. he is the imposter.

Link to comment
Share on other sites

Windows 7 x64

 

I am also running the stock game, in windows 7 64bit. I can confirm that the arm switch has nothing to do with this likely separate issue, as the cannon works fine, the hud arm switch displays in the correct position and the missiles will occasionally fire (on the order of 50% of the time if the button is held.) I have the game running full screen in my monitors native resolution (1600x1200.)

Link to comment
Share on other sites

I don't have this problem but I'm using internal control setup. Could it be because external joystick profiler? you can try to delete assignement there and assign it just in the internal FC2 controls setup.

 

A friend of mine had this problem and was somewhat related to a bad configuration in it's Saitek profiler (it was automatically asigning a release weapon push-unpush-push-unpush-push-unpush etc. for release weapons, he had to delete the unpush part and it was just a constant push while he pressed the joy button, this way worked)

AMD Ryzen 1400 // 16 GB DDR4 2933Mhz // Nvidia 1060 6GB // W10 64bit // Microsoft Sidewinder Precision 2

Link to comment
Share on other sites

I am also running the stock game, in windows 7 64bit. I can confirm that the arm switch has nothing to do with this likely separate issue, as the cannon works fine, the hud arm switch displays in the correct position and the missiles will occasionally fire (on the order of 50% of the time if the button is held.) I have the game running full screen in my monitors native resolution (1600x1200.)

 

The issue is related to ERI, and it is the ERI master arm swtich. The other issue is related to ctrl.

3Sqn - Largest distributor of Flanker, Fulcrum and Frogfoot parts in the Black Sea Region

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...