Jump to content

A-10A Loadout for FC 2.0 - deactivated Weapons - Lock On crash


VTJS17_Fire
 Share

Recommended Posts

Hi,

 

actually I'm working on an A-10A Weapons Mod ... as a start for my self.

I want to insert the weapons from FC 1.12, such as CBU-97 and LAU-10 WP.

 

I found the data in the db_weapons.lua (deactivated with --[[), activate it and insert the item in the A-10A.lua.

 

 

db-weapons.lua

launcher("{5335D97A-35A5-4643-9D9B-026C75961E52}", "CBU-97", _("CBU-97"),

{

Picture = "RBK250.png",

WorldID = "1",

Weight = "420",

Guided = "no",

},

{

element("CBU-97", 0.000000, 0.000000, 0.000000,

drawarg(1, 1.000000),

drawarg(2, 1.000000)

),

}

),

A-10A.lua

pylon(2, 0, -0.690000, -0.133000, -4.526000,

{

FiZ = -3.3,

},

{

{ CLSID = "{5335D97A-35A5-4643-9D9B-026C75961E52}" }, -- CBU-97

}

),

Now, I can load my Hog with a single CBU-97 on Pylon 2. I start the game and see the CBU-97 with the correct skin.

 

 

BUT if I switch to A/G mode, my FC 2.0 flight (not the game) crash (standard windows error message) and i stand in the debriefing page.

 

 

What have I to add or to change, so that this modification will be run?

 

 

Thanks for help, best regards

fire


Edited by VTJG17_Fire

Hardware: Intel i5 4670K | Zalman NPS9900MAX | GeIL 16GB @1333MHz | Asrock Z97 Pro4 | Sapphire Radeon R9 380X Nitro | Samsung SSDs 840 series 120GB & 250 GB | Samsung HD204UI 2TB | be quiet! Pure Power 530W | Aerocool RS-9 Devil Red | Samsung SyncMaster SA350 24" + ASUS VE198S 19" | Saitek X52 | TrackIR 5 | Thrustmaster MFD Cougar | Speedlink Darksky LED | Razor Diamondback | Razor X-Mat Control | SoundBlaster Tactic 3D Rage ### Software: Windows 10 Pro 64Bit

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

  • 1 month later...

 

 

BUT if I switch to A/G mode, my FC 2.0 flight (not the game) crash (standard windows error message) and i stand in the debriefing page.

 

 

What have I to add or to change, so that this modification will be run?

 

 

Thanks for help, best regards

fire

 

I can turn on A2G mode by '7' key but i get simulator.exe crash when i trying to drop the CBU-97 by 'Alt+Space' :mad:

in Temp folder the .crash file:

 

 

LockOn Flaming Cliffs 2\bin\x86\stable\Weapons.dll

# C0000005 ACCESS_VIOLATION at 03B1FFDE 01:0001EFDE

#

# EAX = 00000000

# EBX = 00000001

# ECX = 0D6E4100

# EDX = 0D6E4100

# ESI = 51067060

# EDI = 00000000

# CS:EIP = 001B:03B1FFDE

# SS:ESP = 0023:0012ED90 EBP = 00000002

# DS = 0023 ES = 0023 FS = 003B GS = 0000

# Flags = 00210246

03B1FFDE 00000002 0001:0001EFDE G:\DCS - LockOn Flaming Cliffs 2\bin\x86\stable\Weapons.dll ?Init@wBomb@@AAEXXZ()+19E

03B1FFDE 00000002 0001:0001EFDE G:\DCS - LockOn Flaming Cliffs 2\bin\x86\stable\Weapons.dll ?Init@wBomb@@AAEXXZ()+19E

:mad:

sign-pic4.jpg

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...