Jump to content

Saitek X52Pro BlackShark keystroke mixing

Recommended Posts

Hi All,


I've dwelled in the forums for an anwser but found nothing on the specific problem.


I've just bought a Saitex X52Pro with Rudder Pedals, and I'm having some problems with DCS Blackshark and SST Profiles.


I've updated joystick drivers and program to latest versions ( Joy, rudder, profile editor).

I've deleted lua_direct_output.dll from blackshark so i have clean working mfd.


Everything works fine (profile editor, test panel, mfd key names), till i try to play with BS. I've assigned axis controls to my stick, throttle and rudder, and deleted all in-game key bindings, so I have a pure SST profile working.


Actually it does work if I press simple keys like "C", "Enter", "L", and so on, but when I press some special keys in combination like "LCtrl+T", it seems like it keeps the "LCtrl" and continue to bind it to other keys; so if I subsequentially press a simple key like "C", I'll get "LCtrl+C". It's like the sim tries to re-map my key-bindings. Moreover it sums the keys so I get some useless combos like "LCtrl+LAlt+LShit+Something" on any joy button or trigger, and removes keybindings to the keyboard too so for example the "ESC" key or any other key don't work.


The only solution is to exit with ALT+TAB and hope to recover re-entering the sim (sometimes it doesn't even work), but after i press a "special" key it starts over again.


I've also tried to restore Saitek Output Service, but it's not the solution here.


Note that in the profile editor everything works fine. I've used macros for toggle buttons/functions, and keypresses for continuosly pressed buttons (like cannon trigger or shkval cursor).

Here it is the profile. Please tell me if it does work properly for you (and if you like it, feel free to use; give some feedback!).

http://www.4shared.com/file/QZPxhiM9/Mano_Ka50.html <- Not working (see next post)



I've also tried other profiles uploaded here in the forum, but no way.


Everything else works fine! Throttle, stick and rudder are awesome! only thing this annoying button problem!


I'm using freetrack, with freetrack newinput.dll fix. Note that restoring original .dll file doesn't help.


I'm thinking about remapping all the keys in the sim, so i don't need to use special keys that create problems, but i'd prefer not to. I don't even like the idea to use less modes or functions of my X52pro. that's not what i've payed for!


I've read about some similar problems in the forum, but not like this. Do you play with BS and X52Pro without any problem? How do you do?


note that in FC2 by now i've found no problems, but can't tell for sure.


Thank you in advance for any help!


Edited by Mano
more info about the problem
Link to comment
Share on other sites

Mano, I've made a few profiles for my X-52 and haven't had that problem (I've had others though). Unfortunately, the download didn't work so I couldn't check it.


I understand your reluctance to give up on the software as that is part of what you paid for but if the stick isn't working with it you might want to look at in game programming.

I gave up on STT because of all the issues with it and programed the stick in game. Assign the pinky as a modifier and you'll have more than enough buttons to fly and fight the aircraft.

The down side is you have to program each aircraft that you fly (in FC2 and BS). Oh! and do not use the "save profile" button at the top of the controls screen if you do program in game, it will screw up the settings. When you click OK to leave the page the settings are saved in the Config\input\aircraft folder automatically for you.

I use TIR so I don't know if Freetrack would be an issue.


my $0.02


i7 10700K OC 5.1GHZ / 500GB SSD & 1TB M:2 & 4TB HDD / MSI Gaming MB / GTX 1080 / 32GB RAM / Win 10 / TrackIR 4 Pro / CH Pedals / TM Warthog

Link to comment
Share on other sites

Hi Sarge55, thank you for your answer.


I see the link doesn't work. I'm sorry, I would have to check it before.


Anyway it seems like I've solved the problem. In my old profile I've used all keystrokes like Macros, so when you press i.e. "LAlt+T", the program translates it in "LAlt_pression + T_pression + LAlt_release + T_release". I imagine that this in some way gets the sim think that the LAlt has not been released, so it will keep it for other key pressions.


I've solved this issue changing all the commands to "Advanced Command", so that that command would be: "LAlt_pression + T_pression + T_release + LAlt_release", having the time delay of about 0.1 or 0.05 sec between each command (watch out for Release Weapons command: you have to get about 1 sec between the pression and the release, or weapons won't fire).


This way the flight sim understand the commands given and don't messes up with wrong special keys.


Anyway it looks like I have some problems with BS and MFD, because it freezes sometimes, and it crashes my game and windows. the solution is sometimes use the MFD restarter (found here in the forum by Slayer), but other times i have to restart my pc. Probably it some issue with throttle rotary axis assignments.


Hope this helps.


Here my new profile:


Link to comment
Share on other sites

Hi Mano, that dowloaded no problem. Yup, seems to work well.


It's interesting though to note the difference in setups different people have for the game. My set up is much different. So in other posts those who say it's better to set up your own profile are quite correct.


Glad you've solved that problem.


i7 10700K OC 5.1GHZ / 500GB SSD & 1TB M:2 & 4TB HDD / MSI Gaming MB / GTX 1080 / 32GB RAM / Win 10 / TrackIR 4 Pro / CH Pedals / TM Warthog

Link to comment
Share on other sites

Hi Mano,

I had a problem with my MFD. I don't believe your problem is due to the rotary axis assignments...Feel free to check out my post here for a possible solution.


I applied a minimum SST profile and programmed all other inputs in game.

Unlike Sarge, I don't have a shift function for pinky button - I reserve that for trimmer. Personal preference makes for such a diverse range of profiles, as Sarge says..

Rectum non bustus

Link to comment
Share on other sites

Just following the thread here..

I use Revo Uninstaller, in Hunter mode. Gets rid of everything, and searches the registry for left overs after the uninstall. I recommend, if the problem re-occurs.



Link to comment
Share on other sites

With my new, tuned profile I have no problems at all.


Here it is:



I find it very comfortable and useful. Of course it depends on every one tastes and can be tuned better. The only thing is you have to assign Shkval to stick Pov joy in-game. Instead you'll lose the button dynamics of the shkval cursor (the longer you press, the faster it goes).


I have no problems at all with the MFD (besides some letter stutter on the MFD) or the game. Probably it was due because of wrong throttle rotaries and axis assignment that conflicted with BS and flooded the bandwith of the controller.


Anyway I didn't need to re-install anything (drivers or program) to get it running. (I use CCleaner by the way).


Thanks for the feedback anyway!

Good flying! (With the X52pro and rudder pedals is totally another experience! before i had a simple stick with throttle lever included!)

Link to comment
Share on other sites

  • 3 months later...
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...