Jump to content

Flaming Cliffs, Starforce 3.06 and Windows 7 help please


Recommended Posts

Hi all,


Maybe someone can help me on this matter, I have a problem being Starforce 3.06 and Windows 7.


My original install was on Windows XP Pro, and everything went fine, including the actation of Flaming cliffs (NOT flaming cliffs 2). Now unfortunately, due to circumstances beyond my control, my XP set up is toast.... My Motherboard, processor, etc died. So I had to basically build a new PC with new board and processor etc. So also couldn't deactivate Flaming Cliffs either.


Unfortunately, I can't find my XP Pro disc, and I'd been bought a copy of Windows 7 sometime ago, but never installed it, but with the above problems, I had to install Windows 7, and now I keep being told that my version of Starforce is incompatible with Windows 7.


Can someone please tell me what I'm supposed to do now, and how I can update my version of Starforce to the latest version that IS compatible with Windows 7?


Oh, my version of Flaming Cliffs is the download version.


Thanks in advance



Link to comment
Share on other sites

You need to get the updated Starforce driver. Follow the steps listed in the linked thread - should work, especially with the download version.



Novice or Veteran looking for an alternative MP career?

Click me to commence your Journey of Pillage and Plunder!


'....And when I get to Heaven, to St Peter I will tell....

One more Soldier reporting Sir, I've served my time in Hell......'

Link to comment
Share on other sites

  • 2 years later...

Maybe you could help me yet again


Sorry about the late reply, I'd like to say thanks for the help, it worked. Now I have another problem you may be able to help me with.


I activated flaming cliffs (the first one) after using your link to download and install the updated starforce. NOW I need to deactivate flaming cliffs, so I can uninstall it, and upgrade to Windows 8, but have no idea how to deactivate it.


I tried holding left shift whilst starting flaming cliffs, but all that did was bring up the activation window, and there's no button or anything to deactivate it, so have no idea what to do.


Thanks in advance.



Link to comment
Share on other sites

The deactivate button is hidden in the text.


ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...