Jump to content

Can't trim for the life of me


razorseal
 Share

Recommended Posts

I'm trying to trim my plane, and it just won't 'level out'

 

I'm in a steady non-accelerated flight and I want to trim her out. I start using the trim hat and nothing happens! (to verify I can see them moving on the joystick ingame)

 

I will hold nose down for good 10 seconds, and she just won't trim....

 

is there a step I'm missing? I doubt it :helpsmilie:

 

All the real planes I've flown trimming is one of the easier things. I would say this trim is similar to a SR-20 that I flew, and it was rather easy. just move the hat, and she trimmed! not this thing! :(

Link to comment
Share on other sites

I had exactly the same problem. I'm using G25 pedals as my rudder which the game interpreted as having Force Feedback capabilities. When I turned it FF off, I was able to trim the aircraft.

 

Ninja'd.

Link to comment
Share on other sites

I had exactly the same problem. I'm using G25 pedals as my rudder which the game interpreted as having Force Feedback capabilities. When I turned it FF off, I was able to trim the aircraft.

 

Ninja'd.

 

ok, I'm gonna try... I'm using DFGT wheel/pedal combo so

 

Disable Force-Feedback and try it again.

 

I'm pretty sure it is. I will try that now

 

Let's start with the obvious - is your trim hat mapped to the trim functions?

 

if I see the trim hat moving in the ingame joystick, yes, they are mapped properly

Link to comment
Share on other sites

Disable Force-Feedback and try it again.

 

I had this problem for a while. If your Force-Feedback is turned on when you don't have a Force-Feedback joystick, you won't be able to trim.

Windows 10

Intel Core i5 4670k CPU 3.4 GHz

16GB RAM

MSI RTX 2080 Gaming X Trio

Thrustmaster HOTAS Warthog

TrackIR 4

Link to comment
Share on other sites

When I first started my trim hat was somehow set to ctrl and hat after setting up.

I re-mapped and all was fine.

Asus Sabertooth P67 Motherboard 2600k CPU, 16 gig DDR3, 1600. Samsung 830, 256 gig hard drive,

GTX780 Video Card, Warthog Hotas, Razer Mamba mouse. Saitek Combat Rudder Pedals. Trackir 5, Verizon FIOS 25Meg Up/Down

Link to comment
Share on other sites

I had this problem for a while. If your Force-Feedback is turned on when you don't have a Force-Feedback joystick, you won't be able to trim.

 

yup, that was it. it set FF because of my steering wheel. I shut it off, and now I'm able to trim :)

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...