Jump to content

Can't start right after install - (0xc000007b)


Kevlar
 Share

Recommended Posts

Hi, I just installed the latest version of DCS through the torrent from their site.

 

Picture of the error after install when I try to launch the program, same error for multiplayer.

359dzio.png

 

Translated from Norwegian to English:

Programerror

"The program couldn't start properly (0xc000007b). Click OK to close the program."

 

 

Thanks a lot, I am looking forward to try the game out! :)

Link to comment
Share on other sites

  • 4 weeks later...

What a pain in the ass...really not impressed.

 

I was getting this problem and used a program called Dependence Walker to find out that some how, the auto updater messed-up some files to do with the c++ redistribution program/files.

 

I'm not 100% back to normal but by running this

http://www.microsoft.com/download/en/details.aspx?id=14632

with the REMOVE option and then cleaning the registry with 3 programs before reinstalling it, I can at least get into World now.

 

The above link is for 64bit systems.

 

For 32bit, try here.

http://www.microsoft.com/download/en/details.aspx?id=5555

 

I'm still getting two DLL errors and when I fix those, I will post...hope this helps a bit...

Link to comment
Share on other sites

  • ED Team
I was getting this problem and used a program called Dependence Walker to find out that some how, the auto updater messed-up some files to do with the c++ redistribution program/files.

...

 

I'm still getting two DLL errors and when I fix those, I will post...hope this helps a bit...

 

1) From your description you hadn't run the autoupdater, only the installer.

2) Neither installer, nor autoupdater, nor the game touch the registry beyond Software\Eagle Dynamics\ key. Th autoupdater currently doesn't touch the registry at all.

3) Seems like you skipped VC++ Runtime installation at the installation stage.

 

Which DLL errors do you have exactly?

Dmitry S. Baikov @ Eagle Dynamics

LockOn FC2 Soundtrack Remastered out NOW everywhere - https://band.link/LockOnFC2.

Link to comment
Share on other sites

I hadn't flown for about 3 weeks and when I tried to launch it on Saturday, nothing worked. This was from a perfectly working copy before 1.2.2

 

I didn't run anything initially as I didn't even know there was an update.

 

Then tried to fix 1.2.1 including wiping it and reinstalling in (had it on my external)...full reg cleans and reboots of course.

 

That didn't work so DL'ed 1.2.2 and pretty much the same thing. Did some research and found that it's the C++ RD that is probably the problem. Removed and reinstalled them and got 2/4 file fixed.

 

Currently, the two DLLs still messed are:

IESHIMS.DLL

IEFRAME.DLL

 

Shim is MIA and Frame is...not sure...

Link to comment
Share on other sites

As i mentioned before, I could get into World. I was getting an "autoupdate.cfg is mission" error. Got a friend to email me his. Copied it there and it updated itself.

 

Things look mostly good now I think...too late to dive any deeper now but will post back if there are more problems.

 

Thanks fro the help!

Link to comment
Share on other sites

  • 2 weeks later...

same 0cx000007b error

 

i am getting the same error as the subject error.

 

i installed as admin

 

tried to run as admin

 

i am getting nowhere.

 

from the thread i see one solution was to get a friends copy(?) and install

from that, and it worked. well i don't know anyone who has a working copy

so this is not a solution for me.

 

i am reallly looking forward to running dcs world with p-51d mustang.

 

sys config

 

amd 955 quad 4 black edition

win 7 pro - 64 bit

16 gb ram dd3 1600

gigabyte ga 990fxa ud3 mb

raidmax gold 850 w ps

evga 660 2gb

 

not sure where to go from here. i have uninstalled and reinstalled already.

Link to comment
Share on other sites

Having exactly the same issue ..... VERY VERY IRRITATING

 

Kevlar I have the same problem this is a copy of the request for support from DCS that I have submitted.................. I should add that I DONT EXPECT that DCS team will help, and certainly not promptly!.

 

After a recent auto update my DCS world now will not start, giving the report "Application unable to start correctly(0xc000007b). Click OK to close the application."

 

This respons happens no matter which .exe file I use to attempt to start the program, eg Short cut icon for both Single player /GUI or Icon for multiplay or any auto updater/ repair function.

Since this occured I have un-installed fully the entire program removed all DCS world files and re-installed to defaults from a clean start but the problem continues exactly as before.

 

My Rig....OS;-Win7 home premium +svc pack1 64bit, CPU;-Intel Core i7-2600K @3.4 x 3.4GHz Motherboard;-ASUS P8Z68-VLX + Intel Chipset Graphics:-NVIDIA ZOTAC Gtx 560Ti 10024MB DDR5 HDMI DVI PCI Internal Drives;- C:/Kingstone 500gb SSD F:/ Seagate "Barracuda" 1Tb SATA 1700RPM 32MB cache RAM 4x2048MB DDR3 PC3 12800 @ 1600Mhz 240 tot=8.00 GB

TrakIR4Pro HOTAS;- Saitek X52 Pro + Saitek Pro Rudder pedals.


Edited by OGREMAN
Add comment ,expectation of outcome fm DCS admin.

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Any more help with this? I am having this same problem. I haven't flown DCS in a month or so.. I've tried everything mentioned so far.

[sIGPIC][/sIGPIC]

"If they can make penicillin out of moldy bread, they can certainly make something out of you"

 

-Muhammad Ali

 

WIN 7 64-bit SP1 | AMD Phenom II X4 955 | 8.0 GB RAM | NVidia GeForce GTX 550Ti | CH Pro Throttle | CH Fighterstick | CH Pro Pedals | TrackIR5

Link to comment
Share on other sites

  • 3 weeks later...

I also tried to run DCS world after not using it for a few days and what a mess. Uninstall re install it does not matter, will not work . Deleted every thing including registry entry's . Always errors after reinstalling .

Hope some one has a fix for us .

Link to comment
Share on other sites

I'm not having that problem but I;m having a download and install problem from a pc that run the programe in perfect conditions. I needed to unistal everything from DCS, but know I cant download and what I download is always corrupted.

 

It seems that DCS is not as friendly as it looks. I hope I can get back to fly cause I spend a lot of money in equipment just for this.

 

<S> CO

Link to comment
Share on other sites

After spending half the day downloading and installing and reinstalling finally got this software to work again, for the love of Pete it shouldn't be such a pain in the rear!
:thumbup:

 

Good for you man! hope I can get the same luck. Very hard when not so mush people help :cry:

 

Being stuck on this for a week.

 

<S>

Link to comment
Share on other sites

  • 2 weeks later...
After spending half the day downloading and installing and reinstalling finally got this software to work again, for the love of Pete it shouldn't be such a pain in the rear!

 

What was the answer mate, anything you did different or just random luck?

 

Depends.exe gives this:

 

Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.

Error: Modules with different CPU types were found.

Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

 

It looks like some DLLs are loaded 32bit and some 64bit, or that attempt is made, not sure if this would cause a crash but depends has highlighted the x86 in red...

 

Thanks

 

Tanky


Edited by Tanky
Link to comment
Share on other sites

0xc000007b, is a Microsoft Visual C++ Component Error.

 

It is not limited to DCSW at all.

 

Either User Mistakenly downloaded and installed x86 on a x64 machine, or vise versa, or they didnt update the runtimes at all.

 

MSVC-2010 (x86): http://www.microsoft.com/en-us/download/details.aspx?id=5555

 

MSVC-2010 (x64): http://www.microsoft.com/en-us/download/details.aspx?id=14632

 

MSVC-2012: http://www.microsoft.com/en-us/download/details.aspx?id=30679

 

 

 

 

I hadn't flown for about 3 weeks and when I tried to launch it on Saturday, nothing worked. This was from a perfectly working copy before 1.2.2

 

I didn't run anything initially as I didn't even know there was an update.

 

Then tried to fix 1.2.1 including wiping it and reinstalling in (had it on my external)...full reg cleans and reboots of course.

 

That didn't work so DL'ed 1.2.2 and pretty much the same thing. Did some research and found that it's the C++ RD that is probably the problem. Removed and reinstalled them and got 2/4 file fixed.

 

Currently, the two DLLs still messed are:

IESHIMS.DLL

IEFRAME.DLL

 

Shim is MIA and Frame is...not sure...

 

Both of those files should be in the /root/Program Files/Internet Explorer/ Folder.

 

They are Part of Internet Explorer 8.0 and Above, So They Should be present on any Vista/Win7/Win8 System.


Edited by SkateZilla

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, R7970 Lightning @ 1.2 / 6 GHz Memory

3x ASUS VS248HP + Oculus HMD, Thrustmaster Warthog HOTAS + MFDs

Link to comment
Share on other sites

0xc000007b, is a Microsoft Visual C++ Component Error.

 

It is not limited to DCSW at all.

 

Either User Mistakenly downloaded and installed x86 on a x64 machine, or vise versa, or they didnt update the runtimes at all.

 

MSVC-2010 (x86): http://www.microsoft.com/en-us/download/details.aspx?id=5555

 

MSVC-2010 (x64): http://www.microsoft.com/en-us/download/details.aspx?id=14632

 

MSVC-2012: http://www.microsoft.com/en-us/download/details.aspx?id=30679

 

 

Both of those files should be in the /root/Program Files/Internet Explorer/ Folder.

 

They are Part of Internet Explorer 8.0 and Above, So They Should be present on any Vista/Win7/Win8 System.

 

Thanks for info Skate, I've tried all this. I even tried installing the 32bit redist but it wouldn't let me ;)

 

Not sure where to go with this now... running out of angles. Dependency Walker says the CPU is trying to work in both 86 and 64, its loaded the DLLs from the game folder in 64bit and the dlls from sys32 as x86, should it not be trying to address the DLLs from wow64 folder?

 

I'm not very computer savvy, better than most but this is beyond my knowledge.

 

Anything you can recommend? I've issued a support ticket to DCS World, but as I bought the game on steam I'm not hopeful of their cooperation, I'm going to download the A10C standalone installer overnight and see if I can get a 64bit rise out of that. Please note I've had the 32bit steam version working (just have to launch the game manually from the x86 bin folder). Unfortunately that isnt optimal for my nice 64bit OS and core i5/nvidia gtx 670 :(

 

Rgds

 

Tanky


Edited by Tanky
Link to comment
Share on other sites

STEAM and the STEAM A-10C 1.1.1.1 ISO Are Restricted to 32-BIT,

 

Download the ISO from ED's Site (I reccommend Torrent, its faster),

 

Use your Steam Serial Key to activate.

 

ED's ISO is 64-Bit Enabled, Steams is restricted to 32-Bit and other Steam Restrictions.

 

Right Click Game, View Serial Key, copy paste to notepad, save txt.

 

Right click game, choose Delete Local Files.

 

Install A-10C 1.1.1.1 w/ ED's ISO.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, R7970 Lightning @ 1.2 / 6 GHz Memory

3x ASUS VS248HP + Oculus HMD, Thrustmaster Warthog HOTAS + MFDs

Link to comment
Share on other sites

I got 2 C++ 2008 X86 , a C++ 2010 x64 , and a C++ 2010 x86 . Can I remove any of these please ? Im running win 7 64bit .

 

Im having issue with the game too . Havent been doing much flying over the Christmas , but them I try to connect to a server , the game crashs 9 out of 10 times .

Link to comment
Share on other sites

STEAM and the STEAM A-10C 1.1.1.1 ISO Are Restricted to 32-BIT,

 

Download the ISO from ED's Site (I reccommend Torrent, its faster),

 

Use your Steam Serial Key to activate.

 

ED's ISO is 64-Bit Enabled, Steams is restricted to 32-Bit and other Steam Restrictions.

 

Right Click Game, View Serial Key, copy paste to notepad, save txt.

 

Right click game, choose Delete Local Files.

 

Install A-10C 1.1.1.1 w/ ED's ISO.

 

Can you provide a link mate? I don't want to download the wrong one, not seen any mention of ISOs!

 

thanks again

 

Tanky

Link to comment
Share on other sites

  • 8 months later...

Well did any of you eventually succeed? After a re-install of Windows onto a new HD I too have the same "Application unable to start correctly(0xc000007b)"

Still waiting for DCS help to reply.

Must say am spending far more time "fiddling then flying" and may give up using & purchasing from these online linked programs and go back to my beloved Sturmovik 1946!

Really a shoddy state of affairs!

Link to comment
Share on other sites

Well did any of you eventually succeed? After a re-install of Windows onto a new HD I too have the same "Application unable to start correctly(0xc000007b)"

Still waiting for DCS help to reply.

Must say am spending far more time "fiddling then flying" and may give up using & purchasing from these online linked programs and go back to my beloved Sturmovik 1946!

Really a shoddy state of affairs!

 

Reinstalling windows is OK, but you need to remember that this program (and others) use internal Windows programs like C++ Distribute 2010 and up. Those are not part of Windows core install along with DirectX all ver. need to be installed with the new install of Windows. don't forget the Windows updates that go with the new install.

 

After all of that is completed you will still have to update Bios, GPU and any other drivers that have come out sense the Release of your Windows ver.

 

 

No matter where it is posted the answer is still the same.

This was a Boutique Builder iBuypower rig. Until I got the tinker bug again i7 920 @3.6Mhz 12Gig Corsair XMS3 ram 1600 Nvidia 760 SLi w/4Gig DDR5 Ram Intel 310 SSD HDD 160 Gb + Western Digital 4Terabyte HDD Creative SB X-Fi HD Audio Logitech X-530 5.1 Surround Speaker System Dual Acer 32"Monitors. PSU 1200 w Thermaltake Win10 64Bit.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...