Jump to content

Escort Mission A big bug


theghost
 Share

Recommended Posts

After a many attempts I discovered there is a problem with the Escort function,When you add an escort fighter to the KC-135 The plane losing altitude And not maintains the flight path.

This is an important function It just does not work well at all.

The 147 Squadron commander

"The Goring Ram"

Link to comment
Share on other sites

After a many attempts I discovered there is a problem with the Escort function,When you add an escort fighter to the KC-135 The plane losing altitude And not maintains the flight path.

This is an important function It just does not work well at all.

please post your .miz file and we can take a look at it.

i7-7700K : 16Gb DDR4 2800 Mhz : Asus Mobo : 2TB HDD : Intel 520 SSD 240gb : RTX 2080ti: Win10 64pro : Dx10 : TrackiR4 : TM Warthog : ASUS ROG SWIFT PG348Q

Link to comment
Share on other sites

Ok. first thing I did was add a WP to your F-15s so they knew in which direction to head in.

I then added the escort action to WP1 (its better if its in a WP of its own).

 

1 point to note (and this needs changing, I shall report it) the position you set for the aircraft to 'follow' or 'escort' is based on the position of last aircraft in the formation and not the first (it should really be the first). Makes it a little difficult to work out the x,z co-ords as a result.

 

Anyway .miz attached, tested and works.

R1ver2.miz

i7-7700K : 16Gb DDR4 2800 Mhz : Asus Mobo : 2TB HDD : Intel 520 SSD 240gb : RTX 2080ti: Win10 64pro : Dx10 : TrackiR4 : TM Warthog : ASUS ROG SWIFT PG348Q

Link to comment
Share on other sites

forther testing has revealed that some of the development bugs in follow and escort never made it to 1.2.1.xx This means that there is some unpredictable behaviour using these actions at the moment. With all new features there is always a settling in time as it is impossible to test every variation in which they can be used.

 

In my testers version the aircraft escort or follow correctly and position is set correctly on the leader. Hopefully these fixes will find their way into an autoupdate soon.

i7-7700K : 16Gb DDR4 2800 Mhz : Asus Mobo : 2TB HDD : Intel 520 SSD 240gb : RTX 2080ti: Win10 64pro : Dx10 : TrackiR4 : TM Warthog : ASUS ROG SWIFT PG348Q

Link to comment
Share on other sites

  • 4 weeks later...

Different issue with escort action:

 

I have an MiG-23 take off from Beslan and at it's 1st stearpoint it's set to escort Su-24 taking off from Mozdok. To get their rendezvous timed I set the escort flight to spawn 5 minutes after game start. I had 3 similar pairs of Bomber-Escort taking off from seperate airfield with different time delays.

the result was that all escort flights would take off and then continue on the runway heading forever, basically flying off the map on the heading that they took off on.

 

I tried changing the escort action to different stearpoints with same result.

I tried having the escorts spawn mid air. Same result, they just fly straight ahead forever.

 

Changed one of the flights to Fighter sweep and it would follow it's stearpoints like normal so clearly something wrong with the escort action.

I think it has to do with the spawn delay.

Ideally the escort flights should, upon reaching the waypoint with an escort action, head for the bomber flight they are to escort and form up with them.

 

Please fix this ED


Edited by Essah
Link to comment
Share on other sites

Yes known issue and has been fixed internally, hopefully it will get added to an auto-update soon.

The right man in the wrong place makes all the difference in the world.

Current Projects: Scripting Wiki, Something...

Useful Links: Mission Scripting Tools MIST-(GitHub) MIST-(Thread), SLMOD, IADScript, Mission Editing Wiki!, Mission Building Forum

Link to comment
Share on other sites

  • 11 months later...
Yes known issue and has been fixed internally, hopefully it will get added to an auto-update soon.

 

I wish I had a dollar for every time that statement has been posted.

ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

its been nearly a year and still we suffer from the escort mission bug..

:(

 

Can you post an example you have with it broken? I have been unable to replicate the issues that have existed with it in the past...

The right man in the wrong place makes all the difference in the world.

Current Projects: Scripting Wiki, Something...

Useful Links: Mission Scripting Tools MIST-(GitHub) MIST-(Thread), SLMOD, IADScript, Mission Editing Wiki!, Mission Building Forum

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...