Jump to content

Triggers - Radio Transmission - Loop problem


xxJohnxx
 Share

Recommended Posts

Hi,

 

Today I noticed that a triggered radio transmission (wirhin the trigger menu) will always be looped, independend if "Loop" is set to off or on.

I will upload a mission tomorrow if it becomes nessesary, but you can reproduce this few steps.

 

1. Place A-10/Ka-50/P-51 usercontrolled somewhere on the map.

2. Place a trigger zone near it.

3. Set a trigger like: ONCE->Time more=10seconds->Radio Transmission

4. Leave frequency at 124.000 MHz AM and select audio file. Make sure that "Loop" is set to off.

5. Start mission and enjoy great hours of listening to the soundfile you selected which plays again and again. :music_whistling:

 

BTW: I am pretty sure this was working one or two weeks ago :cry:

 

Best regards,

 

Jonathan

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to comment
Share on other sites

Yea, have the same problem. First thought was I made something wrong but it seems to be a bug. Saddly it would be real cool just to send the radio messages on defined frequencies....

My Rig: Windows 10 Pro, Intel i7-8700k@4.7GHz, 32GB DDR4 3200 RAM, Gigabyte Z370 AORUS Ultra Gaming, 1TB Sabrent Rocket NVMe, Samsung 3*1TB HDD (RAID 0), GTX1070 G1, Thrustmaster HOTAS WARTHOG + Saitek Pro Flight Pedals + TrackIR5, ACER 30" 4K 60FPS GSync Display

Link to comment
Share on other sites

Yea, have the same problem. First thought was I made something wrong but it seems to be a bug. Saddly it would be real cool just to send the radio messages on defined frequencies....

 

Hi,

 

Yeah it is a pity it doesn't work that way it should, however I found another solution, which works for ground units and airborne units and probably ships too.

If you place any vehicle you want somewhere, you can set it with the advanced tasks to use their radio for transmission.

First you give the vehicle the frequency with PERFORM COMMAND -> SET FREQUENCY. This can happen at a waypoint or with a trigger over the advanced tasks.

Then you give the vehicle via PERFORM COMMAND -> RADIO TRANSMISSION the task to talk over the radio. This can also happen at a waypoint or with the advanced tasks.

 

I used this here.

 

John

Check out my YouTube: xxJohnxx

 

Intel i7 6800k watercooled | ASUS Rampage V Edition 10 | 32 GB RAM | Asus GTX1080 watercooled

Link to comment
Share on other sites

I know there were a few little bugs with this feature, but I am not sure if the fixes are in the current patch or will be in a future patch. I'll investigate some more on the tester build.

The right man in the wrong place makes all the difference in the world.

Current Projects: Scripting Wiki, Something...

Useful Links: Mission Scripting Tools MIST-(GitHub) MIST-(Thread), SLMOD, IADScript, Mission Editing Wiki!, Mission Building Forum

Link to comment
Share on other sites

What am I doing wrong? tried to test following by DO SCRIP FILE:

 

do

local koordinate_lat = 420916

local koordinate_lon = 0412928

local modulator = radio.modulation[1]

local radio_vector = coord.LLtoLO(koordinate_lat, koordinate_lon, 0)

trigger.action.radioTransmission('pic_no_task.ogg', radio_vector, modulator, false, 251000, 300)

end

 

All I get is following error

 

00083.876 ERROR SOUND: source_is_playing(-1): invalid source

00083.946 ERROR Lua::Config: load error C:\Users\Tom\AppData\Local\Temp\DCS\/~mis000037C7:[string "C:\Users\Tom\AppData\Local\Temp\DCS\/~mis00..."]:7: Parameter #3 (modulation) missed

stack traceback:

[C]: ?

[C]: in function 'radioTransmission'

[string "C:\Users\Tom\AppData\Local\Temp\DCS\/~mis00..."]:7: in main chunk.

My Rig: Windows 10 Pro, Intel i7-8700k@4.7GHz, 32GB DDR4 3200 RAM, Gigabyte Z370 AORUS Ultra Gaming, 1TB Sabrent Rocket NVMe, Samsung 3*1TB HDD (RAID 0), GTX1070 G1, Thrustmaster HOTAS WARTHOG + Saitek Pro Flight Pedals + TrackIR5, ACER 30" 4K 60FPS GSync Display

Link to comment
Share on other sites

Hi,

 

Today I noticed that a triggered radio transmission (wirhin the trigger menu) will always be looped, independend if "Loop" is set to off or on.

I will upload a mission tomorrow if it becomes nessesary, but you can reproduce this few steps.

 

1. Place A-10/Ka-50/P-51 usercontrolled somewhere on the map.

2. Place a trigger zone near it.

3. Set a trigger like: ONCE->Time more=10seconds->Radio Transmission

4. Leave frequency at 124.000 MHz AM and select audio file. Make sure that "Loop" is set to off.

5. Start mission and enjoy great hours of listening to the soundfile you selected which plays again and again. :music_whistling:

 

BTW: I am pretty sure this was working one or two weeks ago :cry:

 

Best regards,

 

Jonathan

 

When I do so it won't work for the clients :cry:

When I'm selfhosting anything is fine.

My Rig: Windows 10 Pro, Intel i7-8700k@4.7GHz, 32GB DDR4 3200 RAM, Gigabyte Z370 AORUS Ultra Gaming, 1TB Sabrent Rocket NVMe, Samsung 3*1TB HDD (RAID 0), GTX1070 G1, Thrustmaster HOTAS WARTHOG + Saitek Pro Flight Pedals + TrackIR5, ACER 30" 4K 60FPS GSync Display

Link to comment
Share on other sites

When I do so it won't work for the clients :cry:

When I'm selfhosting anything is fine.

 

That was one of the bugs that should be fixed in a future patch.

 

There are a few known issues with some of the trigger.action scripts in current release, however I don't know if radio transmission is one of them. By the looks of things it might have the same issue. I'll try it out.

The right man in the wrong place makes all the difference in the world.

Current Projects: Scripting Wiki, Something...

Useful Links: Mission Scripting Tools MIST-(GitHub) MIST-(Thread), SLMOD, IADScript, Mission Editing Wiki!, Mission Building Forum

Link to comment
Share on other sites

This was the reason I was testing it via script code with triger.action.radiotransmission

 

But something I'm doing wrong there any Ideas :helpsmilie:

 

How do I set the Modulation right tried it with radio.modulation[1] and only 0 or 1 etc.

 

*EDIT*

Ok, the modulation I got to work simply by true or false (true=AM, false=FM)

But now the dcs.log says invalid source? I used the same file as in editor which will be played back!?


Edited by Quax456

My Rig: Windows 10 Pro, Intel i7-8700k@4.7GHz, 32GB DDR4 3200 RAM, Gigabyte Z370 AORUS Ultra Gaming, 1TB Sabrent Rocket NVMe, Samsung 3*1TB HDD (RAID 0), GTX1070 G1, Thrustmaster HOTAS WARTHOG + Saitek Pro Flight Pedals + TrackIR5, ACER 30" 4K 60FPS GSync Display

Link to comment
Share on other sites

bump.

My Rig: Windows 10 Pro, Intel i7-8700k@4.7GHz, 32GB DDR4 3200 RAM, Gigabyte Z370 AORUS Ultra Gaming, 1TB Sabrent Rocket NVMe, Samsung 3*1TB HDD (RAID 0), GTX1070 G1, Thrustmaster HOTAS WARTHOG + Saitek Pro Flight Pedals + TrackIR5, ACER 30" 4K 60FPS GSync Display

Link to comment
Share on other sites

I wonder if its anything to do with the fact that the sound file you refer to in your radio.transmission is not packaged in the miz file. Strictly speaking it should be. On your machine is the sound file used in your lua located in the same folder as the miz file?

 

The radio modulation in the wikki is incorrect, you are right it is a boolean.

 

Also try placing a unit (e.g. radiounit) where you would like the transmission to eminate from and use

 

do
local radio_vector = Unit.getByName('radiounit'):getPosition().p
trigger.action.radioTransmission('this is hawg request picture.ogg', radio_vector, true, false, 251000, 300)
end


Edited by Druid_

i7-7700K : 16Gb DDR4 2800 Mhz : Asus Mobo : 2TB HDD : Intel 520 SSD 240gb : RTX 2080ti: Win10 64pro : Dx10 : TrackiR4 : TM Warthog : ASUS ROG SWIFT PG348Q

Link to comment
Share on other sites

OK that works, but never the less its looping endless even if loop is set to false. So my whishes that the editor trigger only is broken.

 

Saddly the xripting posebility is broken also :cry:

My Rig: Windows 10 Pro, Intel i7-8700k@4.7GHz, 32GB DDR4 3200 RAM, Gigabyte Z370 AORUS Ultra Gaming, 1TB Sabrent Rocket NVMe, Samsung 3*1TB HDD (RAID 0), GTX1070 G1, Thrustmaster HOTAS WARTHOG + Saitek Pro Flight Pedals + TrackIR5, ACER 30" 4K 60FPS GSync Display

Link to comment
Share on other sites

That was one of the bugs that should be fixed in a future patch.

 

There are a few known issues with some of the trigger.action scripts in current release, however I don't know if radio transmission is one of them. By the looks of things it might have the same issue. I'll try it out.

 

Seem to be a bigger problem. Allied Flight Reports if enabled arent be transmitted when you jump into cockpit. I think thats the reason why this little AI-Trigger doesn't work on the client side.

 

Maybe????

My Rig: Windows 10 Pro, Intel i7-8700k@4.7GHz, 32GB DDR4 3200 RAM, Gigabyte Z370 AORUS Ultra Gaming, 1TB Sabrent Rocket NVMe, Samsung 3*1TB HDD (RAID 0), GTX1070 G1, Thrustmaster HOTAS WARTHOG + Saitek Pro Flight Pedals + TrackIR5, ACER 30" 4K 60FPS GSync Display

Link to comment
Share on other sites

Looping and client side issues have been fixed in the testers build. Hopefully the fixes will make the next patch. As for the lua problem and incorrect wiki, they have been reported and await fix.

i7-7700K : 16Gb DDR4 2800 Mhz : Asus Mobo : 2TB HDD : Intel 520 SSD 240gb : RTX 2080ti: Win10 64pro : Dx10 : TrackiR4 : TM Warthog : ASUS ROG SWIFT PG348Q

Link to comment
Share on other sites

Looping and client side issues have been fixed in the testers build. Hopefully the fixes will make the next patch. As for the lua problem and incorrect wiki, they have been reported and await fix.

 

In the actual vanilla 1.2.2 it seem to be disabled completly.:mad:

 

But the Unit AI trigger action "Transmit message" finally works :thumbup:

My Rig: Windows 10 Pro, Intel i7-8700k@4.7GHz, 32GB DDR4 3200 RAM, Gigabyte Z370 AORUS Ultra Gaming, 1TB Sabrent Rocket NVMe, Samsung 3*1TB HDD (RAID 0), GTX1070 G1, Thrustmaster HOTAS WARTHOG + Saitek Pro Flight Pedals + TrackIR5, ACER 30" 4K 60FPS GSync Display

Link to comment
Share on other sites

Hi all,

 

in v.1.2.2. radio transmission trigger endless loop issue has disappeared.

 

 

However,

 

once, unit in zone, radio transmission (loop off); NO SOUND!

once, unit in zone, radio transmission (loop on); works as expected.

 

...and...

 

once, random 100, radio transmission (loop off); works ok

 

...but...

 

once, time more 10, radio transmission (loop off); NO SOUND!

mission start, time more 10, radio transmission (loop on); NO SOUND!

 

 

 

Hope to see this feature (WIP?) in operation soon.:thumbup:

* Asus P8Z68-V * i5-2500k * gtx580 1536MB * 16GB RAM * Corsair Force 3 SSD 120 + 240 GB * Western Digital Caviar Green 1 TB HD * TrackIR 5 & ProClip * BenQG2222HDL @ 1920x1080 * win 10 64bit * Thrustmaster Hotas Warthog * Saitek Pro Flight Combat Rudder Pedals *

Link to comment
Share on other sites

yep it appears that the sounds starts at miz start regardless of condition. I saw this very recently and reported it but it looks the fix didn't make 1.2.2. Look for the fix in an autoupdate at some point.

i7-7700K : 16Gb DDR4 2800 Mhz : Asus Mobo : 2TB HDD : Intel 520 SSD 240gb : RTX 2080ti: Win10 64pro : Dx10 : TrackiR4 : TM Warthog : ASUS ROG SWIFT PG348Q

Link to comment
Share on other sites

  • 5 months later...
I set a trigger zone + radio transmission (once trigger).

 

In SP it works.

But in MP when a client joins the server and the trigger was already activated he can not hear the transmission.

 

kown issue?

 

I'm having the same issue.

Link to comment
Share on other sites

I set a trigger zone + radio transmission (once trigger).

 

In SP it works.

But in MP when a client joins the server and the trigger was already activated he can not hear the transmission.

 

kown issue?

 

Came here to report this issue.

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...