Jump to content

Rudder Braking Question


wallace
 Share

Recommended Posts

Hello folks...

 

First off, awesome sim, love it. Only have 45min in the air at this point as I am having some issues with configuration.

 

Anyway. Ok so my HOTAS and Cougar's showed up and are very nice to say the least. I have basically no issues with them but my question is with my rudder.

 

I am using a Saitek pro rudder system... and have turned off everything in the A10 Controls screen other than the axis for rudder and the brakes. It was showing buttons which was strange, wonder if that relates to multiple controls through a USB hub.... I will look into that later. Anyway... the brakes are backwards. If I press them fully then the aircraft will roll but if not it is stopped, I assume there is a parking brake but I would of thought that once the brakes are pressed it is released... or am I just missing a basic flying point of this cockpit which I have not studied enough (due to the fact that I just wanted to fly it)...

 

Cheers

 

PS. Additionally if anyone has any suggestions as to resources and configuration ideas for the Cougar controls and some of these screens I have seen on YouTube that would be cool.

Link to comment
Share on other sites

If you go to you brake axis' and select one, then click Axis Tune at the bottom of the window. The screen that comes up has a check box for inverting the axis. Check the box and do the same for the other brake axis.

 

Also, all the 'buttons' assigned to things that don't even have buttons, is normal. Just clear out the stuff that does not belong.

ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

Hey,

 

Thanks......... sorry for a non complete message as I do appreciate your response. I had actually done that reversed the settings there and it was the same... now when I did that I also saved it... does that mean I needed to load it before flying?

Link to comment
Share on other sites

Once you make the change, as long as you exit the controls screen with OK instead of Cancel then the changes stay. You should not have to load anything after that.

ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

I'll just go and put my question in here:

 

I got a Saitek Pro Flight Combat rudder pedals, which have wheel brakes on top of the standard rudder axis.

I have them set up properly (both X and Y axes are inverted, so wheel breaks engage when I press the breaks, and disengage when I release them).

In all DCS sims (A10C, P51D), the wheel brakes act funny.

 

Once pressed, the wheel breaks engage fully. But when I release them, they only release to about half in the sims. This means they remain half-pressed in the sims, even though in reality they are fully released. I can best see this behavior if I press RCTRL+Enter, which opens the Controls axes display thing - there, I can easily see how the brakes remain half pressed (and ofcourse, the airplane itself doesn't taxi along the taxiways as it should, as it keeps braking).

 

At first I thought this could be a calibration problem, so I calibrated the pedals in Windows. Over there, everything functions perfectly: both pedals, when released, go to their extremes in the calibration utility. Also, there is no flickering of the axis that could be understood as a symptom of the potentiometers failing - when pressing and releasing the pedals, the movement in the Windows calibration utility is smooth throughout.

 

So, it would appear that the pedals are calibrated correctly and function perfectly.

 

But in A10C or P51D, once I press them, they stay half pressed.

 

The only workaround is to press the Wheel brakes key on the keyboard, which releases the brakes fully. But seriously, I didn't spend well over 100 euros on pedals with brakes, just to end up using the keyboard again, right?

 

 

Any ideas?

DCS A10C Warthog, DCS Black Shark 2, DCS P51D Mustang, DCS UH-1H Huey, DCS Mi-8MTV2 Magnificent Eight, Flaming Cliffs 3, Combined Arms

 

System: Intel i7 4770k @4,2GHz; MSI Z87-G65; 16GB DDR3 1600 MHz RAM; 128GB SSD SATA3 (system disk); 2TB HDD SATA3 (games disk); Sapphire Radeon R9 290 Tri-X; Windows 7 64bit

Flight controls: Thrustmaster HOTAS Warthog; Saitek Pro Flight Combat Rudder; TrackIR 5; Thrustmaster F16 MFDs; 2x 8'' LCD screens (VGA) for MFD display; 27'' LG LCD full HD main display

Link to comment
Share on other sites

Hey,

 

I am away from home and my computer for the next few days but I will describe what I did that got them to work properly.

 

I went into settings and controls and then axis tune.

 

When looking at the rudder pedals the line in axis tune is a 45degree line that is interacting with two little red squares. There is (I think) x and y axis working both at 100. I reduced the x ( think) so that the line sort of goes vertically, looks like a squared off S it goes straight across the screen then a line vertically up the middle. I did the same of course for both pedals but I think one of them was the other axis, cant remember but the right pedal was slightly different.... easy to figure out though once the one was working and I tested it... I just swapped the selected sliders until it worked correctly there as well.

 

Sorry that I cant remember which it was exactly, I will take a look at them when I get home if you still are having issues, that wont be until Monday though. Good luck, hope this helps.

 

Cheers

Link to comment
Share on other sites

@Wallace: I think I understand, what you did there: you set a dead zone in the middle of the axis, making the axis not respond until it is almost fully pressed.

 

This might work, but it kind of eliminates the purpose of analog wheel brakes. In your case, you fully press the brakes and the plane responds by fully braking, but you have nothing in between: you can only fully press them or not at all...

 

If I understood you wrong, let me know.

 

EDIT: I see now I understood wrong. You were talking about the same thing as Heggis in FreeFall's link: you set the X-saturation to very low.

 

 

FreeFall: thanks for the link... I'll try what Heggis did in the last post of that thread (saturation to 70).

 

EDIT2: It didn't work. I set the X saturation to 70 (as suggested by Heggis), and got the same result. Then I set it to 25 (almost vertical, like Wallace suggested), but that didn't work either.

 

EDIT3: I have an idea, but I'll have to try it later today as I'm heading for work now... I'll keep you updated if my theory turns out correct.


Edited by ishtmail

DCS A10C Warthog, DCS Black Shark 2, DCS P51D Mustang, DCS UH-1H Huey, DCS Mi-8MTV2 Magnificent Eight, Flaming Cliffs 3, Combined Arms

 

System: Intel i7 4770k @4,2GHz; MSI Z87-G65; 16GB DDR3 1600 MHz RAM; 128GB SSD SATA3 (system disk); 2TB HDD SATA3 (games disk); Sapphire Radeon R9 290 Tri-X; Windows 7 64bit

Flight controls: Thrustmaster HOTAS Warthog; Saitek Pro Flight Combat Rudder; TrackIR 5; Thrustmaster F16 MFDs; 2x 8'' LCD screens (VGA) for MFD display; 27'' LG LCD full HD main display

Link to comment
Share on other sites

Allright, let me explain my theory a bit:

 

In Windows, when calibrating the Saitek Pro Flight Combat pedals, the toe brakes are represented as X and Y axes. Windows understands these toe brakes like a traditional Joystick.

 

During Windows calibration, Windows asks the user to first leave the stick centered. Then it wants you to push the axes to their extremes. Last it again asks you to center the stick.

 

Now, toe brakes DON'T have a center position. They only go from one extreme point (completely released) to the other (completely pressed).

 

Normally, when calibrating the toe brakes, I would leave the toe brakes released when the utility asks me to 'center the stick'.

 

This would mean that Windows would register the 'center point' of the stick (in this case left and right toe brake) at the extreme point of an axis, rather than at its center.

Windows would still register the movement of the axes correctly, resulting in the Windows utility to properly display the pedals position.

 

 

Moving to DCS:

I'll make an assumption, that DCS software takes Windows calibration as something relevant.

Let's say, it sees that Saitek pedals' toe brakes are visible to DCS like a traditional joystick (where a stick can be centered), instead of like pedals.

Let's say that DCS software, in addition to the 'extreme points' of calibration, also reads the CENTER point of Windows calibration.

 

Since the center point of the toe brakes has been calibrated to be at an axis' extreme, and since DCS 'expects' the center point to be at an axis CENTER instead, the mixup occurs.

 

 

This COULD be the root of all evil, so to speak.

 

 

The real solution would be Saitek: they should release Windows drivers which would put the toe brakes to SLIDERS, instead of traditional joystick axes. Sliders don't have center points, only extremes.

 

 

When I originally purchased my Saitek pedals, there were no dedicated drivers, and the pedals were read by Windows like any USB joystick.

Now, it would appear that Saitek released both drivers AND software for these pedals.

http://www.saitek.com/uk/down/drivers.php

 

At home, I'll try and install the new drivers, see if they make a difference.

DCS A10C Warthog, DCS Black Shark 2, DCS P51D Mustang, DCS UH-1H Huey, DCS Mi-8MTV2 Magnificent Eight, Flaming Cliffs 3, Combined Arms

 

System: Intel i7 4770k @4,2GHz; MSI Z87-G65; 16GB DDR3 1600 MHz RAM; 128GB SSD SATA3 (system disk); 2TB HDD SATA3 (games disk); Sapphire Radeon R9 290 Tri-X; Windows 7 64bit

Flight controls: Thrustmaster HOTAS Warthog; Saitek Pro Flight Combat Rudder; TrackIR 5; Thrustmaster F16 MFDs; 2x 8'' LCD screens (VGA) for MFD display; 27'' LG LCD full HD main display

Link to comment
Share on other sites

When I originally purchased my Saitek pedals, there were no dedicated drivers, and the pedals were read by Windows like any USB joystick.

Now, it would appear that Saitek released both drivers AND software for these pedals.

http://www.saitek.com/uk/down/drivers.php

 

At home, I'll try and install the new drivers, see if they make a difference.

 

I bought my pedals almost 1½ years ago and installed the drivers and software available that time. I haven't updated them since. I'm not at my sim computer right now, so cannot tell the version of drivers.

Link to comment
Share on other sites

Hi Isthmail,

 

I noticed same issue as you have in #6, that the brake pedal input to DCS was staying a 50% when released. If releasing them quickly then once in a while I got them to go to full extremes.

 

I found that #27 on this thread worked for me after two attempts:

http://forums.eagle.ru/showthread.php?t=62025

 

My settings for brakes in the game is

Sat X= 100

Sat Y= 100

Deadzone= 10

Inverted = yes

Slider = yes

Curvature= 0

 

Driver version: Saitek 7.0.3.7

Software: not using Saitek software

  • Like 1
Link to comment
Share on other sites

HMA: thanks for that link! It worked, it appears. I now just have to be careful not to calibrate in Windows :)

DCS A10C Warthog, DCS Black Shark 2, DCS P51D Mustang, DCS UH-1H Huey, DCS Mi-8MTV2 Magnificent Eight, Flaming Cliffs 3, Combined Arms

 

System: Intel i7 4770k @4,2GHz; MSI Z87-G65; 16GB DDR3 1600 MHz RAM; 128GB SSD SATA3 (system disk); 2TB HDD SATA3 (games disk); Sapphire Radeon R9 290 Tri-X; Windows 7 64bit

Flight controls: Thrustmaster HOTAS Warthog; Saitek Pro Flight Combat Rudder; TrackIR 5; Thrustmaster F16 MFDs; 2x 8'' LCD screens (VGA) for MFD display; 27'' LG LCD full HD main display

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...