Jump to content

New Drivers for G940!


Haukka81
 Share

Recommended Posts

http://www.logitech.com/en-roeu/411/5855?section=downloads&bit=%2C32&osid=14

 

Release Notes:

 

  • Mouse clicks can now be assigned to a device button correctly
  • Added support to allow more than one mouse assignment commands to be played at a time
  • Software should now install correctly in some unicode Windows
  • User can now turn off panel lights for G940 in custom game control panel
  • Support G940 ministick manual calibration
  • Better support for G940 resume from suspend

 

 

 

 

:thumbup:

 

 

-haukka81

Oculus CV1, Odyssey, Pimax 5k+ (i5 8400, 24gb ddr4 3000mhz, 1080Ti OC )

 

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Well, looks like i somehow missed these, because my previous drivers vere 5.09 and now i have 5.10s but those are from 2010 ?? Quite old but new to me :D

 

 

-haukka81

Oculus CV1, Odyssey, Pimax 5k+ (i5 8400, 24gb ddr4 3000mhz, 1080Ti OC )

 

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

I knew better. Having recently been to their site and discovering that they have buried the pages for the G940 let me know they are done with the product.

ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

any one tried these new drivers?

 

im still using the G940's got no problems using them with the drivers i got now

[sIGPIC]http://forums.eagle.ru/signaturepics/sigpic90574_1.gif[/sIGPIC]

Australasian Gaming Community

 

Specs: Intel Quad 2.4GHz -- Geforce GTX 560 Duo -- SSD HDD -- 8Gb Mem -- 23" led -- 17"touch -- Logitech G940 Flight System --JoyLocs-- TIR 5 -- Cougar MFD'S -- Helios -

Link to comment
Share on other sites

At least my G940 has dust bunnies to keep it company...nothing to see here , move along :P

[sIGPIC][/sIGPIC]

 

System Specs

 

Intel I7-3930K, Asrock EXTREME9, EVGA TITAN, Mushkin Chronos SSD, 16GB G.SKILL Ripjaws Z series 2133, TM Warthog and MFD's, Saitek Proflight Combat pedals, TrackIR 5 + TrackClip PRO, Windows 7 x64, 3-Asus VS2248H-P monitors, Thermaltake Level 10 GT, Obutto cockpit

 

Link to comment
Share on other sites

  • 1 month later...

Thanks for post, i missed it too! mine still works good as I need it to. Its not a bad setup and many people still use it and works good enough for them.


Edited by emenance

Asus P8Z68-V GEN3/ 2500k 4.4ghz / Corsair 64gb SSD Cache / Corsair 8g 1600 ddr3 / 2 x 320gb RE3 Raid 0 /Corsair 950w/ Zotac 560TI AMP 1gb / Zalman GS1200 case /G940/

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...