Jump to content

Surprise Attack


Exorcet
 Share

Recommended Posts

I'm trying to create a surprise attack in DCS World. The goal is for the player to fly the A-10 over an enemy base without the enemy reacting. The player then opens fire, which causes the base to become active.

 

I'm doing this with Group AI On/Off and the player score. Group AI is off until the player score > 0, at which point it switches to on.

 

I've managed to make it work for stationary objects like watch towers, but not for vehicles, which seem to activate normally despite their AI being off in the ME, or the Late Activation box being checked. AAA vehicles will fire on me as soon as they see me.

 

One thing I haven't tried is setting the alarm state which might actually be better because as is, the AI wouldn't activate if the player opened fire and missed. However even if that works, it sounds like a bug might be involved with the above, so I'm reporting it anyway. Also, I want the vehicles to remain still until they realize that they are under attack. I don't think alarm state will simulate that.

[sIGPIC]http://i280.photobucket.com/albums/kk187/Exorcet/F-15singaturebaseACOmodifiedcomp-1.jpg[/sIGPIC]

Win 10 i5-9600KF 4.6 GHz 64 GB RAM RTX2080Ti 11GB -- Win 7 64 i5-6600K 3.6 GHz 32 GB RAM GTX970 4GB -- A-10C, F-5E, Su-27, F-15C, F-14B, F-16C missions in User Files

Link to comment
Share on other sites

Sounds like you are doing something wrong. If you have correctly turned AI off they will not fire or react to you.

 

What trigger are you using to turn AI off?

 

Id suggest: Mission Start > Random 100% > AI off.

i5-3570K @ 4.5 Ghz, Asus P8Z77-V, 8 GB DDR3, 1.5GB GTX 480 (EVGA, superclocked), SSD, 2 x 1680x1050, x-fi extreme music.



TM Warthog, Saitek combat pro pedals, TrackIR 4

Link to comment
Share on other sites

I'm trying to create a surprise attack in DCS World. The goal is for the player to fly the A-10 over an enemy base without the enemy reacting. The player then opens fire, which causes the base to become active.

 

I'm doing this with Group AI On/Off and the player score. Group AI is off until the player score > 0, at which point it switches to on.

 

I've managed to make it work for stationary objects like watch towers, but not for vehicles, which seem to activate normally despite their AI being off in the ME, or the Late Activation box being checked. AAA vehicles will fire on me as soon as they see me.

 

One thing I haven't tried is setting the alarm state which might actually be better because as is, the AI wouldn't activate if the player opened fire and missed. However even if that works, it sounds like a bug might be involved with the above, so I'm reporting it anyway. Also, I want the vehicles to remain still until they realize that they are under attack. I don't think alarm state will simulate that.

 

nice idea, If you manage to create the mission as mentioned above, maybe you wanna share it with us?

Would fly it with the Toad though ... :D

CPU: Intel I5-2400 @ 3,1GHz

RAM: 28GB Corsair XMS DDR3

GPU: Gainward Geforce GTX 1060 6GB

Win 7 - 64 Pro

Mad Catz Saitek Cyborg V.1

/ Track IR5

 

Running DCS 2.5 on dedicated Sandisk 240GB SSD

Modules: FC3/CA/Gazelle/P51/F5/FA-18C/A4-Community Mod

Link to comment
Share on other sites

Sounds like you are doing something wrong. If you have correctly turned AI off they will not fire or react to you.

 

What trigger are you using to turn AI off?

 

Id suggest: Mission Start > Random 100% > AI off.

 

I was using Mission Start > Time greater than 1 > AI off.

 

I will try random though.

 

EDIT - Random did not work.

 

nice idea, If you manage to create the mission as mentioned above, maybe you wanna share it with us?

Would fly it with the Toad though ... :D

 

Sure, although maybe I'll make some changes before that as I have the base on the edge of the map so that it looks a bit more like a desert. The TAD doesn't display any detail when zoomed in, and there is a rather strange cliff above an infinite flat plane just south of the base. I might have to move things a bit further north so that it doesn't kill immersion for others.


Edited by Exorcet

[sIGPIC]http://i280.photobucket.com/albums/kk187/Exorcet/F-15singaturebaseACOmodifiedcomp-1.jpg[/sIGPIC]

Win 10 i5-9600KF 4.6 GHz 64 GB RAM RTX2080Ti 11GB -- Win 7 64 i5-6600K 3.6 GHz 32 GB RAM GTX970 4GB -- A-10C, F-5E, Su-27, F-15C, F-14B, F-16C missions in User Files

Link to comment
Share on other sites

Mission Start is only evaluated exactly at the start of the mission which is "time 0." Change it to Once> Time greater than 1 > AI Off and it will work.

The right man in the wrong place makes all the difference in the world.

Current Projects: Scripting Wiki, Something...

Useful Links: Mission Scripting Tools MIST-(GitHub) MIST-(Thread), SLMOD, IADScript, Mission Editing Wiki!, Mission Building Forum

Link to comment
Share on other sites

Mission Start is only evaluated exactly at the start of the mission which is "time 0." Change it to Once> Time greater than 1 > AI Off and it will work.

 

Thanks, that did it. Though now I'm curious as to why Mission Start > Random 100% did not work.

[sIGPIC]http://i280.photobucket.com/albums/kk187/Exorcet/F-15singaturebaseACOmodifiedcomp-1.jpg[/sIGPIC]

Win 10 i5-9600KF 4.6 GHz 64 GB RAM RTX2080Ti 11GB -- Win 7 64 i5-6600K 3.6 GHz 32 GB RAM GTX970 4GB -- A-10C, F-5E, Su-27, F-15C, F-14B, F-16C missions in User Files

Link to comment
Share on other sites

AI Off might be an action that simply won't work with mission start triggers because the AI might need to be "alive" for time in game in order for commands like that to be received.

The right man in the wrong place makes all the difference in the world.

Current Projects: Scripting Wiki, Something...

Useful Links: Mission Scripting Tools MIST-(GitHub) MIST-(Thread), SLMOD, IADScript, Mission Editing Wiki!, Mission Building Forum

Link to comment
Share on other sites

  • 2 weeks later...
AI Off might be an action that simply won't work with mission start triggers because the AI might need to be "alive" for time in game in order for commands like that to be received.

 

Exactly.

 

AI needs to be active for a bit before it can be turned off.

 

I once did a mistake where I activated a group and turned off their AI in the SAME TRiGGER and the AI never deactivated. So what I did was wait 3 seconds and then turn off their AI, it worked fine. :)

[sIGPIC][/sIGPIC]

System specs:

2500k @ 4.6 GHz

8GB RAM

HD7950 OC'd

Win7 x64

 

Posting tracks to make your DCS better - attention bump incoming!

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...