Jump to content

How to activate and install?


Stuntie
 Share

Recommended Posts

I have Lock on installed from CD.

It's the Ubisoft CD. No key or anything.

Registration takes you to the Ubi site only.

 

FC3 installer says I need Lock on 1 or FC1 or 2 to install.

Which I have.

But does not recognise it.

No readme or instructions or anything. Nothing to say how I get the old Lock on registered with ED.

 

How do I get FC3 to recognise it and install?

Do I need to install all the FC1 and FC2 files one after the other first?

A ball ache to download and re-install if they just get ignored and or overwritten for FC3.

And a real problem for anyone with just the Lock On CD.

Cheers

Stuntie

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Installed FC2 (had bought it when it came out - but cue hassle of re-downloading the files for this PC)

Updated DCS World (needed but not mentioned - so cue annoyed wait for another large download...)

and then it finally allowed me to install FC3.

 

Launched and ran fine.

But promptly got shot down in minutes as couldn't find where half the controls were mapped to on the Warthog HOTAS before being pounched upon. oh well! least it works now....

 

Concerned though that others with just the Lock On CD will be shafted if it can not detect it automatically. Will they be forced to buy and install FC2 as well to get it to work?

ED/DCS - any install and activation advice for the CD users?

Cheers

Stuntie

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

I am having a similar problem. I purchased LOMAC from Ubisoft via the link on the FC3 page. I downloaded and installed LOMAC, I can run LOMAC just fine. However, when I try to install the DCS Module (FC3_release_en_1.2.2.7122_19.exe), it tells me that Lock On: Modern Air Combat must be installed.

 

Now, the problem may be that I am having difficulty registering LOMAC, because the registration program built into the game keeps telling me that it can't find FMV4Installer.msi, but since LOMAC itself is installed and is playing and fully functional, I don't think that's the problem.

 

I can run DCS: World and was able to install the update for A-10C. I can try downloading and installing the update for CA as well, but I suspect that should work too. Now, when I run DCS: World it says that there's an update available and do I want to download it, but I thought it made more sense to install the modules (since they're all the same version) and then do the update, otherwise the downloaded modules and DCS: World version would be different.

 

Sad part? I'm a computer programmer, I should know this stuff. I swear, staring at code all day must be rotting my brain or something. Since other people can presumably get this to work, I must be doing something wrong.

 

 

Edited to add: I ran the update for DCS: World, it barely took any time to download, so must have been minor. Still getting the same message when I try to run the FC3 module installer.


Edited by Hyperion35
Link to comment
Share on other sites

i had the same problems.

 

But if you have installed LockON (from CD) and FC2 (http://lockon.co.uk/index.php?scr=product&ProductId=6&end_pos=135) into the default folder, FC3 installation software identified your installation!


Edited by mwd2

Playing: DCS: Mi-24 Hind, and AH 64D Apache

Intel i5-7600K @4.1GHz, 32GB DDR4 @2400MHz, GTX 1070 Gigabyte Gaming OC 8GB DDR5, WIN 10 64Bit Prof.

Squadron "Serious Uglies" / Discord-Server: https://discord.gg/2WccwBh

Ghost0815

Link to comment
Share on other sites

Tried that. I bought the downloaded version like Hyperion35. I ran the DCS update and it downloaded and installed with no problems. Even jumped online when my friend tried to buzz me in a mig-29 but got too close and clipped me. The online version downloads into ubisoft/eagledynamics I think.

Link to comment
Share on other sites

I'm having a similar issue. I purchased LOMAC from one of the links provided on the DCS webpage.

 

- Installed it in a non-default directory.

- Received "LOMAC etc must be installed and activated" when running FC3 beta installer

- Reinstalled LOMAC in default directory

- Received same installer error

 

Definitely frustrating to have to purchase an old game to play the latest version but I understand the legal issues that Eagle Dynamics is dealing with.

 

What isn't acceptable is having to do that and it not working properly. This should be a no brainer. Can a dev step in and explain a solution that works? Unacceptable to be charging people for a game that doesn't work when properly installed.

Link to comment
Share on other sites

Yeah, mine is sort-of installed in a non-default directory. It's technically in Program Files (x86\UbiSoft\Eagle Dynamics, but it's on E:\ drive instead of C:\ drive for complicated reasons involving how my drive is partitioned. DCS is installed on the same drive, though, in E:\Program Files\Eagle Dynamics\DCS, though, so I don't think that's the problem.

 

However, when I checked my registry, I found registry entries for DCS and for the DCS modules that are installed, but couldn't find a registry entry for LOMAC. Perhaps that is the source of the problem? LOMAC installs and runs properly, and I tried uninstalling and reinstalling it. Still no registry entry, or at least not anywhere obvious like under UbiSoft or Eagle Dynamics, and FC3 still refuses to even install the module.

Link to comment
Share on other sites

Hell, it might help if we even knew how it searches. Is it looking at the registry? Is it looking solely in C:\Program Files\Ubisoft\Eagle Dynamics? Is it looking for some other hook that the CD version installs but the digital download version doesn't? For that matter, the digital download version does seem to copy what look like the CD files to a temp folder (at least, it includes an autorun.exe) during the installation. If I had any blank CDs with me, I'd try burning those files to disk and seeing if that helps.

 

Finally, it doesn't seem like the digital download version contains any sort of DRM. It doesn't ask for a CD key (and the email didn't include one), and the registration appears to be optional. Perhaps FC3 is looking specifically for some sort of DRM that was included in the earlier disc version of LOMAC that is no longer included in the digital download version from Ubisoft?

Link to comment
Share on other sites

Finally, it doesn't seem like the digital download version contains any sort of DRM. It doesn't ask for a CD key (and the email didn't include one), and the registration appears to be optional. Perhaps FC3 is looking specifically for some sort of DRM that was included in the earlier disc version of LOMAC that is no longer included in the digital download version from Ubisoft?

 

As confirmed previously, LOMAC/LOACS, digital or disc, does not contain any form of DRM whatsoever.

Novice or Veteran looking for an alternative MP career?

Click me to commence your Journey of Pillage and Plunder!

[sIGPIC][/sIGPIC]

'....And when I get to Heaven, to St Peter I will tell....

One more Soldier reporting Sir, I've served my time in Hell......'

Link to comment
Share on other sites

I've tried re-installing LOMAC several times, as well as re-downloading the FC3 module. This time I'm trying to re-download the FC3 module from the HTTP link instead of via torrent. The previous times I'd downloaded FC3 from the torrent link because it was faster. Maybe that version is screwy? If my <expletive> internet service actually remains connected long enough for the download to complete, I'll let you know if that works.

Link to comment
Share on other sites

This time I'm trying to re-download the FC3 module from the HTTP link instead of via torrent....

 

Remember to verify the files with the MD5 values provided just to make 100% sure the download is OK.

Novice or Veteran looking for an alternative MP career?

Click me to commence your Journey of Pillage and Plunder!

[sIGPIC][/sIGPIC]

'....And when I get to Heaven, to St Peter I will tell....

One more Soldier reporting Sir, I've served my time in Hell......'

Link to comment
Share on other sites

I've tried re-installing LOMAC several times, as well as re-downloading the FC3 module. This time I'm trying to re-download the FC3 module from the HTTP link instead of via torrent. The previous times I'd downloaded FC3 from the torrent link because it was faster. Maybe that version is screwy? If my <expletive> internet service actually remains connected long enough for the download to complete, I'll let you know if that works.

I have downloaded the module from both the US and German links.... No joy. Tried running the install as administrator, still no joy.

Link to comment
Share on other sites

I have downloaded the module from both the US and German links.... No joy. Tried running the install as administrator, still no joy.

 

I have also tried every thing I can think of, no Joy for me :cry:

 

No response from the ticket I opened also.

 

I am patient. They will get it handled. I sure its going to be epic when I can get it installed.

 

Key:thumbup:

[sIGPIC][/sIGPIC]

Intel i7-7700K 4.5 Ghz AMD Vega 56 64GB DDR4 3200 500 GB WD Black NVME M.2 X4 SSD

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...