Jump to content

Saitek Pedal Toes


wepper
 Share

Recommended Posts

Hi, there.

I have a little problem using my Saitek Pedal Toes for braking.

It seems that tey are working fine, but once used the brakes do not release.

Is there someone knowing this and may help me?

Link to comment
Share on other sites

When you set up you controls, did you go to Axis Tune and check the invert box for each toe brake axis?

 

 

Btw, welcome to the forum.

ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

Yup, you have to Invert the toe brakes on Saitek pedals. I have the Pro Combat Flight pedals and had the same thing. Quick fix inverting them in Controls settings.

DCS A10C Warthog, DCS Black Shark 2, DCS P51D Mustang, DCS UH-1H Huey, DCS Mi-8MTV2 Magnificent Eight, Flaming Cliffs 3, Combined Arms

 

System: Intel i7 4770k @4,2GHz; MSI Z87-G65; 16GB DDR3 1600 MHz RAM; 128GB SSD SATA3 (system disk); 2TB HDD SATA3 (games disk); Sapphire Radeon R9 290 Tri-X; Windows 7 64bit

Flight controls: Thrustmaster HOTAS Warthog; Saitek Pro Flight Combat Rudder; TrackIR 5; Thrustmaster F16 MFDs; 2x 8'' LCD screens (VGA) for MFD display; 27'' LG LCD full HD main display

Link to comment
Share on other sites

Hello, cichlidfan.

Thanks for anwering. The inverted axes were the first I did think of too.

As I normally fly the MSFS I know this and I already inverted them.

In the control options the axes are looking good.

I have no idea what it could be.:helpsmilie:

Link to comment
Share on other sites

Have you checked for controls conflicts as well?

ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

I forgot about that one but, in my case, they never stick completely they just don't release 100% sometimes. In the A-10 I never noticed it to be a significant issue.

ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...