Jump to content

Black Shark 2 Problem


Recommended Posts



Back in the day, I used to play black shark quite regurarly. Always installed using the old black shark 1 download, then used the black shark 2 thingy ontop of that.


However I've had a break from DCS for a while and recently came back to toy around with the UH-1H etc.


I tried to reinstall my BS2. Downloaded the standalone version of it, since my key says its NOT the upgraded version of the key, and it installs fine. (under international full key)


But then surfaces the problem, whenever I try to join any game, single player, missions, multiplayer I cannot enter the KA-50 cockpit. It always shows other planes etc. Other modules work just fine, all of them.


I've started to think that it might be an activation issue, but I tried to clean my reg, downloaded the module and reinstalled it numerous times, but to no avail.


I've used reg cleaners, and tips from other posts I found. Nothing worked just yet. Do I have to download the old black shark 1? If so where can I do this, as I don't see it under modules any more?


Anyone have any ideas? Been looking all day for a fix.









64bit windows 7


AMD 4x

Link to comment
Share on other sites

Not sure, as I used to play it when we needed black shark 1, I guess it would be the upgraded one. However during the installation I tried selecting the upgrade international but it said I needed black shark 1 installed.




Just downloaded the old version of black shark 1 and installed it. Tried to install BS2 under upgrade but still didnt find it. Also when I browse the E-shop on the main website it says I dont have a key for the upgraded one, but do for the stand alone version of BS2. I am completely hopeless now.. Reinstalled DCS World, all the modules as well this morning to no avail. Just wont let me in the cockpit during missions in a KA-50 slot, whether its multiplayer or not.




- Some things I realised is that whenever I run the repair option it downloads 1.8mb updates. Always.

- Whenever I reinstall the module it automaticly fills in my key, even if I clean the registry for the bs2 key.


I think the problem is somewhere in the activation, since I do not get the thingy to manually activate bs2 at any time.




Error log when I try to activate or deactivate BS2 by the MI8 executable in the bin folder.






I had the same problem, but with BS2 upgrade, i fixed it by doing the following.


Go Start>Run, type in regedit>HKEY_CURRENT_USER>Software>Eagle Dynamics>Black Shark 2>Keys


Here you will find a Licenses entry or multiple license entries, delete all of them, after that go and start DCS run Ka-50 so the registration thing pops up, and enter your key again.


you can also goEagle Dynamics\DCS World\Mods\aircrafts\Ka-50\bin


and run the protect.exe to start the DRM program, then do what it asks you to do.


Tried this, both ways, didnt work. Still cannot enter cockpit, also checked my F1 keybind, its all in place.




Tried several things I found on other posts, nothing worked, activation tries left to 3. Losing my mind now.. uninstalled every module, every trace of DCS world and the modules and reinstalled, still cant get inside the KA-50 cockpit. I also think it does not even spawn when I press fly, when cycling F2.




Trying something radical, deleting mods/ka-50 and replacing it with an old version and letting the repair function update it. Might work.




Doesn't work. Tried uninstalling instruction videos, didn't work. In my module manager it says ''KA-50 Black Shark'' not black shark 2, is this correct or?




Currently installing the game on steam, since it has a different activation system it might work out.




Installed steam version, works fine. No idea what the problem is with the website version.

Edited by blackburnn
Link to comment
Share on other sites

If Steam version of BS2 works, then it was not upgrade version. "Upgrade" keys do not work on Steam.


So the reason it didn't work on the DCS World from us is most likely that you selected Upgrade key. :)


For reference, you can check the type of key through selecting "Orders" on the website while logged in, it will say "Upgrade" if you have Upgrade.


As Skate said; Steam version uses exactly the same system.


Daniel "EtherealN" Agorander | Даниэль "эфирныйн" Агорандер

Intel i7 2600K @ 4.4GHz, ASUS Sabertooth P67, 8GB Corsair Vengeance @ 1600MHz, ASUS GTX 560Ti DirectCU II 1GB, Samsung 830series 512GB SSD, Corsair AX850w, two BENQ screens and TM HOTAS Warthog

DCS: A-10C Warthog FAQ | DCS: P-51D FAQ | Remember to read the Forum Rules |

| Life of a Game Tester
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...