Jump to content

MMjoy


Sokol1_br

Recommended Posts

I did just notice your screenshot had a newer version...guess I will try that since nothing else has worked. Didn't even realize my version was so old.

Sim Rig: Intel i7 9700k, SSD, GTX1660Ti, 32 GB DDR4, Windows 10

HOTAS: TM Warthog, MFG Crosswind Pedals, Opentrack - DIY HeadTracker

IRL: Private Pilot - IFR, Part 107 Drone Pilot

Link to comment
Share on other sites

I looked at github and am only getting the 2015 version. Can you help with a link to the newer version?

 

I believe I found it...

 

 


Edited by Panda_DCS

Sim Rig: Intel i7 9700k, SSD, GTX1660Ti, 32 GB DDR4, Windows 10

HOTAS: TM Warthog, MFG Crosswind Pedals, Opentrack - DIY HeadTracker

IRL: Private Pilot - IFR, Part 107 Drone Pilot

Link to comment
Share on other sites

Thanks! I found the download on the 1st page of this thread and now it works...I appreciate your time and responses!

Sim Rig: Intel i7 9700k, SSD, GTX1660Ti, 32 GB DDR4, Windows 10

HOTAS: TM Warthog, MFG Crosswind Pedals, Opentrack - DIY HeadTracker

IRL: Private Pilot - IFR, Part 107 Drone Pilot

Link to comment
Share on other sites

4 hours ago, crash test pilot said:

recommended by sokol, who wrote this program

Just to clarify- with all my huge respect to Sokol1_br, who is doing a lot for the community, MMJoy2 was written by a different person. It's Mega_Mozg, who is now a chief software designer at Virpil Controls. 

Link to comment
Share on other sites

36 minutes ago, Sergey_Pe said:

Just to clarify- with all my huge respect to Sokol1_br, who is doing a lot for the community, MMJoy2 was written by a different person. It's Mega_Mozg, who is now a chief software designer at Virpil Controls. 

Now i feel really stupid, because i wrote so and deleted it because the thread about mmjoy here and in simhq was started by sokol... me<---double idiot

Link to comment
Share on other sites

1 hour ago, crash test pilot said:

Now i feel really stupid, because i wrote so and deleted it because the thread about mmjoy here and in simhq was started by sokol... me<---double idiot

😀😀😀 Sokol is keeping an eye on everything interesting and useful coming up in simulation area. And he is always eager to share his findings which is great!

  • Like 1
Link to comment
Share on other sites

9 hours ago, crash test pilot said:

maybe you could upgrade to 20160818 (recommended by sokol, who wrote this program). 

 

Oops, my only contribution for MMJoy2 was English translation of some early versions and spread the project in every sim forum I know (an half dozen). 😉

 

MMJoy2 firmware author is MegaMOZG, based on previous Mindaugas (2004) MMjoy-8/16.  MegaMOZG now work for VirPil as electronic developer.

 

 

 

  • Like 2
Link to comment
Share on other sites

I want to use 7 axes on my joystick for steering wheel, brake, accelerator pedal and 2 analog joystick. Is it possibble? I can use 3 of them with x,y and z axes, but i could find to entegrate other 2 axes for my analog joystick. How can i do that?

 

if it is not possible, can you guys explain me how can i use "axis to button" section with details?


Edited by degrave
Link to comment
Share on other sites

  • 1 month later...

Hi, Sorry If I disturbe this topic, but I would like to ask some help for my MMJOY2  problem. If it is not the right plaece please send me PM or give me a link . (I asked this the another forums, simHQ and il2sturmovik.ru)

https://ibb.co/N7CCKFj

I have a Chinese version of the MMJOY  with shield.

https://ibb.co/85Xsxdz

And this is in life:

https://ibb.co/vL3Pv7c

I coloured the pins where I put the wires ,same colour  same wire.  So my problem is that I use one of the shift register in my FLCS joystick handle grip. I connected those buttons  like the pic show. red wire is the common GND and the others are the individual buttons.  When I connected to the PC and set up in the MMJOY program (see above) the shift register is 74hc165 (i'm not sure about that because I can't see on the chip) and 3 chip the CS and DATA pins are D0 and D1. But the 4021B set up is no working .  And when I want to test the buttons they only work in the top of the 2 sockets on the shift register ( on the pics are circled). If I put  other buttons there, they also work, but just in  those sockets.  I don't know what could be the problem if  all of the buttons are working and the program is also recognise it, except the rest of the 4 sockets . I have only one strange  thing, If I connected the shield to the PC  without the shift register just alone then there are some buttons (from 17 to 24)which are flickering in the program .  These buttons are recognised and work from the shift register also. So from 17 to 24 buttons are in the top of the shift register  2 sockets.

 

If we can solve this problem I would like to convert my FLCS/TQS. And I want to use this set up:

https://ibb.co/p2kjmNV

https://ibb.co/HDc5bTp

https://ibb.co/3NwzgQX

https://ibb.co/kJq0Bp1

 

But I don't know how should connect to the arduino pro micro  these device. Which wires can I put together  like the VCC and the GND.  could The TLE5010's  6 pins of 5 be the common with the others? And can I use 4 TLE5010 and 6 other  normal potmeter in the same time on only one pro micro?

As you can see  on the schematic, I would like to put the pro micro inside the TQS base, and the all others wires could be collected from others to there. 

Can somebody to check it and give me some advice to it? Or any other info about that how can I reach my goal that there be a workable  HOTAS. other  board or other program .

Thank you. 

Link to comment
Share on other sites

  • 1 month later...
3 hours ago, slowmover said:

I have a problem with arduino pro micro. I have destroyed many of them because the usb port on the arduino is very sensetive and brakes. Any solution how to avoid that?

 

 

An "add-hoc" solution, with available materials:

 

MMJoy2-USB-cable-support.jpg

 

 

- USB cable is secure.

- Have space for put fixing screws for the assembly.

 

Can use a small breadboard piece.


Edited by Sokol1_br
Link to comment
Share on other sites

  • 3 weeks later...

Hi, i made this and i face a problem i cannot fix. 

(looks like internal config of mmjoy is not "correct" - eeprom pb ? ) 

 

When i test all the buttons they work as expected. 

but, when i launch VKB button tester some are lit. (as if they were configured as button inverted) 

If i "short" the  74 it shows pysically up , but reported down. 

if i short the 75 it "works" but   on/off very fast (some ms ) even if i keep the button pressed.  

 

If i change the config of timer1 , it lights the button 37 !! 

Timer 2 add another button ..  etc.. 

 

Looks really like the config memory if overflowing somewhere and informations are "misread" to translate and report button physical status to windows. 

 

Any idea welcome. 

 

Edit: Tested 20160818 upd1, tried with the firmware after exactly same behavior. 

 

Edit : Tested with another Arduino not connected to my board. The behavior looks the same... 

 

 

physical-vs-reported.png

IMG_3516.jpg


Edited by Cerppo
Add some info testing on another board
Link to comment
Share on other sites

  • 4 weeks later...

As i got no solutions to the MMJOY "bug" , i started to write new code based on Arduino Joystick 2  to drive my board. 

Works perfectly for the 96 buttons. still need some lines of code to read MCP3208 Axis Values.  ( learned a lot doing this 😉 ) 

 

I also should have looked to Freejoy ... which i discovered recently. 

Link to comment
Share on other sites

Okay here is one that's been pulling my hair out.

I have some buttons (40, 50, 49, 36 42) connected via a shift register (CD4021) that in the mmjoy2 interface work perfectly fine, but then in VKB joytester these buttons working extremely intermittently, like if I spam them very rapidly they will fire, but just toggling them on I get nothing.

I guess it's a software issue? Using Version 20160818 Is it a bugged setup?


Edited by TomVR
Link to comment
Share on other sites

6 hours ago, TomVR said:

Is it a bugged setup?

No it's not.

6 hours ago, TomVR said:

mmjoy2 interface work perfectly fine, but then in VKB joytester these buttons working extremely intermittently

How did you define these buttons in MMJoy configurator- as "Button (norm)"?

Link to comment
Share on other sites

6 hours ago, Sergey_Pe said:

No it's not.

How did you define these buttons in MMJoy configurator- as "Button (norm)"?


The only things I have a special configuration are a few toggle switches much further up in the button set and encoders.

The buttons having issues are just normal buttons (And can't be set as custom functions anyway as they are beyond 32) I've attached the setup file.

 

MMJOY2ISSUES.PNG

f18quad_20210418.mmjoy f18quad_20210418.mmjoy_HID_txt

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...