Jump to content

Mission 06: AI wingmen do not always start


Redglyph
 Share

Recommended Posts

DCS 1.5.5.60565.216

 

Mission 06 suffers from the same DCS bug as mission 9 of the Mirage 2000C campaign, the flight will not start if the mission is run immediately after launching DCS.

 

If you play any other mission of track file before, then there are good chances the mission will start correctly.

 

I have included a track file to expose this problem in this campaign, but I'm not sure people can play it without the licence. If the flight does not light the taxi headlights at about 23h26'39", it won't start at all. It will remain grounded - to be honest I haven't taken off to check this out, given the bug is obviously there.

 

Other missions could also suffer from this bug, I have no idea what triggers this but it looks like an uninitialized entity in the DCS code. Hopefully with two track files ED will be able to deter it more easily.

 

 

Temporary work-around: play a few seconds of the track file (or run anything, really) before starting the mission. Sometimes it doesn't work but it's rare.

 

EDIT I realize I'm using a fix for the A-10C cockpit mouse clicks. I don't think it will impact the track replay, hopefully the mouse clicks are not recorded but the changes in cockpit argument values are (or even further down the chain). If the track does look funny, let me know :D

OPF_mission06.ko.trk


Edited by Redglyph

System specs: Win7 x64 | CPU: i7-4770K | RAM: 16 GB | GPU: GTX 980 Ti 6 GB | Thrustmaster HOTAS | MFG rudder pedals | SATA3 SSD | TrackIR

Link to comment
Share on other sites

Yeah, it's hit or miss with getting AI to start, I have sent an email to the dev team to review this bug. Tried multiple solutions some work once and then I retry and they don't work. Thanks for reporting.

 

Sent from my SAMSUNG-SM-N910A using Tapatalk

Link to comment
Share on other sites

I've finally created a thread here, with a link to the two missions I've spotted so far, if I see other ones I'll add them to the list. Hopefully that'll help pinpoint the problem. In the case of the other mission, blocked AI is not even in the same group, and there is no condition, nothing special for this AI group, it should simply start right away. It shouldn't be too hard to find, just requires some time and digging with a good debugger.

System specs: Win7 x64 | CPU: i7-4770K | RAM: 16 GB | GPU: GTX 980 Ti 6 GB | Thrustmaster HOTAS | MFG rudder pedals | SATA3 SSD | TrackIR

Link to comment
Share on other sites

Yeah, it's hit or miss with getting AI to start, I have sent an email to the dev team to review this bug. Tried multiple solutions some work once and then I retry and they don't work. Thanks for reporting.

 

Sent from my SAMSUNG-SM-N910A using Tapatalk

 

Yeah, I can't make mission 07 start, I've tried different things but no luck so far. The re-do trick is not working in this case.

 

ATC is very slow to respond for the start-up, and then it doesn't respond anymore (only once I proceed to taxiing, taking off and so on). So if the AI depends on that, which seems to be the case, it's a problem.

 

I had the same in the Red Flag missions, some aircraft would just remain grounded and ATC wouldn't respond.

System specs: Win7 x64 | CPU: i7-4770K | RAM: 16 GB | GPU: GTX 980 Ti 6 GB | Thrustmaster HOTAS | MFG rudder pedals | SATA3 SSD | TrackIR

Link to comment
Share on other sites

Apparently, it seems to work if I wait until the first dialogue is finished, then call ATC and request start-up. The response is immediate. The wingmen don't light their headlights though, that's disturbing but not a bad omen ;)

System specs: Win7 x64 | CPU: i7-4770K | RAM: 16 GB | GPU: GTX 980 Ti 6 GB | Thrustmaster HOTAS | MFG rudder pedals | SATA3 SSD | TrackIR

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...