Jump to content

FFB Trim mode is always on by default


Recommended Posts

Issue: It seems that Force Feedback Trim is always enabled at the start of a mission, which causes the trim function to behave strangely on most (non-FFB) desktop joysticks; When in that (default) mode, moving the stick disconnects the stick from the trim, but keeps the trimmed position the same (with no effect), until a SAU autopilot mode is turned on. Turning FFB mode off via the hotkey (default RAlt+RShift+J) makes trim work as expected for the rest of the mission, with the stick position always acting relative to the trim.


Game version: OB


Repro steps:

1. make sure you're using a joystick without force feeback (mine is a VKB Gladiator NXT) and that axes and trim bindings are set up correctly

2. start any mission (instant action free flight works) and open the control overlay (RCtrl+Enter)

3. without moving the joystick, use the trim buttons to trim the plane until it flies at a certain attitude

4. note that both the stick position and trim indicator in the overlay move together

5. move the joystick a bit and then re-center it physically, notice that the trim indicator stays in place but the stick position indicator returns to center (and the plane behaves as if in neutral trim)

6. press SAU recovery key and notice that the stick jumps onto the last trimmed position and immediately jerks in that direction

7. restart mission, and disable FFB trim with RAlt+RShift+J

8. do the same steps above and notice that the stick now rests on the trimmed position instead of returning to the center, and SAU recovery no longer "jumps" to that position (as the plane will already be flying with that amount of trim beforehand)


Additional notes: IMO, default FFB trim state should be set via the plane's special settings, as most people don't have a FFB stick, but those who do probably want it to be turned on at the start of every mission, instead of requiring a key combo to enable it.


Attached images are examples of what should be seen immediately after steps steps 2, 3, and 5 (the joystick is physically centered in the second and third images)


[Track file coming soon]




Edited by kukiric
Link to comment
Share on other sites

[Track file contained in attachments]


It is hard to see the issue from the control indicator overlay, but here's a rundown of the track:


In the first part of the replay, the plane is trimmed through the pitch trimmer, with no stick movement, and then the external joystick is moved slightly back and reset, which causes the stick position indicator to go to absolute 0 at rest, while the trim stays slight off-center. Following that, the plane flies as if there is no trim applied.


In the second part of the replay, the plane is "over-trimmed" by holding down the trim switch while the joystick is deliberately held off-center, up until about 50% total trim, and then SAU recovery is enabled, causing the plane to jerk back to the trimmed position. Afterwards, the sequence is repeated, but with max trim, which causes a more violent jerk when SAU recovery is turned on.


This is how I would expect the trim to work on a joystick with FFB, as it would physically hold itself in the trimmed position when released. However, many players may not know that is a thing, and they might not realize that the trim can be adjusted for a non-FFB stick by using RAlt+RShift+J at the start of every flight! This oddity definitely confused me until I was able to troubleshoot it, and the trim works as expected after RAlt+RShift+J (not demonstrated in the track).



Link to comment
Share on other sites

UPDATE: this is a case of PEBKAC, it seems vJoy causes a conflict in the module and fully unbinding it within DCS fixes the issue. Simply not starting any program that uses vJoy for sending inputs does not work, it needs to be fully unbound in the in-game controls menu.

Edited by kukiric
Link to comment
Share on other sites


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...