Jump to content

BS2 crashing !!!


Recommended Posts

Anyone had this situation?


BS1 bought and installed via Steam - plays 100% fine

BS2 upgrade bought and downloaded/installed direct from DCS - crashes when you try to load any mission/training - basically when you try and load the main game. It just crashes with a Black Shark 2 has stopped working message and then returns you to the Debriefing screen...


Settings have been tried on defaults - no joy, customised - no joy... it just wont work.

I have tried the /3Gb switch, reinstalling the June 2010 DirectX etc etc... still nada...

Uninstalled, cleaned Windows and resintalled - nope!

Deleted saved game folders - nope.


Soooo frustrating!!! :cry:

Edited by cwbalmer
Link to comment
Share on other sites

Well bugger me!!


I just had a hunch.... unplugged my Saitek joystick... and it loads!!!


It doesn't like my joystick!!


If i get the game running now, then quit and plug the joystick in, the game crashes if i go into the options screens....


Time to look for an updated joystick driver perhaps....


I cant be the only one out there with a Saitek Cyborg Force using BS2 can i?

Link to comment
Share on other sites

What windows do you use?

I use a Saitek R440 racing wheel as rudderpedals, and in Win 7 64bit atleast the force feedback drivers from Saitek crashed the sim.

Only way to avoid crash were by doing as explained in this post


but then you will not have any force feedback.

Komplett Gamer: PSU 620W, MB MSI P67A-G45 B3, CPU IntelCore i5-2500 3.3GHz, RAM 4GB 1333MHz, GeForce GTX 560Ti 1GB, OS Windows 7 Home pro 64bit, Saitek X-52 HOTAS, Saitek R440 Racing Wheel for Rudder pedals.

Link to comment
Share on other sites

Same problem but mine is even stranger. I bought BS2 (retail version) upgraded it to and the Training and Mission missions just crashes when I try and play them. The strange thing is the Campaign missions work fine!!!

Unplugged my X-52 PRO to see if that affected it (it dosnt) and it did the same in


XP 32 Bit

Latest Nvidia drivers (260 GTX)

Link to comment
Share on other sites

Windows 7 enterprise 64 bit mate....


will try that registry edit...nope - no joy


I have completely removed the joystick from windows, and struggled to get the saitek drivers on as windows prefers to use its own which is a pain...

Edited by cwbalmer
Link to comment
Share on other sites

This is very likely to fix your problem, as long as you have a 64 bit processor. Win XP 32 bit is very dated these days, and will have all sorts of problems with all sorts of newer games.

Intelligent discourse can only begin with the honest admission of your own fallibility.

Member of the Virtual Tactical Air Group: http://vtacticalairgroup.com/

Lua scripts and mods:

MIssion Scripting Tools (Mist): http://forums.eagle.ru/showthread.php?t=98616

Slmod version 7.0 for DCS: World: http://forums.eagle.ru/showthread.php?t=80979

Now includes remote server administration tools for kicking, banning, loading missions, etc.

Link to comment
Share on other sites

  • 1 month later...

How did you force Windows to use the Saitek USB driver. I have X52pro.

Edited by chardly38



=&arrFilter_pf[gameversion]=&arrFilter_pf[filelang]=&arrFilter_pf[aircraft]=&arrFilter_CREATED_USER_NAME=chardly38&set_filter=Filter&set_filter=Y"]MY SKINS And Helios


i7 2600k 3.4 quad w/ Hyper N520 cpu fan_, Asus Sabertooth z77_, RX 580_, Corsair Vengeance 1800 8Gb ram_, 112 OCZ Vertex 3_, Corsair HX 1000, 3 screens res 5292x1050_,and 1 1680x1050 Helios Ir Tracker 5 with Pro Clip_,Hotas Warthog#12167 ...

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...