Jump to content

DCS-A10C Activation Error


Recommended Posts



Just bought DCS A10C to play inside DCS World.

When I start DCS World, goto modules->installed modules and click "view serial" I can see the same serial number as written on my "purchases" page on the DCS website.


However, whenever I try to start a game, I'm shown the A-10C activation application.

I enter the exact serial number as shown in game or on the website (I've copied+pasted... tried without the hashes.. all caps.. all lowercase.. etc) but whenever I click "Next", I Get the following:



The system requires the correct serial number of the application to perform this operation. The serial number entered is wrong or mistyped. Enter a valid serial number and try again.



I've also tried doing the "other" activation and going to that proactive.star-force.com site... I paste in the key and the hardware code.

However, here I'm told:


Invalid hardware code. Make sure the serial number used is valid for the product you are trying to activate, generate a new hardware code and try again.



Not exactly sure how to generate a new hardware code...

and getting quite annoyed by this whole process


Also - waited a couple of days for a reply to a ticket on this and got nowhere :/


ANY advice would be lovely..

But, tbh, if I get nowhere by the end of the week, I'll be asking for a refund via PayPal :(

Link to comment
Share on other sites

Well.. I solved this myself.


Looking in the registry (HKEY_CURRENT_USERS\Software\Eagle Dynamics\Warthog\Keys)

I saw eight subfolders named "License0" to "License7".

Inside each of these was a set of various keys, all of which were blank.


I deleted ALL of the "LicenseN" folders and restarted DCS World as "Administrator"


(running windows 7 Ult 64 with UAC turned off, so didn't initially think of this as a possible issue)


This time, in the activation window, it said my key was valid and authenticated perfectly.

Looking back in the registry now, there is just one "License0" folder and the keys inside it are all filled in appropriately.

Link to comment
Share on other sites


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...