Jump to content

Help HOTAS not working in DCS World for any Sim


Recommended Posts

I just got a Thrustmaster HOTAS, my Christmas gift to myself. Updated DCS World. But the joystick and throttle don't function in any of the sims. Have several and have tried it in A-10, FC, UH-1 and BS2

 

So, I then verified the stick is completely functional. First by testing it in TARGET software, checking each button. Then ran the Falcon AF script. Works fine in Falcon AF.

 

Then I tested it in DCS Black Shark outside of DCS World. Works fine. So then I reverted to update 1.2.7. Still not functional. During this whole process, right after the update, I couldn't get DCS World to start. So read through Forum and found someone with a similar issue where the correction after update was to remove Factory.lua file. Did that and DCS World worked fine.

 

I figure knowing the stick works, I must be doing (or have done) something I'm easily overlooking. Maybe moving that file? I can see the Thrustmaster in my Devices and also as the axis controller in the Options screen in DCS. I just get no function from either device in the Sim. Any ideas?

 

Tom

Link to comment
Share on other sites

How are you testing the function in the game?

Have you tried mapping the buttons in the settings (under the correct section)?


Edited by Yellonet

i7-2600k@4GHz, 8GB, R9 280X 3GB, SSD, HOTAS WH, Pro Flight Combat Pedals, TIR5

Link to comment
Share on other sites

Try deleting your Saved Games\DCS\Config\Input folder. This will reset the DCS control configurations to default, in case those files got corrupted somehow.

ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

As for testing the functions, first I'm just looking for the joystick to work for X/Y axis and it doesn't. So no control at all. I am just trying instant action and have made sure the HOTAS is there in the controller options in the game.

 

I don't seem to have a Saved Games folder. I assume it is off the main folder for DCS World? Haven't located it yet if there is one. I didn't choose a different destination when I installed the game.

Link to comment
Share on other sites

Your Saved Games folder is located in C:\Users\*yourloginhere*

ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

No Dice. Still no control. I unplugged the Throttle to see if I had axis control with the joystick, but there is none. No keyboard control either. And as I have been doing, verified that the Throttle and Joystick were in the control panel on the options screen before starting. Also confirmed the axis control was set for the joystick. Nothing, no response.

Link to comment
Share on other sites

Fixed! Found this in another topic several pages in...

 

 

Originally Posted by lanna26 View Post

Guys, I contacted DCS support, and they solved my issue (imputs not responding, only esc key works).

 

For anyone ho's facing this issue: Go on instalation folder (either "Eagle Dynamics/DCS World" for convencional version, or "SteamApps/common/DCSWorld/" for Steam version) look for Scripts/Input, and delete Input.lua file. I recommend to backup this file first, in case removing it doesn't work.

Link to comment
Share on other sites

Whoever heard of fixing a problem by just deleting files? I fixed two in two days by this method!

 

Can anyone direct me on how I can get my original login here on the forums able to post? I have only been on the site to purchase in the past, never posted, and have been away for over a year before getting my HOTAS!

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...