Jump to content

I fixed a weird interaction between DCS, quest 2 and my CPU (3900x) that has ruined my performance since 2.7


Recommended Posts

So I've been having the worst time with 2.7 until about an hour ago.

My cpu frametime has been at a minimum of 20ms, though it used to be at 9-10ms. If I disabled ASW, my quest wasn't going above 36fps and my GPU was stuck at 50-60%, so CPU bottleneck right? Well, if I paused DCS, my cpu frametime jumped down to 9ms again, so i t was only happening while the sim was running, almost like a half rate vsync or something, except vsync was off in both DCS and globally in the nvidia control panel.

So this has been driving me crazy for ages. I haven't been able to use SRS or viacom because any cpu stutter results in dropped frames and activating the export.lua would cause constant stutter. So I booted up fullscreen and noticed that my fps was actually half my monitor's refresh rate in the main menu, weird. After googling this, I found a reddit post from last year where someone said to delete the "maxfps =180" line in the DCS main config folder in the graphics.lua file. So now on flatscreen my fps was over 2000 on the main menu (lol). I also noticed that ovrserver.exe is defaulted to vysnc = on in nvidia control panel which I also changed to off (though I had tried this before with no effect).

My cpu frametime is back down to 9ms and my ASW works without any stutter again with my GPU operating at 95%+. So long as my computer isn't gaslighting me until the next shutdown, I could literally not be more relieved.

  • Like 3
Link to comment
Share on other sites

Wow good that you found the issue.. do you think this is AMD specific..

ASRock Z590 Phantom Gaming 4-AC / Intel i7 11700K @ 5.0Ghz / Noctua DHS-14 Heatsinkw/Fan /  Samsung 980 Pro M.2 NVME 2TB  /  eVGA FTW3 2080Ti /  RipJaws - 64GB RAM @3200  /  SoundBlaster Z  / Reverb G2 VR /  ThrustMaster HOTAS Cougar  / Buttkicker Gamer 2

Link to comment
Share on other sites

12 hours ago, Lorenzo.D said:

What Is ovrservice.exe?


Inviato dal mio motorola one macro utilizzando Tapatalk
 

 

Typo there, should have said ovrserver_64.exe, it's the oculus runtime executable. Not sure how relevant that part is, but I don't see why it would default to vsync on for a VR service. The maxfps thing has solved all of my DCS problems though. Just played for an hour on Syria at War MP server without any performance problem, locked at 36 reprojected the full time. 

12 hours ago, The_Nephilim said:

Wow good that you found the issue.. do you think this is AMD specific..

 

I have no idea frankly, I don't see why it would be, I just put that in the title in case it's relevant, but ultimately why the maxfps = 180 line capped my cpu frametime is a mystery to me. 

  • Like 1
Link to comment
Share on other sites

I use your fix i removed maxfps=180 and Yesterday i flown in multiplayer with ka50 at 36 FPS.(not in supercarrier that i have Always bad FPS) but i think all was much smootmoother
On the Oculus program i can t see noting reguatds on vsync. Can you explane Better?
Yesterday i also go to Nvidia panel setting e put the parameters Like in this video

I also use oculus tray tool with a in game specific application dedicated to dcs(not general parameters) with specific asw off e GPU scaling off.
Anyway 36 Is 72hz / 2 so where i can found the vsync in Oculus service for try other fix? Thanks


Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...