Jump to content

Collective stick help!


Recommended Posts

Im sorry, but I'm having a seriously annoying problem with the collective stick. This was happening to me when I first got the game, and learned to finally get the heli started, but when I press the num+ nothing would happen... THe blade would not pitch or rotate so I could take off.. I tried everything and nothing seemed to work.. So in confusement I went through and watched the 2 take off tutorails and he took off just fine and when I finished the second tutorial and took control, that button magically worked.. It worked fine there on out, until last night, when I tried the quick mission and I got shot down. I recovered, and not that stupid button wont work again.. I cant take off because of it at all. Whats weird is its trying to work, I can watch the needle on the guage sometimes bounce up and down like it wasnt to pitch the blades, but its like its stuck on 0 pitch most of the time. Its seriously getting on my nerves and hopefully someone can help me out.

Link to comment
Share on other sites


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...