Jump to content

HELP :-) - Multiplayer connection issues

Go to solution Solved by Stonkernz,

Recommended Posts

Hello everyone. 
Me and two of my friends has just joined the community (really really really excited about it) 

We have the game up and running - flying the F-18, but we are having trouble connecting to servers in multiplayer. 

There are no problems in single player/training modes. 

When i try to join a server on the server browser,  it loads for about 0.5 seconds, and then it jumps back to the server browser. When i try to connect to almost all the servers i can see, SOMETIMES it actually joins a server, but that's 1/20 tries.

I can even create a mission, create a server - which my friends can find in the server browser, but they cant join. When we press "join server" it loads for about 0.5 seconds, and then it jumps back to the server browser. No joining, no loading - nothing. Nothing seems to work. 

Sometimes we get the "Callsign already taken" message - and after a restart of the game, we are back to 0.5 seconds of loading and then nothing. 

I have already tried: 
Reinstalling game
Checking firewall settings
Verifying game files in Steam.

I really hope some of you maybe have some ideas/inputs or maybe similar problems.

Thank you in advance 🙂

Link to comment
Share on other sites



We can now all play together - without any problems. I cant even begin to express how stupid i feel. Thank you so much for a quick reply! 
Impressive that after 3 hours of googling i have found nothing 🙂 

Once again, thank you!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...