Jump to content

Strange freezing in DCS BS


Recommended Posts



Recently after many years of using Windows XP I’ve decided to switch to Windows 7. I was quite satisfied with XP, but have heard that 7 is pulling better performances with DCS BS, so I decided to change it.

After installation (of course DCS BS was the first thing to try), I loaded a mission (known airport, helicopter is already started, same game settings as before), there I am in the cockpit (game still paused), hit “RCtrl + Pause Break” – WOW!!! If I had 25fps with XP, now I have 40. GREAT!!!


OK, let’s try it! I hit “Pause Break”, nothing happens. ?????

After 11 seconds of total freezing, game starts. Hmmmm, OK... I pull the collective, helicopter is in stable hover, I press Trimmer button on my stick – freeze again, now for 2 seconds. After the freeze FPSs are back to normal (actually quite high for my machine) 35-50.

So the first time I press most of the buttons (ONLY the first time for each button!!!) like trimmer, master arm, release flares, ABRIS button, F2 view…. Game freezes for 1 or 2 seconds, and then continues to run smoothly with high FPSs. Every second press of the individual button doesn’t affect FPS.


The other thing I’ve noticed that the freezing is especially long after first time unpausing, and when there is damage made to my helicopter. Then the freezing is longer than 10 seconds.

I have tried to burn half of a village, fire and smoke everywhere, it affected only general FPS, but no freezing.


I’ve reduced game settings to minimum, but despite that general FPS are higher, the freezing is still there.


I did search the forums, but didn’t find some similar complaints. Any idea what could it be? Any help is appreciated.


Oh, I almost forgot – I have AMD Athlon Dual Core 5800+, 3GB RAM and ATI Radeon 3650 (no over cloaking).


LOFC2 is running completely smooth, without such problems.




Link to comment
Share on other sites

igormk, if you could start here please: TROUBLESHOOTING - Help us help you.

I think a full DxDiag report would be in place.



- Just for the sake of it, try use some other missions - and SP vs MP.

Some mission have been troubled for some users earlier, not that I remember which missions it was. So just try a variation.


- Win 7 and drivers. It's essential that you have Chipset + Sata drivers up & running from your vendor. Otherwise you will experience just the things you experience right now.


Let start here and have a look at your DxDiag next.

And dont be afraid to have a read at the rest of the posts, there may be other things that applies to you there. :)

  • Like 1

The mind is like a parachute. It only works when it's open | The important thing is not to stop questioning

Link to comment
Share on other sites

Windows 7 does not make all cores run. Windows 7 (and Vista) cannot turn a single-thread process into a multithread one. What it can do is use Dx10/11 drivers which gives some advantages, as well as do load balancing on the CPU (basically hopping the process to whichever core happens to be least used).


igormk, your description of the problem leads me to suspect your sound/hdd drivers - it sounds like you are affected when new sounds need to be loaded from memory. On second use of a given command the sound file will already be in memory and thereby there will be no effect.


Could you furnish a DxDiag file, guidelines in the sticky about troubleshooting?


EDIT: Okey. That's it Panzer. You and me, outside. This sniping has to stop! :P

  • Like 2


Daniel "EtherealN" Agorander | Даниэль "эфирныйн" Агорандер

Intel i7 2600K @ 4.4GHz, ASUS Sabertooth P67, 8GB Corsair Vengeance @ 1600MHz, ASUS GTX 560Ti DirectCU II 1GB, Samsung 830series 512GB SSD, Corsair AX850w, two BENQ screens and TM HOTAS Warthog

DCS: A-10C Warthog FAQ | DCS: P-51D FAQ | Remember to read the Forum Rules |

| Life of a Game Tester
Link to comment
Share on other sites

Problem solved!!!


You guys are amazing, thank you!!!!!!

It was something with the sound drivers. I had to uninstall SoundMax driver, and now everything is smooth, no more freezing. I would never guess!



And Panzertard, I did read the other posts and used “search” function! :)

Just that I forgot to look in Sticky section… I always miss one or two things to do… :glare:

So, I promise, in the future I will look in Sticky section before asking questions. ;)


Thanks again!!!




Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...