Jump to content

Payment Error?


VincentLaw
 Share

Recommended Posts

I bought the MiG-21 through SagePay on the 12th. It accepted all of my info, said it was paid, and gave me a key. Today I was looking at my bank account online and noticed that there is no record of the transaction, not even as a pending transaction.

 

Did something break, did I mess something up, or is it normal to take a few days to show up in my bank account? Most stuff shows up almost instantly on there.

 

edit update to avoid bumping: The payment finally showed up last night. I guess it just took a while for some reason.


Edited by VincentLaw

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Are you sure you paid?

You can go through with orders without actually paying in the ED store but I'm not sure if you can access your key until you have paid.

 

Does the key work though? Maybe you've got the key but it doesn't work until a payment has been done.

 

A payment should show up as pending the very moment you make it.

 

Sounds like a support issue:

http://forums.eagle.ru/showthread.php?t=124718

Link to comment
Share on other sites

I am sure the key works. The key was functional when ED received it from StarForce.

ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...